Works: Solucionando Problema do Erro do Installer 2735

ID do artigo: 281716 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi publicado anteriormente em BR281716
Expandir tudo | Recolher tudo

Nesta página

Sintomas

Ao tentar instalar qualquer um dos programas mencionados no começo deste artigo, você receberá uma das seguintes mensagens de erro:
Erro do Installer 2735: Ação personalizada interrompida prematuramente.
-ou-
Erro do Installer 2735: Instalação interrompida prematuramente.
-ou-
Erro do Installer 2735: Shoebox.dll.

Causa

Esse comportamento pode ocorrer se alguma das seguintes condições for verdadeira:
  • O CD está sujo.
  • Um arquivo do Microsoft Windows está faltando ou está danificado.
  • O arquivo Shoebox.dll está danificado.
  • Um componente de suporte, como DCOM, MDAC ou Microsoft Internet Explorer não está instalado corretamente.

Resolução

Para resolver esse problema, use os seguintes métodos na ordem em que aparecem.

Limpe o CD

Verifique se o CD está limpo. Caso não esteja, limpe-o, mas tenha cuidado para não riscar a superfície dele.

Use o Verificador de Arquivos do Sistema

Se você usa o Microsoft Windows 98, use a ferramenta Verificador de Arquivos do Sistema para localizar e restaurar os arquivos danificados ou que estão faltando.

Para usar o Verificador de Arquivos do Sistema, siga estes passos:
  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite sfc e clique em OK.
  3. Marque a caixa de seleção Procurar arquivos alterados.
  4. Para verificar arquivos alterados ou excluídos, clique em Configurações e marque as seguintes caixas de seleção:
    • Verificar arquivos alterados
    • Verificar arquivos excluídos
  5. Clique em OK.
  6. Clique em Iniciar.
Nota Você pode ser solicitado a inserir o CD-ROM do Windows na unidade de CD-ROM. Se você não tiver o CD-ROM do Windows 98, entre em contato com o fabricante do computador para verificar como restaurar arquivos.

Teste para verificar se o problema foi resolvido. Se o problema persistir, vá para o próximo método.

Remover Pastas e Componentes do Registro

Remova os componentes principais do registro do Works fazendo o download do utilitário adequado ao seu sistema operacional e executando-o.

Windows 95, Windows 98 e Windows Millennium Edition (Me)

O seguinte arquivo está disponível para download no Centro de Download da Microsoft:
Recolher esta imagemExpandir esta imagem
public/PT-BR/Download.gif
http://download.microsoft.com/download/works60/Utility/1/WinMe/EN-US/wks6.exe
Windows 2000

O seguinte arquivo está disponível para download no Centro de Download da Microsoft:
Recolher esta imagemExpandir esta imagem
public/PT-BR/Download.gif
http://download.microsoft.com/download/works60/Utility/1/NT5/EN-US/wks6w2k.exe
Para obter informações adicionais sobre como fazer o download de arquivos de Suporte da Microsoft, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
119591 Como Obter Arquivos de Suporte da Microsoft nos Serviços On-line
A Microsoft verificou esse arquivo em busca de vírus. A Microsoft utilizou o software de detecção de vírus mais recente disponível na data em que o arquivo foi publicado. O arquivo está armazenado em servidores de segurança avançada que ajudam a evitar qualquer alteração não-autorizada no arquivo.

Para executar esses arquivos, siga estes passos:
  1. Salve o arquivo na sua área de trabalho.
  2. Clique duas vezes no arquivo e siga os prompts.

Fazer a Inicialização Limpa do Computador

Para executar uma inicialização limpa do seu computador, siga os passos voltados à sua versão do Windows.

Microsoft Windows XP

  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite msconfig e clique em OK.
  3. Clique na guia Geral, clique em Inicialização seletiva e desmarque as seguintes caixas de seleção:
    • Processar o arquivo System.ini
    • Processar o arquivo Win.ini
    • Carregar itens da inicialização
  4. Clique na guia Serviços, marque a caixa de seleção Ocultar todos os serviços Microsoft e clique em Desativar tudo.
  5. Clique em OK, e em Reiniciar para reiniciar o computador .

Microsoft Windows Millennium Edition (Me)

  1. Clique em Iniciar, em Executar, digite msconfig na caixa Abrir e clique em OK.
  2. Na guia Geral, clique em Inicialização seletiva.
  3. Desmarque todas as caixas de seleção em Inicialização seletiva.
  4. Na guia Inicialização, selecione a caixa de seleção *StateMgr.
  5. Clique em OK.

    Quando solicitado a reiniciar o computador, clique em Sim . Após o computador reiniciar, clique em Iniciar, em Executar, digite msconfig na caixa Abrir e clique em OK.

    Importante Verifique atentamente a guia Geral para se certificar de que as caixas de seleção desmarcadas ainda estejam desmarcadas. Vá para o passo 6 se nenhuma das caixas de seleção estiver marcada. Se você vir uma caixa de seleção cinza ou desabilitada, seu computador não estará realmente com "inicialização limpa" e você poderá necessitar de assistência do fabricante do programa que coloca uma marca de seleção em Msconfig.
  6. Após verificar se seu computador está com inicialização limpa no passo 5, será possível isolar o problema. Se o problema original não reincidir após a inicialização limpa, selecione um item de cada vez em Inicialização seletiva e, em seguida, reinicie o computador para ver se a entrada adicional reproduz o problema original.

Microsoft Windows 98

  1. Clique em Iniciar e em Executar.
  2. Na caixa Abrir, digite msconfig e clique em OK.
  3. Na guia Geral, clique em Inicialização seletiva e desmarque as seguintes caixas de seleção:
    • Processar o Arquivo Config.sys
    • Processar o Arquivo Autoexec.bat
    • Processar o arquivo Winstart.bat (caso esteja disponível)
    • Carregar Itens do Grupo de Inicialização:
  4. Na guia Win.ini, desmarque as seguintes caixas de seleção:
    • Load=
  5. Clique em OK. Quando solicitado a reiniciar o computador, faça isso.
Para obter informações adicionais sobre como fazer uma inicialização limpa no Windows 98, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
192926 Como Executar a Solução de Problemas com Inicialização Rápida para Windows 98
Nota Para restaurar as opções originais de Inicialização, clique em Inicialização normal na guia Geral na ferramenta Utilitário de Configuração do Sistema.

Microsoft Windows 95

  1. Reinicie o computador.

    Quando você vir a mensagem "Iniciando o Windows 95", pressione a tecla F8 e escolha Somente Prompt de Comando no menu Iniciar.
  2. No prompt do comando, digite win e pressione ENTER.

    Mantenha a tecla SHIFT pressionada até a seqüência de inicialização do Windows terminar.
  3. Desative os programas de antivírus ou de disco instalados no computador.

    Para obter mais informações sobre como desativar esses programas, consulte a sua documentação impressa ou on-line.
  4. Feche todos os programas em execução, exceto o Explorer e o Systray.

    Para fazer isso, pressione CTRL+ALT+DELETE, clique no programa que deseja fechar e clique em Finalizar tarefa. Se receber uma mensagem mencionando que o programa está ocupado ou não está respondendo, clique em Finalizar tarefa novamente. Repita esse passo para fechar todos os programas, exceto Explorer e Systray.
Para obter informações adicionais sobre como fazer uma inicialização limpa no Windows 95, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
177604 Multimídia: Solucionando Problemas com a Inicialização Limpa do Windows 95
Nota Para restaurar as opções de Inicialização originais, reinicie o computador normalmente e ative os programas antivírus ou de disco instalados no computador. Para obter mais informações sobre como ativar esses programas, consulte a sua documentação impressa ou on-line.

Instalar DCOM para Windows 95 (Windows 95 Apenas)

Se quiser instalar um dos programas mencionados no começo deste artigo em um computador com Windows 95, instale a versão mais recente de DCOM para Windows 95 (Dcom95.exe) do CD-ROM do Works ou CD-ROM Disco 4 do Works Suite.

Se quiser instalar um dos programas mencionados no começo deste artigo em um computador com IWindows NT 4.0, Windows 98, Windows Millennium Edition (Me) ou Windows 2000, vá para o método "Instalar MDAC no Modo de Segurança".

Para instalar a versão mais recente de DCOM para Windows 95 (Dcom95.exe) do CD-ROM do Works ou do CD-ROM Disco 4 do Works Suite, siga estes passos:
  1. Insira o CD do Works ou o Disco 4 do Works Suite na unidade de CD.

    Mantenha pressionada a tecla SHIFT assim que você inserir o CD-ROM para evitar que a Instalação do Works seja iniciada automaticamente.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir, digite a linha equivalente à sua versão do Works e clique em OK

    Works:

    cd-rom:\redist\ie5\dcom95.exe

    Works Suite:

    cd-rom:\mhp\redist\ie5\dcom95.exe

    em que cd-rom é a letra da unidade de CD-ROM.
  4. Siga as instruções na tela para instalar o DCOM95 para a atualização do Windows 95.

Instalar MDAC

Para instalar MDAC no Modo de Segurança, use o método apropriado para sua versão do Microsoft Windows.

Windows NT 4.0

Se quiser instalar um dos programas mencionados no começo deste artigo em um computador com Windows NT 4.0, faça o download e instale a versão mais recente da utilização de MDAC a partir do seguinte site da Microsoft na Web:
http://msdn.microsoft.com/dataaccess
Para informações adicionais sobre como fazer o download de arquivos do Centro de Download da Microsoft, clique no link Como usar o Centro de Download da Microsoft no seguinte site do Centro de Download da Microsoft na Web:
http://www.microsoft.com/downloads/search.asp

Windows 95, Windows 98, Windows Me ou Windows 2000

Para instalar MDAC no Modo de Segurança, siga esses passos:
  1. Insira o CD do Works ou o Disco 1 do Works Suite na unidade de CD. Mantenha pressionada a tecla SHIFT assim que você inserir o CD-ROM para evitar que a Instalação do Works seja iniciada automaticamente.
  2. Clique em Iniciar aponte para Pesquisar e clique em Arquivos ou Pastas.
  3. Na caixa Nome, digite mdac_typ.exe.
  4. Na caixa Examinar, clique na unidade de CD e clique em Localizar agora.
  5. Na lista de arquivos encontrados, clique com o botão direito no arquivo Mdac_typ.exe e clique em Copiar.
  6. Clique com o botão direito do mouse numa área vazia da área de trabalho do Windows e clique em Colar.
  7. Feche a janela Localizar: Arquivos com o nome mdac_typ.exe.
  8. Reinicie seu computador no modo de Segurança. Para fazer isso, use o método apropriado para a sua versão do Microsoft Windows.

    Microsoft Windows 98:

    Reinicie o computador, mantenha pressionada a tecla CTRL após o computador concluir o Power On Self Test (POST) e escolha o Modo de Segurança no menu Iniciar.

    Microsoft Windows 95:

    Reinicie o computador. Ao ver a mensagem "Iniciando Windows 95", pressione a tecla F8 e escolha Modo de Segurança no menu Iniciar.
  9. Quando o Windows iniciar no Modo de Segurança, clique em OK.
  10. Na área de trabalho do Windows, clique duas vezes no arquivo Mdac_typ.exe e siga as instruções na tela para instalar a atualização de MDAC.
  11. Reinicie o computador no modo normal.
Nota se você não puder instalar MDAC no Modo de Segurança, faça o download e instale a versão mais recente da atualização de MDAC do site da Microsoft na Web. Para fazer isso, consulte o método "Windows NT 4.0".

Reparar o Microsoft Internet Explorer

Para reparar a sua instalação do Internet Explorer, siga estes passos:

Nota Esse procedimento pode não funcionar em computadores com Windows XP:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. Clique duas vezes em Adicionar/remover programas.
  3. Clique duas vezes em versão do Microsoft Internet Explorer.
  4. Clique em Reparar a instalação atual do Internet Explorer e depois clique em OK.
Para obter informações adicionais sobre a ferramenta de Reparo do Internet Explorer, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
194177 Descrição da Ferramenta de Reparo do Internet Explorer
Se o problema persistir, vá para o próximo método.

Remover e Reinstalar o Internet Explorer no Windows 95, Windows 98 ou Windows Me

Se não puder reparar sua instalação do Internet Explorer, use os seguintes métodos na ordem em que aparecem.

Remover o Internet Explorer

Nota Você deve ter privilégios administrativos para instalar e desinstalar o Internet Explorer no Windows NT e Windows 2000. Isso inclui ter esses privilégios na primeira vez em que iniciar o computador após a instalação ou desinstalação do Internet Explorer.

Para remover o Internet Explorer, siga estes passos:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. Clique duas vezes em Adicionar/remover programas.
  3. Na guia Instalar/Desinstalar, clique em Microsoft Internet Explorer 5 e Ferramentas da Internet na lista de programas instalados e clique em Adicionar/Remover.

    Nota Se Microsoft Internet Explorer 5 e Ferramentas da Internet não estiverem na lista de programas instalados, execute Setup.exe a partir da pasta Internet Explorer\Setup. Se estiver executando o Windows 2000, execute o comando w2kexcp.exe /u a partir da pasta "Internet Explorer\IE Uninstall".
  4. Clique em Restaurar a configuração prévia do Windows e clique em OK.
  5. Na caixa de diálogo Internet Explorer 5 e Instalação das ferramentas da Internet, clique em OK para restaurar a versão anterior do Internet Explorer.
  6. Se for solicitado a verificar se deseja restaurar a versão anterior, clique em Sim.
  7. Quando solicitado a reiniciar o computador, faça isso.
Para obter informações adicionais, clique no número abaixo para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
243266 Uninstalling Internet Explorer 5.01 Removes Outlook Express

Reinstalar o Internet Explorer

Para reinstalar o Internet Explorer, siga estes passos:
  1. Insira o CD do Works ou o Disco 1 do Works Suite na unidade de CD.

    Mantenha pressionada a tecla SHIFT assim que você inserir o CD-ROM, para evitar que o CD-ROM seja iniciado automaticamente.
  2. Clique em Iniciar e em Executar.
  3. Na caixa Abrir, digite a linha equivalente à sua versão do Works e clique em OK

    Works:

    cd-rom:\redist\ie\ie5setup.exe

    Works Suite:

    cd-rom:\msword\ie5\en\ie5setup.exe

    em que cd-rom é a letra da unidade de CD-ROM.
  4. Siga as instruções na tela para instalar o Internet Explorer 5.
Se o problema persistir, vá para o próximo método.

Instalar Works ou Works Suite

Instale o Works ou o Works Suite.

Se o problema persistir, execute uma inicialização limpa do computador e instale o Works ou o Works Suite. Para mais informações sobre como fazer a inicialização limpa do computador, consulte o método "Instalar MDAC".

Mais Informações

Para obter informações adicionais, clique nos números abaixo para visualizar os artigos na Base de Dados de Conhecimento da Microsoft:
270592 Mensagem de Erro do Works 6: A Instalação Não Conseguiu Registrar Tarefas
247532 Works Err Msg: Installer Terminated Prematurely
248263 Works Suite: Error 1305 During Installation
218617 Como Solucionar Problemas Relacionados à Leitura de CD-ROM ou DVD-ROM
242323 "Erro Interno..." Mensagem de erro quando ao executar o programa de instalação
242913 Works/HP 2000: Erro 1324 Durante a Instalação
Para obter mais informações sobre como fazer uma inicialização limpa, clique nos números abaixo para visualizar os artigos na Base de Dados de Conhecimento da Microsoft:
310353 Como Executar uma Inicialização Limpa no Windows XP
281770 Como Executar a Solução de Problemas com Inicialização Rápida para Windows 2000
267288 Como Executar uma Inicialização Limpa no Windows Millennium Edition
Para informações adicionais, clique no número abaixo sobre como iniciar um computador Windows no modo de segurança para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
180902 Como Iniciar um Computador Baseado no Windows 98 no Modo de Segurança

Propriedades

ID do artigo: 281716 - Última revisão: sexta-feira, 13 de agosto de 2004 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Works 7.0 Standard Edition
  • Microsoft Works 6.0 Standard Edition
  • Microsoft Works Suite 2003 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2002 Standard Edition
Palavras-chave: 
kbdownload kbgraphxlinkcritical kbimu kbprb KB281716
Aviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.

Submeter comentários