OFFXP: Errors When You Install Office XP from the Command Line Using Setup.exe

Article translations Article translations
Article ID: 281934 - View products that this article applies to.
This article was previously published under Q281934
Expand all | Collapse all

SYMPTOMS

When you attempt to install Microsoft Office XP from the command line using Setup.exe, you receive one of the following error messages:
Creation of administrative installation images is supported only in Enterprise versions of Microsoft Office XP.
-or-
Quiet-mode installation is supported only in Enterprise versions of Microsoft Office XP.

CAUSE

The first error message can occur if you use the /a command-line switch with Setup.exe when you are installing a non-Enterprise (Retail) edition of Office.

Similarly, the second message can occur if you use the /qb command-line switch combination with Setup.exe when you are installing a non-Enterprise (Retail) edition of Office.

NOTE: If you use the /q switch without any additional switch options, the message does not appear. Instead, Office Setup.exe does not run, and there is no obvious reason why. The only indication that the /q switch is not allowed is the information in the Windows Installer log file for the Office installation.

RESOLUTION

If you want to use either the /a switch or the /q switch with Office XP, you need to obtain an Enterprise edition of Office.

For information about obtaining an Enterprise edition of Office XP, please browse to the following Microsoft Web site:
http://www.microsoft.com/licensing/Default.aspx

MORE INFORMATION

Use the /a switch when you want to run an administrative installation of Office.

Use the /q switch when you want to install Office in quiet mode. No user interface is displayed during Setup.

You can successfully use the /qr switch or the property Display=Reduced in the Setup.ini file with the non-Enterprise edition of Office XP.

Properties

Article ID: 281934 - Last Review: January 29, 2007 - Revision: 1.4
APPLIES TO
  • Microsoft Office XP (Setup)
Keywords: 
kbprb KB281934

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com