Sessões desconectadas retém a variável <clientname> original

Traduções deste artigo Traduções deste artigo
ID do artigo: 281981 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você se reconectar a um lo desconectado sessão em um computador diferente daquele em que você originalmente estabelecido a conexão, a variável clientname retém o nome do computador no qual você criaram a sessão original.

Causa

Esse problema ocorre porque quando você se reconectar a uma sessão desconectada, serviços de terminal não verifica se o computador cliente foi alterado.

Resolução

Windows XP informações sobre o hotfix

Um hotfix com suporte foi disponibilizada pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, envie uma solicitação para o Microsoft Online Services de cliente para obter o hotfix. Para enviar uma solicitação on-line para obter o hotfix, visite o seguinte site:
http://go.microsoft.com/?linkid=6294451
Observação Se ocorrerem problemas adicionais ou qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support

Pré-requisitos

Você deve ter o Windows XP Service Pack 2 instalado para aplicar esse hotfix.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com SP2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.1.2600.3501296,44826 De dezembro de 200813: 51x 86
Windows XP Com SP3, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.1.2600.5733296,44826 De dezembro de 200813: 45x 86

Informações sobre o hotfix Windows Server 2003

Um hotfix com suporte foi disponibilizada pela Microsoft. No entanto, destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde o próximo service pack do Windows Server 2003 que contém esse hotfix.

Para resolver esse problema imediatamente, contate o Atendimento cliente Microsoft para obter o hotfix. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Você deve ter o Windows Server 2003 instalado para aplicar esse hotfix.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Como habilitar o hotfix

Você precisa criar manualmente e configurar o UpdateClientNameOnReconnect entrada do registro no computador com Windows 2003 se o hotfix criar e configurar essa entrada do Registro não automaticamente. Para criar e configurar manualmente a entrada do Registro, execute essas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Localize a seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. No painel de detalhes, digite UpdateClientNameOnReconnect e, em seguida, pressione ENTER.
  5. Clique com o botão direito do mouse UpdateClientNameOnReconnect e, em seguida, clique em Modificar .
  6. Na caixa de diálogo Editar valor DWORD , em base , clique em hexadecimal .
  7. Na caixa dados do valor , digite 1 e, em seguida, clique em OK .
  8. Feche o Editor do Registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows Server 2003 com SP1, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2915246,78413 De abril de 200713: 46x 86
Windows Server 2003 com SP2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.4059246,78413 De abril de 200714: 00x 86
Windows Server 2003 com SP1, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2915365,05612 De abril de 200723: 28x 64
Windows Server 2003 com SP2, versões com base em 64 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.4059365,56812 De abril de 200723: 33x 64
Windows Server 2003 com SP1, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.2915698,88012 De abril de 200723: 28IA-64
Windows Server 2003 com SP2, versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
TERMSRV.dll5.2.3790.4059699,90412 De abril de 200723: 32IA-64

Como Contornar

Para resolver esse problema, faça logoff do Terminal Services sessão e log ligue-o para que você pode restabelecer a variável clientname do novo computador.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Programas ou scripts que dependem da variável clientname podem não funcionar se você estabelecer uma sessão em um computador, desconecte e se reconectem a essa sessão de um computador diferente.

Propriedades

ID do artigo: 281981 - Última revisão: terça-feira, 6 de janeiro de 2009 - Revisão: 5.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbmt kbprb kbtermserv KB281981 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 281981

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com