Article ID: 282057 - Last Review: January 15, 2006 - Revision: 1.2

Remote Assistance Session Is Terminated and Unexpected Behavior Occurs

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This article was previously published under Q282057
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SYMPTOMS

When you are using a computer that is running Microsoft Windows XP, if you run Helpctr.exe, and then send a request for assistance to a valid e-mail address, when the expert opens the request, takes control of your computer, and then leaves the computer unattended for one hour, the Remote Assistance connection is closed.

When the computers are brought out of the Sleep or Hibernate state, the tool on the expert's computer is displayed as a white screen and the expert cannot submit a new text message using the chat functionality. On your computer, the tool is displayed, but the Remote Assistance connection closes if you attempt to use it.

If you enable the On resume, password protect option under the Screen saver options on the server, the following behavior occurs:
  • The Welcome screen is displayed on the server.
  • A blank screen is displayed on the client.
  • No events are fired.
  • When you return to the active session, a blank screen is still displayed on the client.

CAUSE

This issue occurs because Terminal Services does not detect when the server comes out of the Hibernate state and reconnects to the client. The connection always comes from the client, and not from the server.

RESOLUTION

To work around this issue, establish a new connection.

STATUS

This behavior is by design.

APPLIES TO
  • Microsoft Windows XP Home Edition
Keywords: 
kbprb KB282057