O estado do índice de conteúdos permanece bloqueado na pesquisa numa base de dados do Exchange Server 2010

Número original da BDC: 2820817

Sintomas

Numa base de dados Microsoft Exchange Server 2010, o estado do Índice de Conteúdos é apresentado como "a pesquisar" e nunca parece atingir um estado de "bom estado de funcionamento". Além disso, apesar de o contador de desempenho Número de Documentos Indexados com Êxito mostrar um aumento progressivo no número de documentos indexados, o valor no contador Número de Caixas de Correio Restantes para Pesquisa não diminui conforme esperado.

Nesta situação, os seguintes eventos são registados no Registo de aplicações:

Time:
ID: 102
Level: Error
Source: MSExchange Search Indexer
Machine: Mailboxserver.contoso.com
Message: Exchange Search Indexer has failed to crawl the mailbox (8832ee80-47b8-4b0e-a98f-c4a239794707) in database (Database1) due to error: (Microsoft.Exchange.Search.MailboxCrawlFailedException: Failed to logon to mailbox). This mailbox will be retried later.
Time:
ID: 5617
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: CI troubleshooter exchange search service restart attempt 81.

Causa

Este problema ocorre quando o System Center Operations Manager está a executar o script Toubleshoot-CI.ps1. Isto faz com que o Exchange Serviço de pesquisa reinicie antes de concluir o processo de indexação.

Resolução

Para resolver este problema, impeça que o servidor do System Center Operations Manager execute o script Troubleshoot-CI.ps1 da seguinte forma:

  1. Abra o System Center Operations Manager.
  2. Clique emMonitorde Objetos> do Pacote de Gestão.
  3. Na caixa Procurar , escreva resolução de problemas e, em seguida, clique em Localizar Agora.
  4. Localize o item que corresponde a Troubleshoot-CI.ps1 script, clique com o botão direito do rato no mesmo e, em seguida, clique em Propriedades.
  5. No separador Substituir , clique em Substituir.
  6. Selecione a caixa de verificação Ativado , defina a opção Substituir valor como Falso e, em seguida, clique em OK.

Mais informações

Normalmente, o System Center Operations Manager executa o script Troubleshoot-CI.ps1 a cada duas horas. No entanto, se o script Troubleshoot-CI.ps1 detetar um dos seguintes sintomas, aciona um reinício do serviço de pesquisa do Exchange:

  • Impasse: impasses da Pesquisa do Exchange enquanto aguarda por threads do MSSearch.
  • Danos: um ou mais índices de pesquisa estão danificados.
  • Stall: assemelha-se a um impasse na medida em que os índices não são atualizados.
  • Registo de tarefas pendentes: o catálogo de Pesquisa tem um registo de tarefas pendentes, pelo que as pesquisas de índices agendadas não são executadas conforme esperado.

Eis um exemplo de um evento que é registado quando o script Troubleshoot-CI.ps1 é executado:

Time:
ID: 5611
Level: Error
Source: CI Troubleshooter
Machine: Mailboxserver.contoso.com
Message: Indexing backlog reached a critical limit of 48 hours or the number of items in the retry queue is greater than 10000 for one or more databases: Database1 (0, 12572, 0)Database1 (0, 31859, 0)

Se as bases de dados tiverem caixas de correio ou caixas de correio grandes com uma contagem elevada de itens, geralmente demora mais de duas horas a concluir o processo de indexação. Quando o serviço de pesquisa do Exchange é reiniciado, as caixas de correio são colocadas novamente na lista para reindexação. Nesta situação, o processo de pesquisa pode nunca ter a oportunidade de terminar.