Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Assume that you have database stored in Microsoft Azure SQL Database in a Windows Server 2012-based failover cluster environment. The cluster is under memory, network and disk pressure. In this situation, you cannot connect to the database because of Internet connection problems in Windows Azura SQL Database nodes.

Cause

This issue occurs because VMSwitch.sys waits for an object identifier (also known as OID) to respond. Additionally, network adapter resets every 8 seconds.

Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012. Additionally, all virtual machines (VMs) that run on the Windows Server 2012-based host must be updated with the latest Integration Services.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You have to restart the VMs on the host after you apply this hotfix. However, you do not have to restart the host computer.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.920 0.20 xxx

    Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Windows5.x-hypervintegrationservices-x64.msi

Not Applicable

1,712,128

07-Mar-2013

06:53

Not Applicable

Windows5.x-hypervintegrationservices-x64.xml

Not Applicable

130

06-Mar-2013

23:44

Not Applicable

Windows6.2-hypervintegrationservices-x64.cab

Not Applicable

671,879

07-Mar-2013

07:11

Not Applicable

Windows6.x-hypervintegrationservices-x64.cab

Not Applicable

678,700

07-Mar-2013

07:01

Not Applicable

Windows6.x-hypervintegrationservices-x64.xml

Not Applicable

167

06-Mar-2013

23:44

Not Applicable

Setup.exe

6.2.9200.20655

226,416

07-Mar-2013

06:24

x64



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about how to troubleshoot connection problems to Azure SQL Database, go to the following Microsoft knowledge base article:

2980233 Troubleshoot connection problems to Azure SQL DatabaseFor more information about how to update the latest integration services, go to the following Microsoft website:

General information about steps to update the latest integration services (Step 4) For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012

File name

Amd64_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.2.9200.20655_none_2ba1e1f02d1cbbff.manifest

File version

Not applicable

File size

3,165

Date (UTC)

07-Mar-2013

Time (UTC)

06:57

Platform

Not applicable

File name

Amd64_microsoft-hyper-v-g..aller-win6x-package_31bf3856ad364e35_6.2.9200.20655_none_2dd84c026b73ef70.manifest

File version

Not applicable

File size

4,261

Date (UTC)

07-Mar-2013

Time (UTC)

07:14

Platform

Not applicable

File name

Amd64_microsoft-hyper-v-guest-installer_31bf3856ad364e35_6.2.9200.20655_none_cb19b938c48b8d84.manifest

File version

Not applicable

File size

4,165

Date (UTC)

07-Mar-2013

Time (UTC)

07:00

Platform

Not applicable


Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×