Messaggio di errore "Impossibile caricare il profilo" quando si installa il software client di Systems Management Server

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importante : questo articolo contiene informazioni sulla modifica del Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986Descrizione del Registro di sistema di Microsoft Windows
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Sintomi

Quando si tenta di installare software di Systems Management Server (SMS) versione 2.0 del client, viene potrebbe essere visualizzato il seguente messaggio di errore:
Impossibile caricare il profilo, contattare l'amministratore.
Questo messaggio di errore viene visualizzato sullo schermo dopo l'utente corrente dispone di accesso al computer.

Cause

Questo comportamento può verificarsi se il profilo di "utente predefinito" è stato sostituito oppure con un profilo preconfigurato o è danneggiato. Questo comportamento può causare il software client SMS sia in grado di apportare le modifiche di protezione alla chiave di archiviazione protetta quando tenta di creare un nuovo profilo utente per uno degli account di software client SMS, l'account di $ SMSCliToknAcct.

Risoluzione

avviso : se si utilizza Editor del Registro di sistema in modo non corretto, si potrebbero provocare problemi gravi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce la che è possibile risolvere i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. Utilizzare Editor del Registro di sistema a proprio rischio.

Per aggirare questo comportamento, utilizzare uno dei tre metodi seguenti:
  • Ignorare gli errori sul client. Il profilo è in grado di caricare nonostante gli errori. Gli errori si verificano solo durante l'installazione del client SMS. La maggior parte dei computer segnalare questo problema solo una volta. Una volta completata l'installazione, il profilo viene caricato correttamente. Il client SMS anche viene eseguito correttamente. Tentativi di accesso successivi non segnalano l'errore di caricamento del profilo.
  • Per ciascun computer che presenta questo comportamento:
    1. Connettersi alla condivisione admin oppure accedere al computer interessato in locale.
    2. Caricare e modificare le autorizzazioni nel file Ntuser.dat "utente predefinito". Per eseguire questo passaggio, è necessario caricare il file Ntuser.dat come un hive del Registro di sistema:
      1. Avviare Regedt32.exe.
      2. Fare clic su nell'hive HKEY_LOCAL_MACHINE .
      3. Scegliere Carica Hive dal menu del Registro di sistema .
      4. Specificare il file Ntuser.dat nella cartella utente %Systemroot%\Profiles\Default sul computer interessato.
      5. Viene chiesto di specificare un "nome chiave". Il nome della chiave viene utilizzato per identificare l'hive che si sta caricando ed è una sottochiave di HKEY_LOCAL_MACHINE . Immettere un nome che non è già in uso.
      6. Individuare HKEY_LOCAL_MACHINE / Key Name nome/software/Microsoft/Protected Storage System Provider / Sid. L'identificatore di protezione (SID) è per l'utente che ha creato il profilo che era stato copiato l'utente predefinito (ad esempio, S-1-5-21-1234567890-1234567890-123456789-1001). Il SID è disponibile poiché non si dispone dell'autorizzazione di accesso questa chiave. Fare clic su questa chiave. Dal menu protezione , fare clic su autorizzazioni e quindi aggiungere il gruppo "Everyone" con accesso con controllo completo.
      7. Fare clic sul nome chiave. Nel menu Registro di sistema , fare clic su Scarica .
  • Consente di sostituire il file Ntuser.dat o il profilo utente intero per "utente predefinito" con una copia non modificata da un altro computer. Questo passaggio, è tuttavia sconsigliata perché può perdere il vantaggio di ottenere un profilo preconfigurato e predefinito in un nuovo utente.

Informazioni

Il profilo utente predefinito si trova nella cartella User %Systemroot%\Profiles\Default. Quando un nuovo utente si accede, il computer copia il profilo "utente predefinito" nella cartella di profilo utenti nuovo nella cartella di Username %Systemroot%\Profiles\. Impossibilità di modificare la protezione dell'archiviazione protetta chiave quando la preconfigurato profilo di (utente predefinito) viene utilizzato per creare un nuovo profilo per l'account di $ SMSCLiToknAcct.

La chiave del Registro di sistema si trova in:
HKEY_CURRENT_USER/software/Microsoft/Protected Storage System Provider / Sid
Nota : la chiave del Registro di sistema precedente è un percorso, la chiave può è stato suddiviso su per migliorare la leggibilità.

Per verificare questo comportamento, attivare la registrazione di userenv come descritto nel seguente articolo:
154120Debugging User Profiles and System Policies in Windows NT 4.0
L'output dalla registrazione può essere simile a quello riportato di seguito:
C:\Winnt\Profiles\Smsclitoknacct\Ntuser.dat
CopyProfileDirectory: Relativo con un valore restituito di 1
IssueDefaultProfile: Relativo correttamente
RestoreUserProfile: Installazione completata locale predefinito.
SetupNewHive: immissione
ApplySecurityToRegistryKey: Impossibile aprire la sottochiave
S-1-5-21-1283131943-1217870647-1252928729-500, errore = 5
ApplySecurityToRegistryKey: Impossibile applicare la protezione per la sottochiave Protected Storage System Provider, errore = 5
ApplySecurityToRegistryKey: Impossibile applicare la protezione Microsoft sottochiave, errore = 5
ApplySecurityToRegistryKey: Impossibile applicare la protezione software sottochiave, errore = 5
SetupNewHive: Impossibile applicare la protezione della struttura del Registro di sistema di utente, errore = 5
SetupNewHive: Relativo con un valore restituito pari a 0
RestoreUserProfile: SetupNewHive non riuscita
RestoreUserProfile: Informazioni per lasciare. Informazioni finale seguente:
ApplySecurityToRegistryKey: Impossibile aprire la sottochiave S-1-5-21-1283131943-1217870647-1252928729-500, errore = 5
ApplySecurityToRegistryKey: Impossibile applicare la protezione a sottochiave Protected Storage System Provider, errore = 5
Il SID è elencato, S-1-5-21-1283131943-1217870647-1252928729-500, a cui appartiene l'account dell'amministratore locale perché l'amministratore era stata utente che ha creato il profilo, che era stato copiato il profilo utente predefinito durante l'installazione del sistema operativo. Errore dopo il sistema operativo copiato il profilo dell'utente predefinito al nuovo account utente (SMSClitokn $, in questo scenario) e tentato di modificare le autorizzazioni nella chiave di archiviazione protetta.

Proprietà

Identificativo articolo: 283056 - Ultima modifica: mercoledì 1 novembre 2006 - Revisione: 2.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Systems Management Server 2.0
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Chiavi: 
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Traduzione automatica articoli
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Clicca qui per visualizzare la versione originale in inglese dell?articolo: 283056
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