Erro ao instalar o WID no Windows Server 2012: O serviço MSSQL$MICROSOFT##WID não pôde fazer logon como NT SERVICE\MSSQL$MICROSOFT##WID

Este artigo funciona em torno de um problema em que você não pode instalar Banco de Dados Interno do Windows (WID) em um computador que executa Windows Server 2012.

Aplica-se a: Windows Server 2012 R2
Número de KB original: 2832204

Sintomas

Quando você instala Serviços de Federação do Active Directory (AD FS) (AD FS) usando o Assistente de Adicionar Funções e Recursos em Windows Server 2012, a instalação do WID falha. E você recebe a seguinte mensagem de erro:

O serviço MSSQL$MICROSOFT##WID não pôde fazer logon como NT SERVICE\MSSQL$MICROSOFT##WID com a senha atualmente configurada devido ao seguinte erro:
Falha de logon: o usuário não recebeu o tipo de logon solicitado neste computador.
Serviço: MSSQL$MICROSOFT##WID

Domínio e conta: NT SERVICE\MSSQL$MICROSOFT##WID

Essa conta de serviço não tem o direito de usuário necessário "Logon como serviço".

Ação do usuário

Atribua "Logon como serviço" à conta de serviço neste computador. Você pode usar As Configurações de Segurança Local (Secpol.msc) para fazer isso. Se esse computador for um nó em um cluster, marcar que esse direito de usuário seja atribuído à conta de serviço cluster em todos os nós do cluster. Se você já atribuiu esse direito de usuário à conta de serviço e o direito do usuário parece ter sido removido, marcar com o administrador de domínio para descobrir se um objeto Política de Grupo associado a esse nó pode estar removendo o direito.

Motivo

Quando o WID é instalado, a NT SERVICE\MSSQL$MICROSOFT##WID conta virtual local é criada. Essa conta recebe o direito do Log on as a service usuário pelo Política de Grupo local. Se um GPO (objeto Política de Grupo) vinculado a um site, domínio ou unidade organizacional substituir a configuração de Política de Grupo local, a conta NT SERVICE\MSSQL$MICROSOFT##WID não terá os direitos de usuário necessários. Portanto, o WID não pode ser instalado.

Solução alternativa

Para contornar o problema, use um dos seguintes métodos:

  • Atribua o direito do Log on as a service usuário ao NT SERVICE\ALL SERVICES no GPO que define o direito do usuário.
  • Exclua o computador do GPO que define o direito do usuário.

Mais informações

Você também pode ter outros sintomas nessa situação. Por exemplo, o serviço WID pode parecer estar instalado, mas não é iniciado. Além disso, o Assistente de Adicionar Funções e Recursos indica que uma reinicialização está pendente.

Coleta de dados

Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à implantação.