Lync non può verificare che il server sia considerato attendibile per l'indirizzo di accesso" durante l'accesso client

Sintomi

Questo articolo descrive due scenari che si verificano quando il client Microsoft Lync non riesce a stabilire una relazione di trust con le risorse che richiedono una connessione TLS sicura.

Scenario 1

Quando gli utenti provano ad accedere a Microsoft Lync in un ambiente Lync Server 2013 per la prima volta, ricevono il messaggio seguente in una finestra di dialogo:

Lync is attempting to connect to:
<Fully qualified domain name (FQDN) of a server>
Lync cannot verify that the server is trusted for your sign-in address. Connect anyway? 

Ad esempio, viene visualizzata la finestra di dialogo modello di attendibilità seguente:

Screenshot che mostra la finestra di dialogo Modello di attendibilità.

Scenario 2

Nella finestra di dialogo Lync - Accesso visualizzata nello screenshot dello scenario 1 viene visualizzato il nome di dominio completo (FQDN) dell'interfaccia del server Accesso client di Exchange dell'organizzazione. Questa interfaccia viene usata dal client Lync per accedere alle informazioni sulla cassetta postale dell'utente tramite Exchange Web Services (EWS). Questo comportamento si verifica se l'URI SIP dell'utente di Lync contiene un suffisso di dominio che non corrisponde al suffisso di dominio dell'interfaccia cas di Exchange. Se l'utente sceglie di non considerare attendibile la connessione all'interfaccia cas di Exchange, il client Lync non avrà accesso ai servizi cassette postali di Exchange di cui viene effettuato il provisioning da EWS.

Per verificare questo comportamento, seguire questa procedura:

  1. Assicurarsi che il client Lync abbia eseguito l'accesso sul desktop del client Windows.
  2. Tenere premuto CTRL e fare clic con il pulsante destro del mouse sull'icona Lync nell'area di notifica del client Windows.
  3. Nel menu di scelta rapida fare clic su Informazioni di configurazione.
  4. Individuare la riga "EWS Information".
  5. Se questa riga contiene "EWS non completamente inizializzato", si verifica il comportamento scenario 2.

Causa

Questo problema si verifica perché il nome di dominio SIP dell'utente non corrisponde ai nomi di dominio nelle proprietà seguenti nel certificato di Servizi Web Lync ed Exchange Web Services:

  • Nome soggetto nella riga Subject Name
  • Nome comune

Risoluzione

Per impedire la visualizzazione della finestra di dialogo Modello di attendibilità, usare la Criteri di gruppo Trusted Domain List (TrustModelData). Dopo aver impostato questo criterio, Lync considera attendibili esclusivamente i domini specificati nei criteri. Valori supportati:

  • Non configurato (impostazione predefinita)/Disabilitato

    Tramite questa impostazione, i domini seguenti sono attendibili per impostazione predefinita:

    • lync.com
    • outlook.com
    • lync.glbdns.microsoft.com
    • microsoftonline.com
  • Abilitato

    Questa impostazione specifica l'elenco di domini da considerare attendibili, ad esempio contoso.com, contoso.co.in.

Per altre informazioni sull'impostazione Criteri di gruppo Elenco di domini attendibili di Lync 2013 (TrustModelData), vedere Configurazione dei criteri di avvio automatico client.

Per altre informazioni sui modelli amministrativi di Lync 2013.admx (ADMX) e ADML (ADML), vedere File di modelli amministrativi di Office 2013 (ADMX/ADML) e Strumento di personalizzazione di Office.

Ulteriori informazioni

Scenario 1

Il client desktop di Lync 2013 usa il nuovo meccanismo di individuazione automatica per individuare il servizio Web Lync interno o esterno, a seconda del percorso di rete dell'utente.

Il processo seguente si verifica quando il client desktop di Lync 2013 tenta di individuare il servizio Web Lync:

  1. Il client desktop di Lync 2013 invia una coppia di richieste HTTP e HTTPS per individuare il servizio di individuazione automatica di Lync. Le richieste HTTP e HTTPS sono costituite da un set predefinito di valori di nome host interno o esterno e dal nome di dominio SIP dell'utente.

    Ad esempio, il client desktop di Lync 2013 invia le richieste seguenti:

    http://LyncdiscoverInternal.contoso.com e https://LyncdiscoverInternal.contoso.com

    Nota

    LyncdiscoverInternal.contoso.com viene risolto nell'FQDN o nell'indirizzo IP del servizio Web Lync interno.

    http://Lyncdiscover.contoso.com e https://Lyncdiscover.contoso.com

    Nota

    Lyncdiscover.contoso.com viene risolto nell'FQDN o nell'indirizzo IP dell'interfaccia esterna del proxy inverso.

  2. Il client desktop di Lync 2013 riceve una risposta che contiene gli URL interni ed esterni sicuri del servizio di individuazione automatica dai servizi Web.

  3. Il client desktop di Lync 2013 tenta di contattare il servizio di individuazione automatica usando una connessione HTTPS. Se il nome di dominio SIP dell'utente non corrisponde al nome di dominio nella proprietà Nome soggetto o Nome comune del certificato assegnato al servizio Web Lync, verrà visualizzata la finestra di dialogo Modello di attendibilità.

Scenario 2

Il client Lync effettua richieste HTTPS all'interfaccia cas di Exchange come parte del processo di post-accesso. Queste richieste includono l'accesso al servizio di individuazione automatica di Exchange tramite URL che includono il nome di dominio completo dell'interfaccia cas di Exchange. Ad esempio:

  • https://<smtpdomain>/autodiscover/autodiscover.xml
  • https://autodiscover.<smtpdomain>/autodiscover/autodiscover.xml

Se il nome di dominio completo del dominio SMTP non corrisponde al nome di dominio completo del dominio SIP a cui è stato eseguito l'accesso del client Lync, si verifica il problema scenario 2.

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