文書番号: 283492 - 最終更新日: 2007年12月1日 - リビジョン: 2.1

コンピュータの再起動後に共有レベルの割り当て済みネットワーク ドライブに接続されない

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
この記事は、以前は次の ID で公開されていました: JP283492
すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP Professional を実行するコンピュータを再起動した後で、以前に割り当てたネットワーク ドライブの一部に再接続されないことがあります。再接続されないネットワーク ドライブに赤の "X" が表示されます。

この現象は、以下のすべての条件に該当する場合に発生する可能性があります。
  • Microsoft Windows 95 または Microsoft Windows 98 を実行するコンピュータをピアツーピア ネットワークで、共有レベルでアクセスを制御したネットワーク ファイル サーバーとして使用している。アクセスを共有レベルで制御することにより、共有リソースごとにパスワードを設定できます。
  • Windows 95 または Windows 98 を実行するコンピュータ上に複数の共有フォルダがあり、それぞれの共有フォルダに異なるパスワードが設定されている。
  • Windows XP Professional を実行するコンピュータから、Windows 95 または Windows 98 ベースのコンピュータ上で共有される、パスワードで保護された複数のフォルダに接続している。
  • Windows 95 または Windows 98 ベースのコンピュータ上で共有される各フォルダで [パスワードを記憶する] チェック ボックスをオンにしている。

原因

パスワードで保護された複数の共有フォルダがある Windows 95 または Windows 98 ベースのコンピュータに接続する場合、[ユーザー名およびパスワードの保存] は最後に接続した共有フォルダのパスワードのみ保存します。この現象はこれが原因で発生します。

回避策

この現象を回避するには、ネットワーク ドライブに手動で再接続します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンを右クリックし、[エクスプローラ] をクリックします。
  2. 左側のウィンドウで [マイ コンピュータ] をクリックします。
  3. 右側のウィンドウで、赤の "X" が表示されたネットワーク ドライブ アイコンをダブルクリックします。
  4. [\\computer name\shared folder name への接続] ダイアログ ボックスで、[ユーザー名] ボックスの一覧からユーザー名をクリックします。
  5. [パスワード] フィールドにパスワードを入力して [OK] をクリックします。

状況

この動作は仕様です。

詳細

[ユーザー名およびパスワードの保存] は、Microsoft Windows XP の機能で、サーバーのユーザー名とパスワードを保存します。この機能を使用すると、ユーザーはログオン時に使用するユーザー名およびパスワードとは異なるユーザー名およびパスワードを使用してサーバーにアクセスできます。ユーザーはこれらのユーザー名およびパスワードを保存して後で再利用することができます。

: Microsoft Windows XP Home Edition では、ネットワーク共有接続に対しては [ユーザー名およびパスワードの保存] が機能しません。Windows XP Home Edition では、リモート アクセス サービス/仮想プライベート ネットワークと Microsoft .NET Passport 資格情報のみが保存されます。

関連情報

保存されているユーザー名およびパスワードの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
306992? (http://support.microsoft.com/kb/306992/ ) [HOW TO] ドメイン内のコンピュータ上で格納されているユーザー名とパスワードを管理する方法
306541? (http://support.microsoft.com/kb/306541/ ) [HOW TO] ドメインにないコンピュータに保存されているユーザー名およびパスワードを管理する方法
281660? (http://support.microsoft.com/kb/281660/ ) [ユーザー名およびパスワードの保存] の動作

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Tablet PC Edition
キーワード:?
kbprb KB283492
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"