Article ID: 283807 - Last Review: March 4, 2009 - Revision: 9.3

Pictures are not displayed on Web sites in Internet Explorer

This article was previously published under Q283807

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SUMMARY

This article describes how to troubleshoot an issue in which pictures (graphics or images) are not displayed on Web sites in Internet Explorer. This article contains troubleshooting steps for beginning, intermediate, and advanced computer users.

SYMPTOMS

When you open a Web page, one or more pictures may not be displayed. Instead, you see a red X or a placeholder of some type.

CAUSE

This behavior can occur if one of the following conditions is true:
  • The Web page includes an image type that is not supported by Internet Explorer.
  • The Show Pictures check box is not selected on the Advanced tab of the Internet Options dialog box in Internet Explorer, or the Toggle Images.exe Web accessory was used to disable images in Internet Explorer.
  • The image is displayed based on a script, an ActiveX control, a cookie, a Java program, or HTTP referral information, and your computer or network is configured to block one or more of these features. For example, you may have Internet Explorer or Symantec Corporation Norton Internet Security (NIS) or Norton Personal Firewall (NPF) 2002 configured to block one or more of these features.
  • Internet Explorer cannot determine the character set (also known as the code page or encoding) that is used by the Web page, or a file or registry key that is required to display the Web page that has the appropriate character set may be missing or damaged. By default, Internet Explorer uses the character set that is specified in the HTTP content type that is returned by the server, the character set that is specified by the meta element in the Web page document, or your Encoding preference if no HTTP content type is returned by the server and no meta element is specified in the Web page document.

RESOLUTION

To correct this issue, follow the methods that are described in this section in the order in which they are presented until the issue is resolved.

You may find it easier to follow the steps if you print this article first.

These methods are designed for beginning to intermediate computer users. After each method, refresh Internet Explorer to check whether the problem is resolved. If the problem is not resolved, try the next method.

Method 1: See whether pictures are available on another Web site

Sometimes the link to a picture on a Web site is broken, and that is why a picture is not being displayed. Visit another Web site to determine whether pictures are being displayed correctly on it. If they are being displayed correctly, then there is nothing wrong with Internet Explorer. Instead, the Web site that you are visiting might be broken.

If you can view pictures on another Web site, you are finished. If you do not see any pictures or if you cannot determine whether the Web site that you are visiting is broken, try clearing your temporary Internet files by using method 2.

Note If you use Internet Explorer 8, try Compatibility View. To do this, start Internet Explorer 8, click Compatibility View Settings on the Tools menu, and then add the Web site that you want to view by using Compatibility View.

Method 2: Clear temporary Internet files

Clearing your temporary Internet files creates more space on your hard disk. If your hard disk is close to being full, this could affect your ability to view pictures on a Web site.

To clear temporary Internet files, follow these steps:

Internet Explorer 8
  1. Start Internet Explorer 8.
  2. On the Tools menu, click Internet Options.
  3. On the General tab, click Delete under Browsing History.
  4. In the Delete Browsing History dialog box, click to clear all of the check boxes except for the Temporary Internet Files check box, and then click Delete.
  5. Click OK to close the Internet Options dialog box.
Internet Explorer 7
  1. Start Internet Explorer 7.
  2. On the Tools menu, click Delete Browsing History.
  3. In the Delete Browsing History dialog box, click Delete Files.
  4. Click OK to close the Internet Options dialog box.
Internet Explorer 6 and earlier versions
  1. On the Tools menu, click Internet Options.
  2. On the General tab, click Delete Files under Temporary Internet files.
  3. Click to select the Delete all offline content check box, and then click OK.
  4. Click OK to close the Internet Options dialog box.
Check whether you can now see pictures. If you still cannot see pictures, try method 3.

Method 3: Verify that the Show Pictures option has not been turned off

If the Show Pictures option in Internet Explorer is turned off, you cannot see pictures. To determine whether the Show Pictures option is turned off, follow these steps:
  1. On the Tools menu, click Internet Options.
  2. Click the Advanced tab, and then verify that the Show Pictures check box is selected under Multimedia.
  3. Click OK.
Determine whether you can now see pictures. If you still cannot see pictures, try method 4.

Method 4: Enable scripting, ActiveX controls, cookies, and Java programs

Enable scripting, ActiveX controls, cookies, and Java programs to make sure that your computer is set up to enable Web pages to run the way that they were designed to.

To do this, follow these steps:
  1. On the Tools menu, click Internet Options.
  2. Click the Security tab, and then click Default Level (if it is available) for the zone that contains the Web page (for example, the Internet zone).
  3. If you are using Internet Explorer 6, click the Privacy tab, and then click Default (if it is available).
Check whether you can now see pictures. If you still cannot see pictures, you must do some advanced troubleshooting. If you are not comfortable with advanced troubleshooting, you might want to check the "Next Steps" section for some other resources that you can use for help.

Advanced troubleshooting

Method 1: Verify that the image type is supported by Internet Explorer

Internet Explorer displays images with .art, .wmf, .emf, .png, .mov, .xbm, .avi, .mpg, .gif, .jpg, .mpeg, and .bmp extensions.

Right-click the red X or the placeholder for the image, and then click Properties. Verify that the image type is supported by Internet Explorer by examining the Type or Address (URL) values in the Properties dialog box. For example, a Graphics Interchange Format (GIF) file lists GIF Image for the Type value. The Address (URL) value ends with .gif.

If the image type is not supported by Internet Explorer, you are finished. If the image type is supported, go to method 2.

Method 2: Make sure that the Toggle Images.exe Web accessory is not present and disabling images

The Toggle Images.exe program can be set to disable images. Make sure that it is set to show images.

If you have the Toggle Images.exe Web accessory installed, click the Toggle Images.exe link on the Links Bar in Internet Explorer to turn on images.

Note If the Links bar is not visible, right-click a blank area of the toolbar and verify that there is a check mark next to Links. If the Toggle Images.exe link is not visible on the Links bar, click the arrow with two angle brackets on the rightmost side of the Links bar.

If this method solved your problem, you are finished. If you still cannot see pictures, go to method 3.

Method 3: Make sure that a third-party Internet security, firewall, or cookie-blocking program is not causing the problem

If you are using a third-party Internet security, firewall, or cookie-blocking program, contact the manufacturer of the program for information about how to enable scripting, ActiveX controls, cookies, Java programs, advertisements, and HTTP referral information. For example, if you have Norton Internet Security (NIS) or Norton Personal Firewall (NPF) installed, visit the following Symantec Corporation Web sites for more information about the various settings in these products that could cause the behavior that this article describes:
http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam)
http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam)
If you access the Internet through a local area network (LAN), contact the administrator of your LAN to verify that scripting, ActiveX controls, cookies, Java programs, advertisements, and HTTP referral information are not blocked by a firewall or by other security features on the network.

If this method solved your problem, you are finished. If you still cannot see pictures, go to method 4.

Method 4: Enable the Auto-Select encoding option

In Internet Explorer 7 or in Internet Explorer 8, on the Page menu, point to Encoding. If a check mark does not appear next to Auto-Select, click Auto-Select.

In Internet Explorer 6, on the View menu, point to Encoding. If a check mark does not appear next to Auto-Select, click Auto-Select.

If this method solved your problem, you are finished. If you still cannot see pictures, go to method 5.

Method 5: Make sure that the encoding option is set to the correct language

In Internet Explorer 7 or in Internet Explorer 8, on the Page menu, point to Encoding, and then click the appropriate language for the Web page that you are trying to view. For example, if the Web page is in English (United States), click Western European (ISO) or click Western European (Windows).

In Internet Explorer 6, on the View menu point to Encoding, and then click the appropriate language for the Web page that you are trying to view. For example, if the Web page is in English (United States), click Western European (ISO) or click Western European (Windows).

If the required language is not available on the View menu in Internet Explorer 6 or on the Page menu in Internet Explorer 7 or Internet Explorer 8, follow these steps to add it:
  1. On the Tools menu, click Internet Options.
  2. On the General tab, click Languages, and then click Add.
  3. Click the appropriate language, and then click OK.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

If this method solved your problem, you are finished. If you still cannot see pictures, go to the "Next Steps" section.

NEXT STEPS

If these methods did not work for you, you can use the Microsoft Customer Support Services Web site to find other solutions to your problem. Some services that the Microsoft Customer Support Services Web sites provide include the following:
  • Searchable Knowledge Base (http://support.microsoft.com/search/?adv=1) : Search technical support information and self-help tools for Microsoft products.
  • Solution Centers (http://support.microsoft.com/select/?target=hub) : View product-specific frequently asked questions and support highlights.
  • Microsoft Customer Support Newsgroups (http://www.microsoft.com/communities/newsgroups/default.mspx) : Contact counterparts, peers, and Microsoft Most Valuable Professionals (MVPs).
  • Other Support Options (http://support.microsoft.com/default.aspx?pr=csshome) : Use the Web to ask a question, contact Microsoft Customer Support Services, or provide feedback.
If you continue to have problems after you use these Microsoft Web sites or if you cannot find a solution to the problem on the Microsoft Support Services Web site, click the following link to contact Support.
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

APPLIES TO
  • Windows Internet Explorer 8
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbtshoot kbresolve kbdisplay kbenv kbprb KB283807
 

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