Artikel ID: 283807 - Laatste beoordeling: dinsdag 20 oktober 2009 - Wijziging: 9.3

Afbeeldingen worden niet weergegeven op websites in Internet Explorer

Dit artikel is eerder gepubliceerd onder NL283807

Op deze pagina

Alles uitklappen | Alles samenvouwen

Samenvatting

In dit artikel wordt uitgelegd hoe u een probleem kunt oplossen waarbij afbeeldingen (illustraties of foto's) op websites niet worden weergegeven in Internet Explorer. Dit artikel bevat stappen voor probleemoplossing voor beginnende, enigszins ervaren en ervaren computergebruikers.

Symptomen

Als u een webpagina opent, worden een of meer afbeeldingen niet weergegeven. In plaats daarvan wordt er een rood X-teken of een tijdelijke aanduiding weergegeven.

Oorzaak

Mogelijke oorzaken van dit probleem zijn:
  • De webpagina bevat een type afbeelding dat niet door Internet Explorer wordt ondersteund.
  • Het selectievakje Afbeeldingen weergeven is niet ingeschakeld op het tabblad Geavanceerd van het dialoogvenster Internetopties of de webaccessoire Toggle Images.exe is gebruikt om afbeeldingen in Internet Explorer uit te schakelen.
  • De afbeelding wordt weergegeven op basis van een script, ActiveX-besturingselement, cookie, Java-programma of op basis van HTTP-verwijzingsgegevens. Bovendien zijn op de computer of het netwerk instellingen van kracht die een of meer van deze functies blokkeren. U hebt bijvoorbeeld Internet Explorer van Microsoft of Norton Internet Security (NIS) of Norton Personal Firewall (NPF) 2002 van Symantec Corporation zodanig geconfigureerd dat het programma een of meer van deze functies blokkeert.
  • Internet Explorer kan niet vaststellen welke tekenset (ook wel codepagina of codering genoemd) er op de webpagina wordt gebruikt. Het is ook mogelijk dat een bestands- of registersleutel die is vereist voor het weergeven van de webpagina, ontbreekt of is beschadigd. Internet Explorer maakt standaard gebruik van de tekenset die wordt gespecificeerd in het door de server geretourneerde HTTP-inhoudstype, of van de tekenset die wordt gespecificeerd door het meta-element in het webpaginadocument. Als er geen HTTP-inhoudstype door de server wordt geretourneerd en er geen meta-element in het webpaginadocument is gespecificeerd, gebruikt Internet Explorer de door u opgegeven voorkeur voor codering.

Oplossing

U kunt dit probleem oplossen door de methoden te gebruiken die in deze sectie zijn beschreven. Hanteer daarbij de aangegeven volgorde, totdat het probleem is opgelost.

Wellicht kunt u de stappen beter volgen als u dit artikel afdrukt.

Deze methoden zijn bedoeld voor beginnende tot enigszins ervaren computergebruikers. Vernieuw Internet Explorer na elke methode om te controleren of het probleem is opgelost. Als het probleem niet is opgelost, gaat u verder met de volgende methode.

Methode 1: Controleren of op andere websites afbeeldingen worden weergegeven

Soms is de koppeling naar een afbeelding op een website verbroken en wordt er daarom geen afbeelding weergegeven. Bezoek een andere website om na te gaan of afbeeldingen op de desbetreffende website op de juiste wijze worden weergegeven. Als deze correct worden weergegeven, is het probleem niet aan Internet Explorer te wijten. In dat geval is er mogelijk een probleem met de website die u bezoekt.

Als afbeeldingen op andere websites wel worden weergegeven, bent u klaar. Als er geen afbeeldingen worden weergegeven of als u niet kunt nagaan of er inderdaad een probleem is met de website die u bezocht, kunt u proberen of u het probleem kunt oplossen door de tijdelijke internetbestanden te verwijderen via methode 2.

Opmerking Als u Internet Explorer 8 gebruikt, kunt u de compatibiliteitsweergave gebruiken. Start hiertoe Internet Explorer 8, klik op Instellingen voor compatibiliteitsweergave in het menu Extra en voeg vervolgens de website toe waarvoor u de compatibiliteitsweergave wilt gebruiken.

Methode 2: Tijdelijke internetbestanden verwijderen

Als u uw tijdelijke internetbestanden verwijdert, komt er meer ruimte vrij op de vaste schijf. Als uw vaste schijf bijna vol is, kan dit van invloed zijn op de mogelijkheid om afbeeldingen op een website weer te geven.

Voer de volgende stappen uit om tijdelijke internetbestanden te verwijderen:

Internet Explorer 8
  1. Start Internet Explorer 8.
  2. Open het menu Extra en klik op Internetopties.
  3. Ga naar het tabblad Algemeen en klik onder Browsegeschiedenis op Verwijderen.
  4. Schakel in het dialoogvenster Browsegeschiedenis verwijderen alle selectievakjes uit, behalve Tijdelijke internetbestanden en klik vervolgens op Verwijderen.
  5. Klik op OK om het dialoogvenster Internetopties te sluiten.
Internet Explorer 7
  1. Start Internet Explorer 7.
  2. Klik in het menu Extra op Browsegeschiedenis verwijderen.
  3. Klik in het dialoogvenster Browsegeschiedenis verwijderen op Bestanden verwijderen.
  4. Klik op OK om het dialoogvenster Internetopties te sluiten.
Internet Explorer 6 en eerdere versies
  1. Open het menu Extra en klik op Internetopties.
  2. Open het tabblad Algemeen en klik onder Tijdelijke Internet-bestanden op Bestanden verwijderen.
  3. Schakel het selectievakje Ook alle offline items verwijderen in en klik op OK.
  4. Klik op OK om het dialoogvenster Internetopties te sluiten.
Controleer vervolgens of er afbeeldingen worden weergegeven. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u methode 3 proberen.

Methode 3: Controleren of de optie Afbeeldingen weergegeven is uitgeschakeld

Als de optie Afbeeldingen weergegeven in Internet Explorer is uitgeschakeld, worden er geen afbeeldingen weergegeven. Volg de volgende stappen als u wilt nagaan of de optie Afbeeldingen weergegeven is uitgeschakeld:
  1. Open het menu Extra en klik op Internetopties.
  2. Open het tabblad Geavanceerd en controleer of het selectievakje Afbeeldingen weergeven onder Multimedia is ingeschakeld.
  3. Klik op OK.
Controleer vervolgens of er afbeeldingen worden weergegeven. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u methode 4 proberen.

Methode 4: Scripts, ActiveX-besturingselementen, cookies en Java-programma's inschakelen

Schakel scripts, ActiveX-besturingselementen, cookies en Java-programma's in, zodat u er zeker van kunt zijn dat uw computer zo is geconfigureerd dat webpagina's kunnen worden uitgevoerd op de wijze waartoe deze zijn ontworpen.

Volg hiertoe de volgende stappen:
  1. Open het menu Extra en klik op Internetopties.
  2. Open het tabblad Beveiliging en klik op de knop Standaardniveau (als deze beschikbaar is) voor de zone die de webpagina bevat (bijvoorbeeld de zone Internet).
  3. Als u werkt met Internet Explorer 6, opent u het tabblad Beveiliging en klikt u op de knop Standaardniveau (als deze beschikbaar is).
Controleer vervolgens of er afbeeldingen worden weergegeven. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u proberen of u het probleem kunt verhelpen via geavanceerde probleemoplossing. Als u niet vertrouwd bent met geavanceerde probleemoplossing, gaat u naar de sectie Volgende stappen controleren voor informatie over andere bronnen die u kunt gebruiken om het probleem op te lossen.

Geavanceerde probleemoplossing

Methode 1: Controleren of het afbeeldingstype door Internet Explorer wordt ondersteund

In Internet Explorer kunnen afbeeldingen met de extensies ART, WMF, EMF, PNG, MOV, XBM, AVI, MPG, GIF, JPG, MPEG en BMP worden weergegeven.

Klik met de rechtermuisknop op de rode X of de tijdelijke aanduiding voor de afbeelding en klik op Eigenschappen. Controleer of het type afbeelding door Internet Explorer wordt ondersteund door in het dialoogvenster Eigenschappen naar de waarden achter Type of Adres (URL) te kijken. Voor bijvoorbeeld een GIF-bestand (Graphics Interchange Format) wordt bij Type de waarde GIF-afbeelding weergegeven en bij Adres (URL) een adres dat eindigt met de extensie GIF.

Als het afbeeldingstype door Internet Explorer niet wordt ondersteund, bent u klaar. Als het afbeeldingstype wel wordt ondersteund, gaat u naar methode 2.

Methode 2: Controleren of de webaccessoire Toggle Images.exe niet aanwezig is en afbeeldingen blokkeert

Het programma Toggle Images.exe kan zo worden ingesteld dat het weergeven van afbeeldingen is uitgeschakeld. Controleer of het programma is ingesteld op het weergeven van afbeeldingen.

Als de webaccessoire Toggle Images.exe is geïnstalleerd, klikt u op de koppeling Toggle Images.exe op de werkbalk Koppelingen in Internet Explorer om afbeeldingen in te schakelen.

Opmerking Als de werkbalk Koppelingen niet wordt weergegeven, klikt u met de rechtermuisknop op een leeg gedeelte van de werkbalk en controleert u of er naast Koppelingen een vinkje wordt weergegeven. Als de koppeling Toggle Images.exe niet op de werkbalk Koppelingen wordt weergegeven, klikt u op de twee punthaken uiterst rechts op de werkbalk Koppelingen.

Als het probleem via deze methode is opgelost, bent u klaar. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u methode 3 proberen.

Methode 3: Controleren of het probleem niet wordt veroorzaakt door een programma voor internetbeveiliging, een firewall of een programma dat cookies blokkeert van een andere leverancier

Als u een internetbeveiligingsprogramma, een firewallprogramma of een programma voor het blokkeren van cookies gebruikt dat van een andere fabrikant afkomstig is, neemt u contact op met de fabrikant van het desbetreffende programma voor informatie over het inschakelen van scripts, ActiveX-besturingselementen, cookies, Java-programma's, advertenties en HTTP-verwijzingsgegevens. Als u bijvoorbeeld Norton Internet Security (NIS) of Norton Personal Firewall (NPF) hebt geïnstalleerd, bezoekt u de volgende websites van Symantec Corporations voor meer informatie over de verschillende instellingen in deze producten die dit gedrag kunnen veroorzaken:
http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/sunset-c2002kb.nsf/29dd58255a9a57a585256ee600556cc1/73af2219f66216e585256ede00518e72?OpenDocument&src=bar_sch_nam)
http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam (http://service1.symantec.com/SUPPORT/nip.nsf/429934053165308488256d8e0076af48/77ee338ff06cf3b5882568a1006a69a3?OpenDocument&src=bar_sch_nam)
Als u toegang hebt tot internet via een LAN, neemt u contact op met de beheerder van het LAN om na te gaan of scripts, ActiveX-besturingselementen, cookies, Java-programma's, advertenties en HTTP-verwijzingsgegevens niet worden geblokkeerd door een firewall of andere beveiligingsfuncties in het netwerk.

Als het probleem via deze methode is opgelost, bent u klaar. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u methode 4 proberen.

Methode 4: De coderingsoptie Auto-Select inschakelen

Wijs in Internet Explorer 7 of in Internet Explorer 8 in het menu Pagina de optie Codering aan. Als er geen vinkje wordt weergegeven naast Auto-Select, klikt u op Auto-Select.

Wijs in Internet Explorer 6 de optie Codering aan in het menu Beeld. Als er geen vinkje wordt weergegeven naast Auto-Select, klikt u op Auto-Select.

Als het probleem via deze methode is opgelost, bent u klaar. Als er nog steeds geen afbeeldingen worden weergegeven, kunt u methode 5 proberen.

Methode 5: Controleren of de coderingsoptie is ingesteld op de juiste taal

Wijs in Internet Explorer 7 of in Internet Explorer 8 in het menu Pagina de optie Codering aan en klik op de juiste taal voor de webpagina die u probeert weer te geven. Als de webpagina bijvoorbeeld in het Nederlands is, klikt u op West-Europees (ISO) of West-Europees (Windows).

Wijs in Internet Explorer in het menu Beeld de optie Codering aan en klik op de juiste taal voor de webpagina die u probeert weer te geven. Als de webpagina bijvoorbeeld in het Nederlands is, klikt u op West-Europees (ISO) of West-Europees (Windows).

Als de vereiste taal in Internet Explorer 6 niet in het menu Beeld wordt weergegeven of als de vereiste taal in Internet Explorer 7 of in Internet Explorer 8 niet in het menu Pagina wordt weergegeven, volgt u de volgende stappen om deze toe te voegen:
  1. Open het menu Extra en klik op Internetopties.
  2. Open het tabblad Algemeen, klik op Talen en klik op Toevoegen
  3. Klik op de juiste taal en klik op OK.
Microsoft verstrekt deze contactinformatie om u te helpen bij het aanvragen van technische ondersteuning. Deze contactinformatie kan zonder aankondiging worden gewijzigd. Microsoft kan derhalve niet instaan voor de juistheid van deze contactinformatie.

De niet-Microsoft-producten die in dit artikel worden vermeld, worden vervaardigd door fabrikanten die geheel onafhankelijk zijn van Microsoft. Microsoft verleent dan ook geen enkele garantie, impliciet noch anderszins, omtrent de prestaties of de betrouwbaarheid van deze producten.

Als het probleem via deze methode is opgelost, bent u klaar. Als er nog steeds geen afbeeldingen worden weergegeven, gaat u naar de sectie Volgende stappen.

VOLGENDE STAPPEN

Als deze methoden niet voor u hebben gewerkt, kunt u op de Microsoft Customer Support Services-website andere oplossingen zoeken voor het probleem. Een aantal van de diensten die op de websites van Microsoft Customer Support Services worden geboden, zijn:
  • Doorzoekbare Knowledge Base (http://support.microsoft.com/search/?adv=1) : u kunt hiermee zoeken naar technische ondersteuning en zelfhulpmiddelen voor Microsoft-producten.
  • Solution Centers (http://support.microsoft.com/select/?target=hub) : hier kunt u productgebonden veelgestelde vragen en veelvoorkomende problemen bekijken.
  • Nieuwsgroepen van Microsoft Customer Support (http://www.microsoft.com/communities/newsgroups/default.mspx) : hier kunt u contact opnemen met collega's en Microsoft MVP's (Most Valuable Professionals).
  • Overige ondersteuningsopties (http://support.microsoft.com/default.aspx?pr=csshome) : u kunt vragen stellen via het web, contact opnemen met Microsoft Customer Support Services of feedback geven.
Als u na het gebruik van deze Microsoft-websites nog problemen hebt of als u geen oplossing kunt vinden op de website van Microsoft Support Services, klikt u op de volgende koppeling om contact op te nemen met Customer Support:
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)

De informatie in dit artikel is van toepassing op:
  • Windows Internet Explorer 8
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 6.0 op de volgende platformen
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows® 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Tweede editie
    • Microsoft Windows 98 Standard Edition
Trefwoorden: 
kbtshoot kbresolve kbdisplay kbenv kbprb KB283807
 

Vertaalde artikelen