Lorsque vous importez, exportez ou liez des fichiers dans Access 2002 ou Access 2003, certains types de fichiers sont manquants ou un message d'erreur « Pilote ISAM introuvable » s'affiche

Traductions disponibles Traductions disponibles
Numéro d'article: 283881 - Voir les produits auxquels s'applique cet article
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
Utilisateurs avertis : cet article requiert des connaissances de base en matière de macros, de programmation et d'interopérabilité.

Cet article s'applique à une base de données Microsoft Access (.mdb) et à un projet Microsoft Access (.adp).

Pour vous procurer une version Microsoft Access 2000 de cet article, reportez-vous à l'article 209805.
Pour vous procurer une version Microsoft Access 97 de cet article, reportez-vous à l'article 90111.
Agrandir tout | Réduire tout

Symptômes

Lorsque vous importez, exportez ou liez des fichiers dans Microsoft Access, certains types de fichiers sont manquants dans la liste déroulante Types de fichiers de la boîte de dialogue Importation, Exportation ou Liaison. Lorsque vous essayez d'importer ou d'exporter un fichier ou d'établir un lien vers un fichier à l'aide d'un pilote ISAM, un message d'erreur peut s'afficher si Microsoft Access ne parvient pas à trouver le pilote ISAM.

Cause

Les pilotes ISAM sont utilisés par Access pour mettre à jour les formats de fichiers autres que le format Access. Si le chemin d'accès au pilote ISAM dans votre Registre Windows n'est pas valide ou si le pilote ISAM n'existe pas, l'un des messages d'erreur suivants peut s'afficher :

Message d'erreur 1
Pilote ISAM introuvable
Message d'erreur 2
L'Assistant ne peut accéder aux informations du fichier '<nom_chemin>'. Veuillez vérifier que le fichier existe et que son format est correct.

Résolution

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour résoudre le problème, vous devez corriger les erreurs de nom du chemin d'accès dans le Registre et installer ou remplacer le fichier provoquant le problème.

Dans le cas du premier message d'erreur, le nom de fichier est directement lié à l'opération tentée.

Dans le cas du deuxième message d'erreur, le nom de fichier est mentionné dans le texte du message.
  1. Recherchez le fichier approprié dans le tableau ci-dessous.
    Réduire ce tableauAgrandir ce tableau
    Nom du fichierISAM d'importation/exportation pour :Registre Windows
    Msexcl40.dllMicrosoft ExcelHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel
    Msexch40.dllMicrosoft ExchangeHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange
    Msrd2x40.dllMicrosoft Jet 2.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x
    Msrd3x40.dllMicrosoft Jet 3.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x
    Msltus40.dllLotus 1-2-3HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus
    Mspbde40.dllImprise ParadoxHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox
    Mstext40.dllTexteHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Text
    Msxbde40.dlldBaseHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase
  2. Utilisez l'Explorateur Microsoft Windows pour rechercher le fichier.
  3. Si vous trouvez le fichier, enregistrez son nom de chemin d'accès ; sinon, passez à l'étape 9.
  4. Démarrez l'Éditeur du Registre.
  5. Accédez à la sous-clé de Registre décrite dans le tableau, puis comparez le chemin d'accès affiché au chemin d'accès réel.
  6. Corrigez le nom de chemin d'accès s'il est incorrect ; poursuivez ces étapes s'il est correct.
  7. Quittez l'Éditeur du Registre. Si vous avez modifié le chemin d'accès, répétez la procédure ayant généré l'erreur d'origine.
  8. Si l'erreur persiste ou si le chemin d'accès était correct à l'étape 6, renommez le fichier.
  9. Démarrez l'outil Ajout/Suppression de programmes.
  10. Démarrez le programme d'installation Office en cliquant sur le bouton Modifier en regard de son entrée dans l'outil Ajout/Suppression de programmes et sélectionnez l'option pour réparer ou réinstaller Office.

Références

Pour plus d'informations sur la modification du Registre, tapez Registre dans le Compagnon Office, puis cliquez sur Rechercher pour consulter les rubriques correspondantes.

Propriétés

Numéro d'article: 283881 - Dernière mise à jour: mercredi 13 juin 2007 - Version: 5.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Access 2003
  • Microsoft Access 2002
Mots-clés : 
kbupdateissue kberrmsg kbprb KB283881
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com