System Center 2012 Configuration Manager Mac client enrollment fails if passwords contain special characters

Article ID: 2839072 - View products that this article applies to.
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Symptoms

The Configuration Manager CMEnroll tool fails on a Mac client computer with the following error:

Error recieved: Server Connection failed. HTTP Response code is 400 and reason is Bad request.

Cause

This issue can occur if the user has the special characters  "&" and "<" in their domain password. CMEnroll.exe does not encode the "&" and "<" special characters correctly for Mac based clients.

Resolution

To work around this issue, have the user change their password so that it does not contain these special characters.

More Information

For more information on Mac clients and Configuration Manager please see the following:

How to Install Clients on Mac Computers in Configuration Manager: http://technet.microsoft.com/en-us/library/jj591553.aspx

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2839072 - Last Review: April 16, 2013 - Revision: 1.0
Applies to
  • Microsoft System Center 2012 Configuration Manager
  • Microsoft System Center 2012 Configuration Manager Service Pack 1
Keywords: 
KB2839072

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