Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

This article applies to the following products:

  • Microsoft BizTalk Adapter Pack 2010

  • Microsoft BizTalk Adapter Pack 2013

Symptoms

Assume that you configure a BizTalk Adapter user account or BizTalk Adapter Service Runtime user account to use a case-sensitive language. When you use BizTalk Adapter for Oracle Database to connect to an Oracle database, you receive the following exception message:

Microsoft.ServiceModel.Channels.Common.MetadataException: Retrieval of Operation Metadata has failed while building WSDL at 'http://Microsoft.LobServices.OracleDB/2007/03/POLLINGSTMT' ---> System.ArgumentException: Column 'PROVIDERTYPE' does not belong to table SchemaTable.


Cause

This issue occurs because the adapter incorrectly handles some metadata. The adapter uses the metadata to identify columns of datasets. However, the adapter uses the wrong case formatting for the metadata.

Resolution

Cumulative update package information


For BizTalk Adapter Pack 2013

The hotfix that resolves this issue is included in cumulative update package 1 for BizTalk Adapter Pack 2013.

For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2892600 Cumulative update package 1 for BizTalk Adapter Pack 2013

For BizTalk Adapter Pack 2010

The hotfix that resolves this issue is included in cumulative update package 3 for BizTalk Adapter Pack 2010.

For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2617150 Cumulative update package 3 for BizTalk Adapter Pack 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Workaround

To work around the issue, configure a language that is not case-sensitive for the user account.

More Information

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×