无法在 Microsoft SQL Server 2012年中创建高可用性组

文章翻译 文章翻译
文章编号: 2847723 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

当您尝试在 Microsoft SQL Server 2012年创建高可用性组时,您会收到以下错误消息:

消息 41131,级别 16,状态为 0,第 2 行
未能使可用性组availability_group联机。该操作已超时。请验证本地 Windows 服务器故障转移群集 (WSFC) 节点处于联机状态。然后,验证 WSFC 群集中存在相应的可用性的组资源。如果此问题仍然存在,可能需要删除的组中的可用性并重新创建它。

原因

如果 [NT AUTHORITY\SYSTEM] 帐户缺少 SQL Server 登录过程中,或者如果该帐户没有必要的权限来创建高可用性组,则会发生此问题。

解决方案

若要解决此问题,请使用下列方法之一。

方法 1: 使用手动步骤
  1. 在承载您的可用性的组中的副本每个 SQL Server 计算机上的 [NT AUTHORITY\SYSTEM] 帐户,在 SQL Server 中创建登录。
  2. 将 [NT AUTHORITY\SYSTEM] 帐户授予以下服务器级别权限:
    • 更改任何可用性组
    • 将 SQL 连接
    • 查看服务器状态

    注意请确保没有其他权限授予该帐户。
方法 2: 使用脚本
  1. 若要创建 [NT AUTHORITY\SYSTEM] 帐户,请在查询窗口中运行以下命令:

    USE [master]
    GO
    CREATE LOGIN [NT AUTHORITY\SYSTEM] FROM WINDOWS WITH DEFAULT_DATABASE=[master]
    GO

  2. 要授予对 [NT AUTHORITY\SYSTEM] 帐户的权限,请在查询窗口中运行以下命令:

    GRANT ALTER ANY AVAILABILITY GROUP TO [NT AUTHORITY\SYSTEM]
    GO
    GRANT CONNECT SQL TO [NT AUTHORITY\SYSTEM]
    GO
    GRANT VIEW SERVER STATE TO [NT AUTHORITY\SYSTEM]
    GO

更多信息

[NT AUTHORITY\SYSTEM] 帐户用于 SQL Server AlwaysOn 运行状况检测连接到 SQL Server 计算机并监视运行状况。创建一个可用性组时,可用性组中的主副本变为联机状态时,会启动运行状况检测。如果 [NT AUTHORITY\SYSTEM] 帐户不存在或没有足够的权限,运行状况检测而无法启动,并在创建过程中,可用性组不能到联机状态。

要确保这些权限存在无法承载可用性组的主副本的每个 SQL Server 计算机上。

注意承载 SQL Resource.dll 的资源监视器服务主机进程 (RHS.exe) 可以仅在系统帐户下运行。

请参阅自动故障转移 SQL Server 2012 AlwaysOn 环境中的问题的疑难解答 有关其他故障现象,并对自动故障转移方案进行疑难解答的详细信息。

属性

文章编号: 2847723 - 最后修改: 2013年6月7日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft SQL Server 2012 Enterprise
关键字:?
kbexpertiseinter kbprb kbsurveynew kbmt KB2847723 KbMtzh
机器翻译
重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。
点击这里察看该文章的英文版: 2847723
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com