Printing to an IPP printer fails in Windows 8

Article translations Article translations
Article ID: 2850453 - View products that this article applies to.
Expand all | Collapse all

Symptoms

If you try to print a document by using Internet Printing Protocol (IPP) on a computer that is running Windows 8, the document may not be printed.

Cause

WinHTTP in Windows 8 causes a new connection to be created for each security token of the thread that makes the connection. Even if "Keep-Alive" is specified on the connection according to RFC 2616, connections are not reused, and new connections are created for each IPP print. Although these connections will eventually time out and be disconnected, if Windows 8 keeps creating multiple connections up to the limit of the printer device before the old connections are disconnected, new connections will not be created. Therefore, printing will fail.

Note This is new behavior. It occurs because of strengthened WinHTTP internal security in Windows 8.

Status

This behavior is by design.

Properties

Article ID: 2850453 - Last Review: June 17, 2013 - Revision: 4.0
Applies to
  • Windows 8
  • Windows 8 N
  • Windows 8 Enterprise
  • Windows 8 Enterprise N
  • Windows 8 Pro
  • Windows 8 Pro N
Keywords: 
KB2850453

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com