Message d'erreur : Erreur de script Internet Explorer - Une erreur s'est produite

Traductions disponibles Traductions disponibles
Numéro d'article: 285212 - Voir les produits auxquels s'applique cet article
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous tentez d'ouvrir l'un des programmes répertoriés au début de cet article, l'un des messages d'erreur suivants peut s'afficher :
Erreur de script Internet Explorer - Une erreur s'est produite.
- ou -
Erreur de script de Internet Explorer
Une erreur est survenue sur le script de cette page.
Ligne : 574
Car : 2
Erreur : Classe non enregistrée
Code : 0
URL : msell2://c:&v=2&pid=ELLE00A&cmd=openitss&itssname=ell&path=home/home .htm

Voulez-vous continuer à exécuter des scripts sur cette page ?

Cause

Ce problème peut se produire si certains fichiers Microsoft Internet Explorer sont endommagés.

Résolution

Tentez de résoudre ce problème en redémarrant votre ordinateur. Si cela n'a aucun effet, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

Suppression des fichiers Internet temporaires

Les fichiers Internet temporaires sont des copies mises en mémoire cache des pages Web que vous ouvrez, ainsi que des fichiers supplémentaires comme des images graphiques et des vidéos. Les pages Web auxquelles vous avez accédé précédemment peuvent mettre plus longtemps à se charger la première fois que vous les ouvrez après avoir supprimé ces fichiers de la mémoire cache.

Pour supprimer les fichiers Internet temporaires, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Options Internet.
  3. Sous l'onglet Général, cliquez sur Supprimer les fichiers.
    - ou -
    Sous l'onglet Avancés, cliquez sur Paramètres, puis sur Vider le dossier.
Si le problème persiste, essayez la méthode suivante.

Réduction du nombre de couleurs utilisées par Windows

Pour réduire le nombre de couleurs que Windows utilise, procédez comme suit :
  1. Cliquez avec le bouton droit sur le bureau, cliquez sur Propriétés, puis sur l'onglet Paramètres.
  2. Dans la zone Couleurs, cliquez sur un paramètre inférieur au paramètre actuel, sur OK, puis sur Oui.

Réduction de la zone d'écran

Pour réduire la zone d'écran, procédez comme suit :
  1. Cliquez avec le bouton droit sur le bureau, cliquez sur Propriétés, puis sur l'onglet Paramètres.
  2. Dans la zone Zone écran, déplacez le curseur Zone d'écran vers une zone inférieure à la zone actuelle, cliquez sur OK, puis sur Oui.

Utilisation des valeurs par défaut des paramètres de sécurité dans Internet Explorer

Pour configurer les paramètres de sécurité d'Internet Explorer avec les valeurs par défaut, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Options Internet.
  3. Cliquez sur l'onglet Sécurité.
  4. Sous Sélectionnez une zone de contenu Web pour spécifier ses paramètres de sécurité, cliquez sur Internet.
  5. Cliquez sur Niveau par défaut.
  6. Cliquez sur Appliquer.
  7. Répétez les étapes 4 à 6 pour chaque zone de contenu Web.
  8. Cliquez sur OK.
Si le problème persiste, passez à la méthode suivante.

Réparation d'Internet Explorer

Pour réparer Internet Explorer, utilisez l'outil Réparation d'Internet Explorer :
  1. Cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.
  2. Sous l'onglet Installation/Désinstallation, cliquez sur Microsoft Internet Explorer 5, puis sur Ajouter/Supprimer.
  3. Cliquez sur l'option Réparer l'installation en cours d'Internet Explorer, puis sur OK.
Remarque Internet Explorer 5.5 est livré avec Microsoft Windows Millennium Edition (Me) ; vous ne pouvez pas le réparer à l'aide de l'outil Réparation d'Internet Explorer.

Si le problème persiste, passez à la méthode suivante.

Réinstallation d'Internet Explorer 5.5

Pour réinstaller Internet Explorer 5.5, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

Fermeture des programmes

  1. Appuyez sur CTRL+ALT+SUPPR.
  2. Dans la boîte de dialogue Fermer le programme, cliquez sur le programme à fermer, puis sur Fin de tâche.

    Remarque Ne fermez pas le programme Explorer ou Systray, car il s'agit de composants de Windows.
  3. Répétez les étapes 1 et 2 pour chaque programme en cours d'exécution.

Désinstallation d'Internet Explorer 5.5

Vous pouvez désinstaller Internet Explorer 5.5 des systèmes d'exploitation Windows suivants :
  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows NT 4.0
  • Microsoft Windows 2000
Remarque Vous ne pouvez pas désinstaller Internet Explorer 5.5 de Windows Me.

Remarque Vous devez disposer de privilèges d'administrateur pour pouvoir installer et désinstaller Internet Explorer 5.5 dans Windows NT 4.0 et Windows 2000.

Pour désinstaller Internet Explorer :
  1. Cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.
  2. Sous l'onglet Installation/Désinstallation, cliquez sur Microsoft Internet Explorer 5 et Outils Internet dans la liste des programmes installés, puis sur Ajouter/Supprimer.

    Remarque Si Microsoft Internet Explorer 5 et Outils Internet ne figurent pas dans la liste des programmes installés, lancez Setup.exe à partir du dossier "Internet Explorer\Setup."

    Si vous exécutez Windows 2000, exécutez la commande w2kexcp.exe /u à partir du dossier "Internet Explorer\\IE Unistall".
  3. Cliquez sur Rétablir la configuration précédente de Windows ou sur Avancés pour préciser tous les autres composants à supprimer, puis cliquez sur OK.
  4. Dans la boîte de dialogue Fichiers d'installation d'Internet Explorer 5 et Outils Internet ou en mode maintenance, cliquez sur OK pour restaurer la version précédente d'Internet Explorer et des composants partagés.
  5. Lorsque vous êtes invité à vérifier que vous voulez restaurer la version précédente, cliquez sur Oui.
  6. Lorsque vous êtes invité à redémarrer Windows, cliquez sur Redémarrer Windows.

Installation d'Internet Explorer 5.5

  1. Insérez le CD-ROM d'installation du programme dans le lecteur. Lorsque vous insérez le CD-ROM, maintenez la touche MAJ enfoncée pour éviter le démarrage automatique du programme d'installation.
  2. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
  3. Dans la zone Nommé, tapez ie5setup.exe.
  4. Dans la zone Rechercher dans, sélectionnez votre lecteur de CD-ROM.
  5. Cliquez sur Rechercher.
  6. Dans la fenêtre de résultats de la recherche, double-cliquez sur ie5setup.exe, puis suivez les invites à l'écran pour installer le programme.
Si le problème persiste, passez à la méthode suivante.

Suppression des dossiers relatifs à Internet

Pour supprimer les dossiers relatifs à Internet :
  1. Cliquez sur Démarrer, puis sur Arrêter.
  2. Sélectionnez Redémarrer en mode MS-DOS, puis cliquez sur OK.
  3. Si vous n'utilisez pas de fichiers de cookies pour stocker des informations pour certains sites Web, passez à l'étape suivante.

    Si vous utilisez des fichiers de cookies pour stocker des informations telles que des mots de passe, vous pouvez copier le contenu du dossier Cookies pour conserver ces informations.

    Pour copier le dossier Cookies, tapez les lignes suivantes à l'invite de commandes C:\Windows et appuyez sur ENTRÉE après chaque ligne :
    cd..
    smartdrv.exe
    md nouveau_nom_dossier
    copy c:\windows\cookies\*.* c:\windows\nouveau_nom_dossier

    nouveau-nom_dossier étant le nom du dossier dans lequel vous voulez copier le contenu du dossier Cookies.
  4. Si vous n'utilisez pas le dossier Favoris pour stocker vos liens vers des sites Web, passez à l'étape suivante.

    Si vous utilisez le dossier Favoris pour stocker vos liens vers des sites Web, vous pouvez copier le contenu du dossier Favoris pour conserver ces informations.

    Pour copier le dossier Favoris, tapez les lignes suivantes à l'invite de commandes C:\Windows et appuyez sur ENTRÉE après chaque ligne :
    cd..
    smartdrv.exe
    md nouveau_nom_dossier
    copy c:\windows\favori~1\*.* c:\windows\nouveau_nom_dossier

    nouveau-nom_dossier étant le nom du dossier dans lequel vous voulez copier le contenu du dossier Favoris.
  5. À l'invite de commandes C:\Windows, tapez les lignes suivantes en appuyant sur ENTRÉE à la fin de chaque ligne : Pour confirmer la suppression de chaque dossier, appuyez sur O, puis sur ENTRÉE.
    deltree cookies
    deltree favori~1
    deltree history
    deltree tempor~1
  6. Tapez exit, puis appuyez sur ENTRÉE pour redémarrer Windows.
Si le problème est résolu après la suppression des dossiers liées à Internet, nous ne vous conseillons pas de remplacer le contenu des nouveaux dossiers par le contenu des dossiers renommés. Si vous voulez copier le contenu des dossiers renommés, il est préférable de copier les éléments un par un, puis de tester Internet Explorer, pour s'assurer que ce fichier particulier n'est pas la cause de l'erreur du script. Pour ce faire, procédez comme suit.
  1. Cliquez avec le bouton droit sur Démarrer, puis cliquez sur Explorer.
  2. Dans le volet de gauche, double-cliquez sur le dossier Windows.
  3. Double-cliquez sur [nouveau_nom_dossier] .
  4. Dans le volet de droite, cliquez sur une ligne pour la sélectionner.
  5. Une fois la ligne sélectionnée, cliquez avec le bouton droit et choisissez Copier.
  6. Dans le volet de gauche, double-cliquez sur le dossier dans lequel vous voulez coller cette ligne : Favoris ou Cookies.
  7. Cliquez avec le bouton droit et choisissez Coller.
  8. Répétez ces étapes pour chaque dossier et pour toutes les lignes de chaque dossier.
Remarque Testez Internet Explorer après avoir copié chaque ligne. Si l'erreur de script s'affiche après la copie d'une ligne, supprimez cette ligne.

Suppression de fichiers programmes téléchargés

Pour supprimer des fichiers programmes téléchargés :
  1. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
  2. Dans la zone Nommé, tapez fichiers programmes téléchargés.
  3. Dans la zone Rechercher dans, cliquez sur Poste de travail.
  4. Cliquez sur Rechercher.
  5. Double-cliquez sur le dossier Fichiers programmes téléchargés.
  6. Cliquez avec le bouton droit sur un fichier à supprimer, puis cliquez sur Supprimer.

    Remarque Ne supprimez pas le fichier Win32 Classes du dossier Fichiers programmes téléchargés.
  7. Répétez l'étape 5 jusqu'à ce que tous les fichiers du dossier Fichiers programmes téléchargés soient supprimés, puis redémarrez l'ordinateur.

Mise à niveau vers Internet Explorer 6.

Pour effectuer la mise à niveau vers Internet Explorer 6, cliquez sur le lien ci-dessous et suivez les instructions de téléchargement (en anglais) :
http://www.microsoft.com/windows/ie/ie6/downloads/default.mspx#ENC

Plus d'informations

Pour plus d'informations sur les erreurs de script dans Internet Explorer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
308260 Procédure de dépannage des erreurs de script dans Internet Explorer


Pour plus d'informations sur la façon de télécharger et d'installer la dernière version de DirectX, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
179113 Comment faire pour télécharger et installer DirectX


L'outil Réparation d'Internet Explorer diagnostique et répare les problèmes suivants :
  • Fichiers Internet Explorer obsolètes.
  • Inscription incorrecte ou incomplète de fichiers Internet Explorer.
  • Raccourcis Internet Explorer sur le Bureau ou dans le menu Démarrer manquants ou ne fonctionnant pas correctement.

Propriétés

Numéro d'article: 285212 - Dernière mise à jour: mardi 25 juillet 2006 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Greetings 2001 Standard Edition
  • Microsoft Greetings 2002 Standard Edition
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Express 2002
  • Microsoft Picture It! Photo 2001 Premium Edition
  • Microsoft Picture It! Photo 2002 Standard Edition
  • Microsoft Picture It! Photo 2001 Premium Edition
  • Microsoft Picture It! Photo 2002 Premium Edition
  • Microsoft Picture It! 2002 Publishing Gold
  • Microsoft Picture It! Publishing 2001 Gold Edition
  • Microsoft Picture It! Publishing 2001 Silver Edition
  • Microsoft Picture It! Publishing 2001 Platinum Edition
  • Microsoft Picture It! Publishing 2002 Platinum Edition
  • Microsoft Encarta Language Learning Spanish 1.0 Standard Edition
  • Microsoft Encarta Language Learning French 1.0 Standard Edition
  • Microsoft Encarta Reference Suite 2001
Mots-clés : 
kbenv kberrmsg kbprb KB285212
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com