Řešení potíží s poškozenými dokumenty Word pro Mac

Překlady článku Překlady článku
ID článku: 285393 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek obsahuje postupy odstranění potíží, můžete identifikovat poškozené soubory v aplikaci Word pro Mac a v některých případech obnovit soubory.

Poškozené soubory dokumentů mohou způsobit neobvyklé chování jakéhokoli programu. Takové chování dochází, protože program je příjem nesprávné informace z poškozeného souboru.

Další informace

Určení poškození souboru

Poškozené soubory často způsobit chování, které není součástí návrhu programu--například, infinite přestránkování, nesprávné dokumentu rozložení a formátování nečitelné znaky na obrazovce, chybové zprávy během zpracování, zablokuje systém nebo selhání při načtení nebo zobrazení souboru nebo jakékoli jiné neobvyklé chování, které nelze považovat za normální operace program. Tyto chování může být také způsoben jinými faktory než poškozením dokumentu. Chcete-li vyloučit jiné faktory, postupujte tyto tipy poradce při potížích:
  • Zkontrolujte podobné chování v jiných dokumentech.
  • Zkontrolujte podobné chování v jiných aplikacích.
  • Převzít dotyčný soubor do jiného počítače a pokuste se chování duplikovat.
  • Použijte jiný ovladač tiskárny a pokuste se chování duplikovat. Chcete-li použít jiný ovladač tiskárny, postupujte takto:

    1. Výběr vyberte v nabídce Apple.
    2. V okně Výběr vyberte jiný ovladač tiskárny a zavřete Výběr.
    3. V aplikaci Word pro Mac Vzhled stránky vyberte v nabídce soubor na ověřte, zda je ovladač tiskárny vybraný v okně Výběr vybrán v aplikaci Word for Mac.
  • Přejmenování šablony připojené k dokumentu a pokuste chování duplikovat.
  • Spusťte počítač znovu, rozšíření vypnuta zakázat všechny programy jiných výrobců systémem (například terminate-and-stay-resident programy [TSR], správci písem a spořiče obrazovky). Pokuste chování duplikovat. Další informace o spuštění počítače s příponami vypnout klepněte na článek číslo článku databáze Microsoft Knowledge Base:
    263159Jak odstraňovat konflikty rozšíření v systému Macintosh
Pokud po provedení předchozích kroků, dojde k problému s jediného dokumentu, je dokument pravděpodobně poškozen. Pokud program neočekávaně před uzavřen soubor a povolena možnost obnovení, obnovení souboru bylo pravděpodobně vytvořeno. Tento soubor obnovení můžete použít k obnovení dotyčný soubor.

Funkce automatického obnovení v aplikaci Word Mac pokusí automaticky obnovit text z dokumentu, který byl při Word Mac přestal reagovat. Po restartování aplikace Word pro Mac po přestane reagovat (zablokuje se), dialogové okno zobrazí s následující zpráva:
Při otevírání Název souboru bylo zjištěno poškození souboru. Část tohoto dokumentu jsou možná obnovitelné. Pokus o obnovení nyní?
Poznámka: Tato zotavení může trvat delší dobu v závislosti na velikosti dokumentu a částka poškození v dokumentu.

Po obnovený dokument okamžitě pomocí příkazu Uložit jako v nabídce soubor uložte dokument pod novým názvem souboru. Tím zajistíte, že bude k dispozici pro další pokusy o obnovení původní dokument. Tato metoda automatické zotavení Odříznout všechny formátování, grafiky a objekty z dokumentu.

Jiné metody uvedené v tomto článku může povolit více původní formátování z poškozený dokument obnovit.

Další informace o funkci automatického obnovení naleznete v tématu "Zabránit ztráty z a obnova ztracených dokumentů Word" v aplikaci Word Mac Nápověda.

Jak opravě poškozeného dokumentu

Můžete se pokusit opravit poškozený dokument několika způsoby. Metodu použijete, závisí na typu a závažnosti poškození a typ chování je exhibited. I když je řada z těchto metod obvykle úspěšná, nelze obnovit každý poškozený dokument. Udržování záložní kopii dokumentu je nejlepším způsobem, jak zajistit jeho obnovení.

Následující postupy odstranění potíží jsou rozděleny do dvou částí: "Pokud soubor může být otevřen v Word pro Mac" a "Pokud soubor nemůže být otevřen v Word pro Mac." Použijte příslušné části pro danou situaci.

Pokud může být soubor otevřen v aplikaci Word pro Mac

Soubor můžete otevřít v aplikaci Word pro Mac, použijte jednu z následujících metod.

Metoda 1: Soubor převést na jiný formát

Převést soubor do jiného formátu a převést jej zpět do nativní formát.

Toto je dokument nejjednodušší a nejúplnější metodu obnovení; vždy vyzkoušejte nejprve. Uložte soubor ve formátu RTF (RICH Text Format). Tento formát zachovává formátování Word pro Mac dokumentu. Po uložení souboru v RTF znovu otevřete soubor v aplikaci Word pro Mac a převeďte ji z RTF. Pokud tato metoda úspěšná, poškození souboru odebrána během převodu.

Uložte soubor jako RTF, postupujte takto:
  1. V nabídce soubor klepněte na příkaz Uložit jako.
  2. Klepněte v seznamu Formát a potom vyberte RTF.
  3. Změnit název dokumentu. (Toto je doporučeno, takže můžete pokračovat dalších kroků pomocí původní dokument nezměněna.)
  4. Klepněte na tlačítko Uložit.
Jestliže poškození potrvá po uložení souboru ve formátu RTF, zkuste soubor uložit v následujících formátech:
  • Jiné formáty zpracování textu
  • Pouze text
Poznámka: uložení souboru ve formátu pouze text často opraví problém poškození; však všechny formátování bude ztraceno, včetně grafiky a pole kódů v aplikaci Word for Mac. Tato metoda vyžaduje další přeformátování; jej proto použít pouze po jiných formátů souborů nezdaří opravit problém.

Další informace o ztrátě jazyka pro kód Applications v aplikaci Word pro dokumenty Mac jsou převedeny do jiných formátů souborů klepněte na následující číslo článku databáze Microsoft Knowledge Base:
184153WD98: Ztracené po převodu na jiný formát dokumentu kódu VBA

Metoda 2: Kopírování veškerého obsahu kromě posledního znaku konce odstavce do nového dokumentu

Word Mac přidružuje širokou škálu formátování poslední značku odstavce zejména oddílu a formátování stylu. Jestliže zkopírujete veškerý obsah v souboru s výjimkou posledního odstavce do nového souboru, může být ponechána poškození v původním dokumentu.

Zkopírujte celý obsah kromě posledního znaku konce odstavce v dokumentu, postupujte takto:
  1. Otevřete dokument, který se projevuje liché chování.
  2. V nabídce Úpravy klepněte na tlačítko Vybrat vše.
  3. S dokumentem, vybrána stiskněte klávesu směrové COMMMAND + SHIFT + ŠIPKA vlevo. (Z výběru odebrány pouze poslední značku odstavce.)
  4. V nabídce Úpravy vyberte příkaz Kopírovat.
  5. V nabídce soubor vyberte Nový dokument.
  6. V novém dokumentu vyberte Vložit v nabídce Úpravy.

    Poznámka: V novém dokumentu pravděpodobně nutné znovu použít formátování oddílu nebo formátování stylu.

Metoda 3: Kopírování nepoškozených souboru do nového souboru

Někdy můžete určit umístění poškození v souboru na soubor nebo testování souboru určit chování dojde. Zkopírujte buď jednu stránku na čas nebo řadu stránek do nového souboru je jiným způsobem, jak zjistit, jaké oblasti soubor je poškozen. Nový soubor uložit a otestujte pro původní chování. Pokud chování nedojde, pokračujte v kopírování stránky, uložení a testování dokud původní chování.

Pokud Najít co oblasti soubor je poškozen, zkopírujte vše kromě poškozené části nový soubor a postupujte takto k rekonstrukci dokumentu:
  1. Zkopírujte nepoškozeného částí dokumentu a vložit do nového souboru (pravděpodobně není chcete vyberte značku odstavce konečný výběr, protože některé nesprávné informace mohou obsahovat tento znak konce odstavce).
  2. Uložit kopii poškozeného dokumentu ve formátu pouze text.
  3. Otevřete soubor pouze text.
  4. Zkopírujte text z tohoto souboru a vložit jej do souboru, který obsahuje nepoškozenou část vašeho souboru.
  5. Přeformátovat oddíly dokumentu, který jste vložili v kroku 4 a uložit obnovený dokument.

Pokud soubor nemůže být otevřen v aplikaci Word pro Mac

V aplikaci Word nemůže otevřít soubor pro Mac, použijte jednu z následujících metod podle potřeby.

Metoda 1: Vložení souboru do prázdný dokument

Pokud nelze otevřít soubor zkopírujte text (s výjimkou značka odstavce konečný), pravděpodobně vložení souboru do nového dokumentu. To vloží nové značku konečného odstavce do souboru opravované. Postupujte takto:
  1. Vytvořit nový dokument založený na šabloně Normal.
  2. V nabídce Vložit klepněte na soubor. Vyberte poškozený dokument a potom klepněte na tlačítko OK.

Metoda 2: Používat příkaz Vložit propojení pro otevření dokumentu s odkaz

Tato metoda používá k vytvoření propojení "fiktivní" dokumentu a přepne propojení mezi "fiktivní" dokumentu a poškozený dokument.

Takto operace vložení propojení použít k otevření poškozeného dokumentu:
  1. Zavřete všechny otevřené dokumenty Word pro Mac a otevřete nový prázdný dokument.
  2. Typ Test.
  3. Vyberte slovo Test. V nabídce Úpravy klepněte na tlačítko Kopírovat.
  4. V nabídce soubor klepněte na příkaz Nový a otevřete nový prázdný dokument.
  5. V nabídce Úpravy klepněte na příkaz Vložit jinak. V dialogovém okně Vložit jinak klepněte na příkaz Vložit propojení. V poli Typ klepněte na položku Formátovaný Text (RTF) a klepněte na tlačítko OK.
  6. V nabídce Úpravy příkaz propojení.
  7. V dialogovém okně propojení klepněte na tlačítko Změnit zdroj. V dialogovém okně Otevřít vyhledejte a vyberte dokument, který chcete obnovit. Klepněte na tlačítko Otevřít a potom klepněte na tlačítko OK.
  8. Po otevření dokumentu klepněte v nabídce soubor na příkaz Uložit jako. Zadejte nový název dokumentu a potom klepněte na tlačítko Uložit.
  9. Otevření dokumentu v nabídce Úpravy klepněte na příkaz propojení.
  10. V dialogovém okně propojení klepněte na příkaz Zrušit propojení. V dialogovém okně, které se zobrazí klepněte na tlačítko Ano přerušit propojení.
Poznámka: Po propojení přerušeno, měli byste uložit dokument před jej zavřít nebo ji upravit.

Metoda 3: Otevřete soubor pomocí "Obnovení textu z libovolného souboru"

Jako poslední možnost můžete použít zvláštní převaděč "Obnovení textu z libovolného souboru" ručně otevírání poškozených dokumentů. Tento převaděč odebere veškeré formátování, grafiky a vložené objekty ze souboru a ponechá pouze čitelného textu (znaky ASCII). Kvůli způsobu, jakým Word Mac dokumentu soubory jsou uspořádány a uloženy může být text disjointed nebo duplikovány.

S dokonce nejjednodušší soubory značné přeformátování je vyžadován. S menší soubory můžete otevřít nový druhý dokument a zkopírovat a vložit text ze obnovený dokument do nového dokumentu protože tak mnohem nežádoucí text obnovit.

Použít převaděč "Obnovení textu z libovolného souboru" otevření dokumentu, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Otevřít.
  2. V seznamu Zobrazit klepněte na příkaz Obnovení textu z libovolného souboru.
  3. Vyhledejte složku obsahující poškozený soubor a potom vyberte soubor.
  4. Klepněte na tlačítko Otevřít.
Poznámka: obnovení proces může nějakou dobu trvat, v závislosti na velikosti dokumentu a typ poškození. Ihned po dokončení obnovení je v nabídce soubor klepněte na tlačítko Otevřít a změnit Zobrazit soubory typu zpět na Dokumenty Word nebo Vyjádření soubory.

TIP: v tomto okamžiku uložit obnovený soubor s novým názvem. To zabrání náhodnému přepsání původního dokumentu a zajistí původní dokument zůstává k dispozici pro ostatní pokusů o zotavení.

Metoda 4: Otevření jako kopie

Otevřete kopii poškozeného dokumentu, postupujte takto:
  1. Zavřete všechny otevřené dokumenty.
  2. V nabídce soubor klepněte na tlačítko Otevřít.
  3. Otevřít seznamu vyberte Kopírovat.
  4. Vyberte poškozený soubor.
  5. Klepněte na tlačítko Otevřít.

Vlastnosti

ID článku: 285393 - Poslední aktualizace: 29. ledna 2007 - Revize: 2.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 2004 for Mac
  • Microsoft Word X pro počítače Macintosh
  • Microsoft Word 2001 pro počítače Mac
Klíčová slova: 
kbmt kbinfo KB285393 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:285393

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com