Cómo solucionar problemas de documentos dañados de Word para Mac

Seleccione idioma Seleccione idioma
Id. de artículo: 285393 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Este artículo proporciona procedimientos de solución de problemas que puede utilizar para identificar los archivos dañados de Microsoft Word para Mac y, en algunos casos, recuperar dichos archivos.

Archivos de documentos dañados pueden hacer que cualquier programa que muestre un comportamiento inusual. Este comportamiento se produce porque el programa está recibiendo información incorrecta de un documento dañado.

Más información

Cómo identificar un archivo dañado

Archivos dañados a menudo causan el comportamiento que no forma parte del diseño del programa, por ejemplo, repaginación infinita, diseño de un documento incorrecto y el formato, caracteres ilegibles en la pantalla, mensajes de error durante el procesamiento, el sistema se bloquea o produce un error al cargar o ver el archivo, o cualquier otro comportamiento inusual que no pueda atribuirse al funcionamiento normal del programa. Estos comportamientos también pueden deberse a factores distintos de documento dañado. Para descartar otros factores, siga estas sugerencias para solucionar problemas:
  • Busque un comportamiento similar en otros documentos.
  • Busque un comportamiento similar en otros programas.
  • Llevar el archivo en cuestión a otro equipo e intente repetir el comportamiento.
  • Utilizar un controlador de impresora diferente e intentar duplicar el comportamiento. Para utilizar un controlador de impresora diferente, siga estos pasos:

    1. En el menú Apple , seleccione selector de campos .
    2. En el selector de campos, seleccione otro controlador de impresora y, a continuación, cierre el selector de campos.
    3. En Word para Mac, seleccione Configurar página en el menú archivo , para comprobar que el controlador de impresora que ha seleccionado en el selector está activado en Word para Mac.
  • Cambiar el nombre de las plantillas que se adjuntan al documento y, a continuación, intente reproducir el comportamiento.
  • Inicie el equipo nuevo, con las extensiones desactivadas para deshabilitar los programas de terceros que se están ejecutando (por ejemplo, los programas terminate-and-stay-resident [TSR], administradores de fuentes y protectores de pantalla). A continuación, intente reproducir el comportamiento. Para obtener información adicional acerca de cómo iniciar el equipo con las extensiones de apagado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    263159 Cómo solucionar conflictos de extensiones en Macintosh
Si el problema se produce sólo con un único documento después de realizar los pasos anteriores, probablemente está dañado el documento. Si el programa se cierre inesperadamente antes de cerrar el archivo y la opción Autorrecuperación está habilitada, puede se haya creado un archivo de Autorrecuperación. Puede utilizar este archivo de Autorrecuperación para recuperar el archivo en cuestión.

La función de Autorrecuperación de Word para Mac intenta recuperar automáticamente el texto de un documento que estaba abierto cuando Word para Mac ha dejado de responder. Cuando reinicie Word para Mac después de que deja de responder (se bloquea), se mostrará un cuadro de diálogo con el siguiente mensaje:
Word encontró daños en archivos al abrir el Nombre de archivo. Parte de este documento podría recuperarse. ¿Intentar la recuperación ahora?
Nota: esta recuperación puede tardar algún tiempo, dependiendo del tamaño del documento y el importe de los daños en el documento.

Una vez recuperado el documento, inmediatamente utiliza el comando Guardar como en el menú archivo para guardar el documento con un nuevo nombre de archivo. Esto garantiza que el documento original estará disponible para otros intentos de recuperación. Este método de recuperación automática tiras de formato, gráficos y objetos del documento de todos.

Otros métodos que se enumeran más adelante en este artículo pueden permitirle recuperar más de su formato original del documento dañado.

Para obtener más información acerca de la función de Autorrecuperación, vea el tema "Evitar la pérdida de y recuperar perdido documentos de Word" en Word para la Ayudade Mac.

Cómo corregir un documento dañado

Existen varias técnicas que puede utilizar para intentar corregir un documento dañado. El método que utilice depende del tipo y la gravedad de los daños y el tipo de comportamiento que se presenta. Aunque muchos de estos métodos suelen tener éxito, no todos los documentos dañados pueden recuperarse. Mantener una copia de seguridad de un documento es la mejor manera de garantizar su recuperación.

Los siguientes procedimientos de solución de problemas se dividen en dos secciones: "Si el archivo puede ser abierto en Word para Mac" y "Mac si el archivo no puede ser abierto en Word para". Utilice la sección apropiada para su situación.

Si el archivo se puede abrir en Word para Mac

Si puede abrir el archivo en Word para Mac, utilice uno de los métodos siguientes.

Método 1: Convertir el archivo a otro formato

Convertir el archivo a otro formato y, a continuación, volverla a convertir a su nativo formato.

Éste es el método de recuperación de documentos más completo; Inténtelo siempre en primer lugar. Guarde el archivo en formato de texto enriquecido (RTF). Este formato mantiene el formato en el documento de Word para Mac. Una vez guardado el archivo en formato RTF, vuelva a abrir el archivo en Word para Mac y, a continuación, convertirlo en RTF. Si este método se realiza correctamente, se quita el daño del archivo durante la conversión.

Para guardar el archivo como RTF, siga estos pasos:
  1. En el menú archivo , haga clic en Guardar como.
  2. Haga clic en la lista de formato y, a continuación, seleccione el Formato de texto enriquecido.
  3. Cambiar el nombre del documento. (Se recomienda para que pueda continuar con el resto de pasos utilizando el documento original sin modificar.)
  4. Haga clic en Guardar.
Si el daño persiste después de guardar el archivo como RTF, pruebe a guardar el archivo en uno de los siguientes formatos de archivo:
  • Otros formatos de procesamiento de textos
  • Sólo texto
Nota: guardar un archivo en formato de sólo texto con frecuencia corrige el problema de daños; Sin embargo, todo el formato se pierde, incluidos los códigos de campo y gráficos en Word para Mac. Este método requiere dar más formato; por lo tanto, utilícelo sólo cuando otros formatos de archivo no consigan corregir el problema.

Para obtener información adicional acerca de la pérdida de Visual Basic para Aplicaciones de código en Word para documentos de Mac que se han convertido a otros formatos de archivo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
184153WD98: Código VBA perdido después de convertir a otro formato de documento

Método 2: Copiar todo excepto la última marca de párrafo en un documento nuevo

Word para Mac asocia una amplia variedad de formatos con la última marca de párrafo especialmente de secciones y el formato de estilo. Si copia todo, en el archivo, excepto la última marca de párrafo, en un archivo nuevo, el posible daño se quede en el documento original.

Para copiar todo excepto la última marca de párrafo en el documento, siga estos pasos:
  1. Abra el documento que exhibe un comportamiento extraño.
  2. En el menú Edición , haga clic en Seleccionar todo.
  3. Con el documento seleccionado, presione la tecla direccional de comandos a la izquierda. (Esto elimina la última marca de párrafo de la selección.)
  4. En el menú Edición , seleccione Copiar.
  5. En el menú archivo , seleccione Nuevo documento.
  6. En el nuevo documento, seleccione Pegar en el menú Edición .

    Nota: en el nuevo documento, tendrá que volver a aplicar el formato de la sección o el formato de estilo.

Método 3: Copiar las partes no dañadas del archivo en un archivo nuevo

En ocasiones, puede determinar la ubicación de los daños en el archivo por mirar el archivo o probar el archivo para determinar cuándo se produce el comportamiento. Otra manera de determinar qué área del archivo está dañado es copiar alguna de las una páginas a una hora o una serie de páginas en un archivo nuevo. Guarde el nuevo archivo y, a continuación, pruebe el comportamiento original. Si no se produce el comportamiento, continuar copiando páginas, guardar y pruebas hasta que se produzca el comportamiento original.

Si puede encontrar el área del archivo está dañado, puede copiar todo excepto la parte dañada a un nuevo archivo y, a continuación, siga estos pasos para reconstruir el documento:
  1. Copie las partes no dañadas del documento y pegarlos en un nuevo archivo (puede no desea seleccionar la marca de párrafo final de esta selección, ya que esa marca de párrafo puede contener información incorrecta).
  2. Guardar una copia del documento dañado en formato de sólo texto.
  3. Abra el archivo de sólo texto.
  4. Copie el texto de este archivo y, a continuación, péguelo en el archivo que contiene la parte no dañada del archivo.
  5. Cambiar el formato de las secciones del documento que ha pegado en el paso 4 y, a continuación, guarde el documento recuperado.

Si no se puede abrir el archivo en Word para Mac

Si no se puede abrir el archivo en Word para Mac, utilice uno de los métodos siguientes según corresponda.

Método 1: Insertar el archivo en un documento en blanco

Si no se puede abrir un archivo para copiar todo el texto (excepto la última marca de párrafo), puede ser capaz de insertar el archivo en un documento nuevo. Este modo inserta una nueva marca de párrafo final en el archivo que está corrigiendo. Para ello, siga estos pasos:
  1. Crear un nuevo documento basado en la plantilla Normal.
  2. En el menú Insertar , haga clic en archivo. Seleccione el documento dañado y, a continuación, haga clic en Aceptar.

Método 2: Usar el comando de Pegar vínculo para abrir el documento con un vínculo

Este método utiliza un documento "ficticio" para crear un vínculo y, a continuación, cambia el vínculo entre el documento "ficticio" y el documento dañado.

Siga estos pasos para usar una operación de Pegar vínculo para abrir un documento dañado:
  1. Cierre todos los documentos abiertos en Word para Mac y, a continuación, abra un nuevo documento en blanco.
  2. Tipo Prueba.
  3. Seleccione la palabra prueba. En el menú Edición , haga clic en Copiar.
  4. En el menú archivo , haga clic en nuevo y, a continuación, abra un nuevo documento en blanco.
  5. En el menú Edición , haga clic en Pegado especial. En el cuadro de diálogo Pegado especial , haga clic en Pegar vínculo. En el cuadro como , haga clic en Texto con formato (RTF)y, a continuación, haga clic en Aceptar.
  6. En el menú Edición , haga clic en vínculos.
  7. En el cuadro de diálogo vínculos , haga clic en Cambiar origen. En el cuadro de diálogo Abrir , busque y seleccione el documento que desea recuperar. Haga clic en Abrir y, a continuación, haga clic en Aceptar.
  8. Cuando se abre el documento, haga clic en Guardar como en el menú archivo . Escriba un nombre nuevo para el documento y, a continuación, haga clic en Guardar.
  9. Con el documento abierto, haga clic en vínculos en el menú Edición .
  10. En el cuadro de diálogo vínculos , haga clic en Romper vínculos. En el cuadro de diálogo que aparece, haga clic en para romper el vínculo.
Nota: después de que se rompe el vínculo, debe guardar el documento antes de cerrarla o modificarlo.

Método 3: Abrir el archivo mediante el uso de "Recuperar texto de cualquier archivo"

Como último recurso, puede utilizar el convertidor "Recuperar texto de cualquier archivo" especial para abrir manualmente un documento dañado. Este convertidor todos los formatos gráficos y objetos incrustados en el archivo elimina y deja sólo el texto legible (caracteres ASCII). Debido a la forma en que Word para Mac archivos de documento se organizan y se guardan, el texto puede ser inconexos o duplicado.

Incluso los archivos más simple, es necesario volver a dar formato considerable. Con archivos más pequeños, es aconsejable abrir un segundo documento nuevo y copiar y pegar texto desde el documento recuperado en el nuevo documento, porque no hay mucho texto no deseado recuperado.

Para utilizar el convertidor "Recuperar texto de cualquier archivo" para abrir un documento, siga estos pasos:
  1. En el menú Archivo, haga clic en Abrir
  2. Haga clic en la lista Mostrar y, a continuación, haga clic en Recuperar texto de cualquier archivo.
  3. Busque la carpeta que contiene el archivo dañado y, a continuación, seleccione el archivo.
  4. Haga clic en Abrir.
Nota: el proceso de recuperación puede tardar algún tiempo, dependiendo del tamaño del documento y el tipo de daño. Tan pronto como la recuperación es completa, haga clic en Abrir en el menú archivo y, a continuación, cambie la Lista Tipo de archivo a Documentos de Word o Archivos legibles.

Sugerencia: guardar el archivo recuperado con un nuevo nombre en este momento. Esto impide que pueda sobrescribir accidentalmente el documento original y se garantiza que el documento original sigue estando disponible para otros intentos de recuperación.

Método 4: Abrir como copia

Para abrir una copia de un documento dañado, siga estos pasos:
  1. Cierre todos los documentos abiertos.
  2. En el menú archivo , haga clic en Abrir .
  3. Seleccione Copiar en la lista abierta .
  4. Seleccione el archivo dañado.
  5. Haga clic en Abrir.

Propiedades

Id. de artículo: 285393 - Última revisión: domingo, 28 de abril de 2013 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Macintosh
Palabras clave: 
dftsdahomeportal kbinfo kbmt KB285393 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 285393

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com