Comment faire pour résoudre les documents endommagés dans Word pour Mac

Traductions disponibles Traductions disponibles
Numéro d'article: 285393 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article fournit les procédures dépannage que vous pouvez utiliser pour identifier les fichiers endommagés dans Microsoft Word pour Mac et, dans certains cas, récupérer ces fichiers.

Fichiers documents endommagés peuvent entraîner un comportement inhabituel des programmes. Ce problème se produit car le programme reçoit des informations incorrectes du fichier endommagé.

Plus d'informations

Comment faire pour identifier un fichier endommagé

Fichiers endommagés souvent provoquer comportement qui n'est pas partie de la structure de programme--par exemple, Repagination en infinie, la disposition du document incorrect et mise en forme, les caractères illisibles à l'écran, les messages d'erreur au cours de traitement, les blocages du système ou se bloque lorsque vous chargez ou affichez le fichier, ou tout autre comportement inhabituel qui ne peut pas être attribué à l'opération normale du programme. Ces problèmes peuvent également être provoqués par fait autre que le document est endommagé. Pour éliminer les autres facteurs, suivez ces conseils dépannage :
  • Recherchez des comportements similaires dans d'autres documents.
  • Recherchez des comportements similaires dans d'autres programmes.
  • Transférez le fichier en question sur un autre ordinateur et tente de reproduire le comportement.
  • Utilisez un autre pilote d'imprimante et tente de reproduire le comportement. Pour utiliser un autre pilote d'imprimante, procédez comme suit :

    1. Sélectionnez Sélecteur de champs dans le menu Apple .
    2. Dans le Sélecteur de champs , sélectionnez un autre pilote d'imprimante et puis fermez le Sélecteur de champs .
    3. Dans Word pour Mac, sélectionnez mise en page dans le menu Fichier , pour vérifier que le pilote d'imprimante sélectionné dans le Sélecteur de champs est sélectionné dans Word pour Mac.
  • Renommez les modèles qui sont attachés au document, puis essayez de reproduire le comportement.
  • Démarrez l'ordinateur, avec des extensions désactivées pour désactiver les programmes tiers qui s'exécutent (comme terminer-et-rester-résidant en programmes [programmes résidents], les gestionnaires de police et veille). Puis essayez de reproduire le comportement. Pour plus d'informations façon de démarrer l'ordinateur avec des extensions désactiver, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
    263159 Comment faire pour résoudre conflits extension sur le Macintosh
Si le problème se produit uniquement avec un seul document après avoir effectué les étapes précédentes, votre document est probablement endommagé. Si le programme ferme de façon inattendue avant le fichier a été fermé et l'option de récupération automatique a été activée, un fichier de récupération automatique peut avoir été créé. Vous pouvez utiliser ce fichier de récupération automatique pour récupérer le fichier en question.

La fonctionnalité Récupération automatique dans Word pour Mac tente de récupérer automatiquement du texte d'un document qui était ouvert lorsque Word pour Mac ne répond plus. Lorsque vous redémarrez Word pour Mac après que qu'il cesse de répondre (se bloque), une boîte de dialogue va s'afficher avec le message suivant :
Word a rencontré endommagement de fichiers lors de l'ouverture de nom de fichier . Une partie de ce document peut être récupérée. Tentative de récupération maintenant ?
Remarque : cette récupération peut prendre quelques minutes, selon la taille du document et le montant des dommages dans le document.

Après que le document récupéré, immédiatement utilisez la commande Enregistrer sous dans le menu Fichier pour enregistrer le document sous un nouveau nom de fichier. Cela garantit que le document d'origine sera disponible pour autres tentatives de récupération. Cette méthode de récupération automatique supprime tout mise en forme, graphismes et objets à partir du document.

Autres méthodes répertoriées plus loin dans cet article peuvent vous autorise à récupérer plus de votre mise en forme d'origine à partir du document endommagé.

Pour plus d'informations sur la fonctionnalité de récupération automatique, consultez la rubrique « empêcher perte de Word et récupérer perte documents » dans Word pour Mac de l'aide .

Comment faire pour corriger un document endommagé

Il existe plusieurs techniques que vous pouvez utiliser pour essayer de corriger un document endommagé. La méthode que vous utilisez varie selon le type et la gravité des dommages et le type de comportement est apparu. Bien que la plupart des ces méthodes réussissent régulièrement, pas tous les documents endommagés peuvent être récupérés. Conserver une copie de sauvegarde d'un document est le meilleur moyen pour garantir la récupération.

Les procédures de dépannage suivantes sont divisées en deux sections: « si le fichier peut être ouvert dans Word pour Mac » et Mac » si le fichier ne peut pas être ouvert dans Word pour. » Utilisez la section appropriée à votre cas.

Si le fichier peut être ouvert dans Word pour Mac

Si vous pouvez ouvrir le fichier dans Word pour Mac, utilisez une des méthodes suivantes.

Méthode 1: convertir le fichier en un autre format

Convertir le fichier vers un autre format et puis convertissez-le à son format natif.

Il s'agit de la méthode de récupération de document plus simple et plus complète ; toujours essayez-le tout d'abord. Enregistrez le fichier de format (RICH Text). Ce format conserve la mise en forme dans votre document Word pour Mac. Après avoir enregistré le fichier en format RTF, rouvrez le fichier dans Word pour Mac et puis convertissez-le de RTF. Si cette méthode réussit, ce qui endommageait le fichier est supprimé pendant la conversion.

Pour enregistrer le fichier en tant que format RTF, procédez comme suit :
  1. Dans le menu Fichier , cliquez sur Enregistrer sous .
  2. Cliquez sur la liste Format , puis sélectionnez Format RTF .
  3. Modifier le nom du document. (Il est recommandé afin que vous pouvez continuer à l'aide le document d'origine non modifiée avec les autres étapes.)
  4. Cliquez sur Enregistrer .
Si les dommages persiste après avoir enregistré le fichier en tant que format RTF, essayez d'enregistrez le fichier dans un des formats de fichier suivants :
  • Autres formats de traitement de texte
  • Texte uniquement
Remarque : enregistrement d'un fichier au format texte-uniquement fréquemment corrige le problème dommages ; Cependant, toutes les mises en forme est perdues, y compris les graphismes et le champ codes dans Word pour Mac. Cette méthode nécessite le reformatage plus ; par conséquent, l'utiliser uniquement après que les autres formats de fichier vain corriger le problème.

Pour plus d'informations sur la perte de Visual Basic pour Applications dans Word pour les documents Mac sont convertis en d'autres formats de fichier, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft. :
184153 WD98 : code VBA perdu après la conversion sur un autre format de document

Méthode 2: copier tout sauf la dernière sélectionnez paragraphe vers un nouveau document

Word pour Mac associe un large éventail de mise en forme à la marque paragraphe dernière, particulièrement section et mise en forme du style. Si vous copiez tout dans le fichier, sauf la dernière marque de paragraphe dans un nouveau fichier, elle peut être laissée derrière dans le document d'origine.

Pour copier tout sauf la dernière marque de paragraphe dans le document, procédez comme suit :
  1. Ouvrez le document qui présente le comportement étrange.
  2. Dans le menu Edition , cliquez sur Sélectionner tout .
  3. Avec le document sélectionné, appuyez sur touche directionnelle commande + MAJ + gauche. (Cela supprime la dernière marque de paragraphe de la sélection.)
  4. Dans le menu Edition , sélectionnez copier .
  5. Dans le menu Fichier , sélectionnez un nouveau document .
  6. Dans le nouveau document, sélectionnez Coller dans le menu Edition .

    Remarque : dans le nouveau document, vous devrez peut-être réappliquer la mise en forme de section ou d'une mise en forme du style.

Méthode 3: copier des parties non endommagées du fichier dans un fichier

Parfois, vous pouvez déterminer la localisation des dégâts dans votre fichier en consultant le fichier ou de test le fichier pour déterminer si le problème se produit. Un autre moyen de déterminer le zone du fichier est endommagé est de copier soit une page à une heure ou une série de pages dans un nouveau fichier. Enregistrez le nouveau fichier et tester le comportement d'origine. Si le problème ne se produit, continuez à copier les pages, l'enregistrement et le test jusqu'à ce que le comportement d'origine se produise.

Si vous pouvez trouver la zone du fichier est endommagé, vous pouvez copiez tout sauf la partie endommagée dans un nouveau fichier et puis procédez comme suit pour reconstruire votre document :
  1. Copier les parties de votre document intacte et collez-les dans un nouveau fichier (vous peut ne pas souhaitez sélectionner la dernière marque de paragraphe de cette sélection, car cette marque de paragraphe susceptibles de contenir des informations incorrectes).
  2. Enregistrer une copie du document endommagé au format texte-uniquement.
  3. Ouvrez le fichier en texte uniquement.
  4. Copier le texte à partir de ce fichier et puis collez-le dans le fichier qui contient la partie intacte de votre fichier.
  5. Remettre en forme les sections du document que vous avez collé dans l'étape 4 et puis enregistrez le document récupéré.

Si le fichier ne peut pas être ouvert dans Word pour Mac

Si vous ne pouvez pas ouvrir le fichier dans Word pour Mac, utiliser une des méthodes suivantes comme approprié.

Méthode 1: Insérer le fichier dans un document

Si vous ne pouvez pas ouvrez un fichier à copier tout le texte (sauf la dernière marque de paragraphe), vous pourrez insérer dans un nouveau document. Cela insère une nouvelle marque de paragraphe finale sur le fichier que vous corrigez. Pour ce faire, procédez comme suit :
  1. Créer un nouveau document basé sur le modèle Normal.
  2. Dans le menu Insertion , cliquez sur fichier . Sélectionnez le document endommagé, puis cliquez sur OK .

Méthode 2: utiliser la commande de liaison coller pour ouvrir le document avec un lien

Cette méthode utilise un document "factice" pour créer un lien et puis active le lien entre le document "factice" et le document endommagé.

Procédez comme suit pour utiliser une opération de collage-lien pour ouvrir un document endommagé
  1. Fermez tous les ouvrir des documents dans Word pour Mac et puis ouvrez un nouveau document vierge.
  2. Type de test .
  3. Sélectionnez le mot test . Dans le menu Edition , cliquez sur Copier .
  4. Dans le menu Fichier , cliquez sur Nouveau , puis ouvrez un nouveau document vierge.
  5. Dans le menu Edition , cliquez sur Collage spécial . Dans la boîte de dialogue Collage spécial , cliquez sur Coller avec liaison . Dans la zone Sous , cliquez sur texte mis en forme (RTF) , puis cliquez sur OK .
  6. Dans le menu Edition , cliquez sur liaisons .
  7. Dans la boîte de dialogue Liaisons , cliquez sur Modifier la source . Dans la boîte de dialogue Ouvrir , recherchez et sélectionnez le document que vous souhaitez récupérer. Cliquez sur Ouvrir , puis cliquez sur OK .
  8. Lorsque le document s'ouvre, cliquez sur Enregistrer sous dans le menu Fichier . Tapez un nouveau nom pour le document, puis cliquez sur Enregistrer .
  9. Avec le ouvert document, cliquez sur liens dans le menu Edition .
  10. Dans la boîte de dialogue Liaisons , cliquez sur rompre les liaisons . Dans la boîte de dialogue qui s'affiche, cliquez sur Oui pour rompre la liaison.
Remarque : après que le lien est rompu, vous devez enregistrer le document avant de fermer ou modifiez-le.

Méthode 3: ouvrir le fichier à l'aide de récupération de texte à partir d'un fichier

En dernier ressort, vous pouvez utiliser convertisseur la spécial « récupération texte de tout type de fichier pour ouvrir manuellement des documents endommagés. Ce convertisseur supprime tout mise en forme, graphismes et objets incorporés à partir du fichier et conserve uniquement lisible texte (caractères ASCII). En raison de la façon dont Word pour les fichiers de document Mac sont organisées et enregistré, le texte peut être dissociée ou dupliqué.

Même les fichiers plus simple, en le reformatant considérable est obligatoire. Avec des fichiers plus petits, vous souhaiterez Ouvrez un nouveau document deuxième et la copie et collez texte à partir du document récupéré dans le nouveau document, étant il du tellement indésirable texte récupéré.

Pour utiliser le convertisseur « récupérer à partir de tout fichier texte » pour ouvrir un document, procédez comme suit :
  1. Dans le menu Fichier , cliquez sur Ouvrir .
  2. Cliquez sur la liste Afficher , puis cliquez sur récupérer le texte de tout fichier .
  3. Recherchez le dossier qui contient le fichier endommagé et sélectionnez le fichier.
  4. Cliquez sur Ouvrir .
Remarque : le processus de récupération peut prendre quelques minutes, selon la taille du document et le type de dommages. Dès que la récupération est terminée, cliquez sur Ouvrir dans le menu fichier et puis rétablir type de fichiers documents Word ou fichiers visu .

TIP : enregistrez le fichier récupéré avec un nouveau nom à ce stade. Cela vous empêche d'écraser accidentellement le document d'origine et garantit que le document d'origine reste disponible pour les autres tentatives de récupération.

Méthode 4: ouvrir en tant que copie

Pour ouvrir une copie d'un document endommagé, procédez comme suit :
  1. Fermez toutes les documents.
  2. Cliquez sur Ouvrir dans le menu Fichier .
  3. Sélectionnez copie de la liste Ouvrir .
  4. Sélectionnez le fichier endommagé.
  5. Cliquez sur Ouvrir .

Propriétés

Numéro d'article: 285393 - Dernière mise à jour: lundi 29 janvier 2007 - Version: 2.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 2004 for Mac
  • Microsoft Word X pour Mac
  • Microsoft Word 2001 pour Mac
Mots-clés : 
kbmt kbinfo KB285393 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 285393
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com