Come risolvere i problemi relativi a documenti danneggiati in Word per Mac

Traduzione articoli Traduzione articoli
Identificativo articolo: 285393 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritte le procedure di risoluzione dei problemi che Ŕ possibile utilizzare per identificare i file danneggiati in Microsoft Word per Mac e in alcuni casi, ripristinare tali file.

I file danneggiati determinano comportamenti anomali nei programmi. Questo comportamento si verifica perchÚ la ricezione di informazioni non corrette dal file danneggiato.

Informazioni

Come identificare un File danneggiato

File danneggiati determinano spesso comportamento che non fa parte del programma, ad esempio, impaginazione, layout di documento non corretti e formattazione, caratteri illeggibili, messaggi di errore durante l'elaborazione, il sistema si blocchi o arresti anomali del sistema durante il caricamento o visualizzare il file o qualsiasi altro comportamento inusuale non attribuibile al normale funzionamento del programma. Questi comportamenti possono anche essere causati da altri fattori. Per escludere altri fattori, attenersi ai suggerimenti sulla risoluzione dei problemi:
  • Controllo per un comportamento simile in altri documenti.
  • Controllo per un comportamento simile in altri programmi.
  • Il file in questione in un altro computer e tentare di riprodurre il comportamento.
  • Utilizzare un driver di stampante diverso e tentare di riprodurre il comportamento. Per utilizzare un driver di stampante diverso, attenersi alla seguente procedura:

    1. Selezionare selezione dal menu Apple .
    2. Nella finestra di selezione, selezionare un driver di stampante diverso e quindi chiudere la finestra di selezione.
    3. In Word per Mac, selezionare Imposta pagina dal menu File , per verificare che il driver della stampante selezionata in selezione sia selezionato in Word per Mac.
  • Rinominare tutti i modelli che sono associati al documento e quindi si tenta di riprodurre il comportamento.
  • Avviare di nuovo il computer con le estensioni disattivate per disattivare i programmi di terze parti che sono in esecuzione (ad esempio terminate-and-stay-resident programmi TSR, gestori di caratteri e screen saver). Quindi tentare di riprodurre il comportamento. Per ulteriori informazioni su come avviare il computer con le estensioni off, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
    263159 Come risolvere i conflitti di estensione in Macintosh
Se il problema si verifica solo con un unico documento dopo aver eseguito i passaggi precedenti, il documento Ŕ probabilmente danneggiato. Se viene chiuso improvvisamente prima che il file Ŕ stato chiuso e l'opzione di salvataggio automatico Ŕ abilitata, Ŕ possibile che un file di salvataggio automatico Ŕ stato creato. ╚ possibile utilizzare questo file di salvataggio automatico per ripristinare il file in questione.

La funzionalitÓ di salvataggio automatico in Word per Mac tenta di ripristinare automaticamente il testo da un documento aperto all'arresto di Word per Mac. Quando si riavvia Word per Mac dopo che non risponde (si blocca), una finestra di dialogo verrÓ visualizzata il seguente messaggio:
Rilevato file danneggiato durante l'apertura del Nome del File. Parte di questo documento potrebbe essere recuperata. Tenta il ripristino?
Nota: questo ripristino potrebbe richiedere alcuni minuti, a seconda delle dimensioni del documento e la quantitÓ di danni nel documento.

Dopo il ripristino del documento, utilizzare immediatamente il comando Salva con nome dal menu File per salvare il documento con un nuovo nome file. In questo modo che il documento originale sarÓ disponibile per altri tentativi di recupero. Questo metodo di ripristino automatico rimuove la formattazione, grafica e gli oggetti dal documento.

Altri metodi descritti pi¨ avanti in questo articolo consentono di recuperare gran parte della formattazione originale dal documento danneggiato.

Per ulteriori informazioni sulla funzionalitÓ di salvataggio automatico, vedere l'argomento "Impedire perdite di e ripristinare persi documenti di Word" in Word per Mac la Guida in linea.

Come correggere un documento danneggiato

Esistono diverse tecniche che Ŕ possibile utilizzare per tentare di correggere un documento danneggiato. Il metodo da utilizzare dipende dal tipo e la gravitÓ del danno e il tipo di comportamento sia esposto. Sebbene molti di questi metodi vengano utilizzati regolarmente con successo, non tutti i documenti danneggiati possono essere recuperati. Conservare una copia di backup di un documento Ŕ il modo migliore per garantire il ripristino.

Le seguenti procedure di risoluzione dei problemi sono suddivise in due sezioni: "Se il File pu˛ essere aperto in Word per Mac" e "Se il File non pu˛ essere aperto in Word per Mac" Utilizzare la sezione appropriata per la propria situazione.

Se il File pu˛ essere aperto in Word per Mac

Se Ŕ possibile aprire il file in Word per Mac, utilizzare uno dei metodi descritti di seguito.

Metodo 1: Convertire il File in un altro formato

Convertire il file in un altro formato e quindi riconvertirlo in sua nativeformat.

Questo Ŕ il metodo di ripristino pi¨ semplice e completo documento; sempre provare prima. Salvare il file in formato testo RTF (RICH). Questo formatpreserves la formattazione del documento di Word per Mac.Dopo aver salvato il file in formato RTF, riaprire il file in Word per Mac e quindi convertirlo dal formato RTF. Se questo metodo ha esito positivo, viene rimosso il danneggiamento di file durante la conversione.

Per salvare il file in formato RTF, attenersi alla seguente procedura:
  1. Scegliere Salva con nomedal menu File .
  2. Fare clic sull'elenco di formato e quindi selezionare il Formato RTF.
  3. Modificare il nome del documento. (Si consiglia in modo da poter continuare con le altre operazioni utilizzando il documento originale non modificato.)
  4. Fare clic su Salva.
Se l'errore persiste dopo aver salvato il file in formato RTF, provare a salvare il file in uno dei seguenti formati:
  • Altri formati di elaborazione testi
  • Solo testo
Nota: salvataggio di un file in formato solo testo spesso risolve il problema di danni; Tuttavia, tutta la formattazione viene persa, inclusi i codici di campo e grafica in Word per Mac. Questo metodo richiede pi¨ la formattazione; Utilizzarlo pertanto solo dopo altri formati di file non consentono di correggere il problema.

Per ulteriori informazioni sulla perdita di Visual Basic, Applications Edition codice in Word per i documenti di Mac vengono convertiti in altri formati di file, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
184153 WD98: Perdita dopo la conversione in un altro formato di documento di codice VBA

Metodo 2: Copiare tutto il contenuto, ad eccezione dell'ultimo segno di paragrafo in un nuovo documento

Word per Mac consente di associare una vasta gamma di informazioni di formattazione dell'ultimo segno di paragrafo, particolare sezione e la formattazione dello stile. Se si copia tutti gli elementi nel file, ad eccezione dell'ultimo segno di paragrafo in un nuovo file, il danno pu˛ rimanere nel documento originale.

Per copiare tutto tranne l'ultimo segno di paragrafo del documento, attenersi alla seguente procedura:
  1. Aprire il documento che presenta il comportamento insolito.
  2. Dal menu Modifica , fare clic su Seleziona tutto.
  3. Con il documento selezionato, premere Comando + Maiusc + freccia sinistra direzionale. (L'ultimo segno di paragrafo si rimuove dalla selezione.)
  4. Scegliere Copiadal menu Modifica .
  5. Dal menu File , selezionare Nuovo documento.
  6. Nel nuovo documento, selezionare Incolla dal menu Modifica .

    Nota: nel nuovo documento, Ŕ necessario riapplicare la formattazione di sezione o la formattazione dello stile.

Metodo 3: Copiare le parti danneggiate del File in un nuovo File

Talvolta Ŕ possibile determinare la posizione dei danni nel file esamina il file o il test del file per determinare quando si verifica il comportamento. Un altro modo per determinare quale area del file Ŕ danneggiato consiste nel copiare entrambi una pagina alla volta o una serie di pagine in un nuovo file. Salvare il nuovo file e quindi verificare il comportamento originale. Se non si verifica il comportamento, continuare a copiare le pagine, salvataggio e il test fino a quando non si verifica il comportamento originale.

Se Ŕ possibile trovare l'area del file Ŕ danneggiato, Ŕ possibile copiare tutto tranne la parte danneggiata di un nuovo file e quindi attenersi alla seguente procedura per ricostruire il documento:
  1. Copia delle parti danneggiate del documento e incollarli in un nuovo file (non potete selezionare il segno di paragrafo finale di questa selezione, perchÚ tale segno di paragrafo pu˛ contenere alcune informazioni non corrette).
  2. Salvare una copia del documento danneggiato in formato solo testo.
  3. Aprire il file di solo testo.
  4. Copiare il testo dal file e quindi incollarlo in un file che contiene la parte non danneggiata del file.
  5. Riformattare le sezioni del documento incollato nel passaggio 4 e quindi salvare il documento recuperato.

Se il File non pu˛ essere aperto in Word per Mac

Se Ŕ possibile aprire il file in Word per Mac, Ŕ possibile utilizzare uno dei seguenti metodi a seconda dei casi.

Metodo 1: Inserire il File in un documento vuoto

Se Ŕ possibile aprire un file per copiare tutto il testo (ad eccezione dell'ultimo segno di paragrafo), Ŕ possibile inserirlo in un nuovo documento. Consente di inserire un segno di paragrafo finale sul file che si sta correggendo. A tale scopo, attenersi alla seguente procedura:
  1. Creare un nuovo documento basato sul modello Normal.
  2. Dal menu Inserisci , fare clic su File. Selezionare il documento danneggiato e quindi fare clic su OK.

Metodo 2: Utilizzare il comando Incolla Link per aprire il documento con un collegamento

Questo metodo utilizza un documento "fittizio" per creare un collegamento, quindi passa il collegamento tra il documento "fittizio" e il documento danneggiato.

Attenersi alla seguente procedura per utilizzare un'operazione di Incolla collegamento per aprire un documento danneggiato:
  1. Chiudere tutti i documenti aperti in Word per Mac e aprire un nuovo documento vuoto.
  2. Tipo Test.
  3. Selezionare la parola Test. Scegliere Copiadal menu Modifica .
  4. Dal menu File , fare clic su Nuovo e quindi aprire un nuovo documento vuoto.
  5. Scegliere Incolla specialedal menu Modifica . Nella finestra di dialogo Incolla speciale fare clic su Incolla collegamento. Nella casella come selezionare Testo formattato (RTF)e quindi fare clic su OK.
  6. Scegliere collegamentidal menu Modifica .
  7. Nella finestra di dialogo collegamenti fare clic su Cambia origine. Nella finestra di dialogo Apri , individuare e selezionare il documento che si desidera ripristinare. Fare clic su Apri e quindi fare clic su OK.
  8. All'apertura del documento, fare clic su Salva con nome dal menu File . Digitare un nuovo nome per il documento e quindi fare clic su Salva.
  9. Con il documento aperto, scegliere collegamenti dal menu Modifica .
  10. Nella finestra di dialogo collegamenti fare clic su Interruzione di collegamenti. Nella finestra di dialogo visualizzata, fare clic su per interrompere il collegamento.
Nota: dopo il collegamento viene interrotto, Ŕ consigliabile salvare il documento prima di chiuderla o modificarlo.

Metodo 3: Aprire il File utilizzando l'opzione "Recupera testo da qualsiasi File"

Come ultima risorsa, Ŕ possibile utilizzare il convertitore "Recupera testo da qualsiasi File" speciale per aprire manualmente documenti danneggiati. Questo convertitore consente di rimuovere tutta la formattazione, grafica e oggetti incorporati dal file e lascia solo il testo leggibile (caratteri ASCII). A causa del modo che Word per Mac i file di documento vengono organizzati e salvati, il testo potrebbe essere non connessi o duplicato.

Anche i file pi¨ semplice, Ŕ necessaria la riformattazione considerevole. File di piccole dimensioni, Ŕ possibile aprire un nuovo documento secondo e copiare e incollare il testo dal documento recuperato nel nuovo documento, poichÚ non esiste in modo pi¨.

Per utilizzare il convertitore "Recupera testo da qualsiasi File" per aprire un documento, attenersi alla seguente procedura:
  1. Dal menu File , fare clic su Apri.
  2. Fare clic su Mostra elenco e quindi fare clic su Recupera testo da qualsiasi File.
  3. Individuare la cartella che contiene il file danneggiato e quindi selezionare il file.
  4. Fare clic su Apri.
Nota: il processo di ripristino pu˛ richiedere molto tempo, a seconda delle dimensioni del documento e il tipo di danno. Appena il ripristino Ŕ completato, fare clic su Apri dal menu File e quindi modificare il Tipo file nuovamente in Documenti di Word o File leggibili.

Suggerimento: salvare il file recuperato con un nuovo nome a questo punto. Questo impedisce di sovrascrivere accidentalmente il documento originale e si garantisce che il documento originale rimane disponibile per altri tentativi di recupero.

Metodo 4: Apri come copia

Per aprire una copia di un documento danneggiato, attenersi alla seguente procedura:
  1. Chiudere tutti i documenti aperti.
  2. Scegliere Apri dal menu File .
  3. Selezionare Copia dall'elenco Apri .
  4. Selezionare il file danneggiato.
  5. Fare clic su Apri.

ProprietÓ

Identificativo articolo: 285393 - Ultima modifica: sabato 8 febbraio 2014 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Word 2004 for Mac
  • Microsoft Word X per Macintosh
  • Microsoft Word 2001 per Mac
Chiavi:á
dftsdahomeportal kbinfo kbmt KB285393 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo Ŕ stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre Ŕ perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilitÓ per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualitÓ della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 285393
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com