Como resolver problemas de documentos danificados no Word para Mac

Traduções de Artigos Traduções de Artigos
Artigo: 285393 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo fornece procedimentos de resolução de problemas que pode utilizar para identificar ficheiros danificados no Microsoft Word para Mac e, em alguns casos, recuperar esses ficheiros.

Ficheiros de documento danificado podem levar qualquer programa a apresentar um comportamento estranho. Este comportamento ocorre porque o programa está a receber informações incorrectas do ficheiro danificado.

Mais Informação

Como identificar um ficheiro danificado

Ficheiros danificados fazer comportamento que não faz parte da concepção do programa ? por exemplo, repaginação infinita, esquema do documento incorrecta e formatação, caracteres ilegíveis no ecrã, mensagens de erro durante o processamento, não reage de sistema ou falha ao carregar ou visualizar o ficheiro ou qualquer outro comportamento estranho que não pode ser atribuído ao funcionamento normal do programa. Estes comportamentos também podem ser causados por factores diferente de danos no documento. Para excluir outros factores, siga estas sugestões de resolução de problemas:
  • Verificar um comportamento semelhante noutros documentos.
  • Verificar um comportamento semelhante noutros programas.
  • Copie o ficheiro em questão para outro computador e tente duplicar o comportamento.
  • Utilizar um controlador de impressora diferente e tente duplicar o comportamento. Para utilizar um controlador de impressora diferente, siga estes passos:

    1. Seleccione o selector de recursos no menu de Apple .
    2. No selector de recursos , seleccione outro controlador de impressora e, em seguida, fechar o selector de recursos .
    3. No Word para Mac, seleccione o Programa de configuração de página no menu ficheiro , para verificar se o controlador de impressora que seleccionou no selector de recursos é seleccionado no Word para Mac.
  • Mudar o nome nenhum modelo anexado ao documento e, em seguida, tente duplicar o comportamento.
  • Inicie o computador novamente, com extensões desactivadas para desactivar quaisquer programas de terceiros em execução (como, por exemplo, programas de terminate-and-stay-resident [TSR], gestores de tipos de letra e protecções de ecrã). Em seguida, tente duplicar o comportamento. Para obter informações adicionais sobre como iniciar o computador com extensões desactivar, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
    263159Como resolver problemas de conflitos de extensões no Macintosh
Se o problema ocorrer apenas com um único documento depois de efectuar os passos anteriores, o documento está provavelmente danificado. Se o programa ser encerrado inesperadamente antes do ficheiro foi fechado e a opção de recuperação automática foi activada, poderá ter sido criado um ficheiro de recuperação automática. Pode utilizar este ficheiro de recuperação automática para recuperar o ficheiro em questão.

A funcionalidade de recuperação automática do Word para Mac tentará automaticamente recuperar texto de um documento que estava aberto quando o Word para Mac deixou de responder. Quando reiniciar o Word para Mac depois de este deixa de responder (não reage), será apresentada uma caixa de diálogo com a seguinte mensagem:
O Word detectou danos no ficheiro ao abrir o Nome do ficheiro . Parte deste documento pode ser recuperado. Tentativa de recuperação agora?
Nota : esta recuperação poderá demorar algum tempo, dependendo do tamanho do documento e a quantidade de danos no documento.

Depois do documento ser recuperado, imediatamente utilize o comando Guardar como no menu ficheiro para guardar o documento com um novo nome de ficheiro. Isto assegura que o documento original estará disponível para outras tentativas de recuperação. Este método de recuperação automática remove tudo formatação, gráficos e objectos do documento.

Outros métodos listados mais adiante neste artigo podem permitir a recuperar mais a formatação original do documento danificado.

Para obter mais informações sobre a funcionalidade de recuperação automática, consulte o tópico "Impedir a perda de e recuperar perdem-se documentos do Word" no Word para Mac Ajuda .

Como corrigir um documento danificado

Existem várias técnicas que pode utilizar para tentar corrigir um documento danificado. O método que utiliza depende do tipo e gravidade dos danos e o tipo de comportamento que é apresentado. Apesar de muitos destes métodos tiver êxito regularmente, nem todos os documentos danificados podem ser recuperados. Manter uma cópia de segurança de um documento é a melhor forma de garantir a recuperação.

Os procedimentos de resolução de problemas estão divididos em duas secções: "Se o ficheiro pode ser aberto no Word para Mac" e "Mac Se o ficheiro não é possível ser aberto no Word para." Utilize a secção adequada à sua situação.

Se o ficheiro pode ser aberto no Word para Mac

Se conseguir abrir o ficheiro no Word para Mac, utilize um dos seguintes métodos.

Método 1: Converter o ficheiro para outro formato

Converter o ficheiro para outro formato e, em seguida, converta-o para o formato nativo.

Este é o método de recuperação de documentos mais fácil e mais completo; tente sempre-lo primeiro. Guarde o ficheiro em Rich Text Format (RTF). Este formato preserva a formatação do documento Word para Mac. Depois de guardar o ficheiro no formato RTF, reabrir o ficheiro no Word para Mac e, em seguida, convertê-la a partir do formato RTF. Se este método tiver êxito, os danos do ficheiro é removido durante a conversão.

Para guardar o ficheiro como RTF, siga estes passos:
  1. No menu ficheiro , clique em Guardar como .
  2. Clique na lista formato e, em seguida, seleccione Rich Text Format (RTF) .
  3. Altere o nome do documento. (Isto é recomendado para que possa continuar com os outros passos utilizando o documento original inalterado.)
  4. Clique em Guardar .
Se o problema persistir depois de guardar o ficheiro como RTF, tente guardar o ficheiro dos seguintes formatos de ficheiro:
  • Outros formatos de processamento de texto
  • Só de texto
Nota : guardar um ficheiro no formato só de texto frequentemente corrige o problema de danos; no entanto, toda a formatação é perdida, incluindo códigos de campo e de gráficos no Word para Mac. Este método requer mais reformatar; assim, utilizá-lo apenas depois de outros formatos de ficheiro não conseguem corrigir o problema.

Para mais informações sobre a perda do Visual Basic da aplicações de código no Word para Mac documentos que serão convertidos para outros formatos de ficheiro, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
184153WD98: Código do VBA perdeu-se depois de converter para outro formato de documento

Método 2: Copiar tudo, excepto a última marca de parágrafo para um documento novo

Word para Mac associa uma vasta gama de formatação à última marca de parágrafo, especialmente formatação de secções e estilos. Se copiar tudo no ficheiro, excepto a última marca de parágrafo, para um novo ficheiro, os danos, seja resolvido no documento original.

Para copiar tudo excepto a última marca de parágrafo no documento, siga estes passos:
  1. Abra o documento que apresenta o comportamento estranho.
  2. No menu Editar , clique em Seleccionar tudo .
  3. Com o documento seleccionado, prima tecla de direcção comando + SHIFT + à esquerda. (Isto remove apenas a última marca de parágrafo da selecção.)
  4. No menu Editar , seleccione Copiar .
  5. No menu ficheiro , seleccione Novo documento .
  6. No novo documento, seleccione Colar no menu Editar .

    Nota : no documento novo, poderá ter de voltar a aplicar a formatação de secção ou formatação de estilo.

Método 3: Copiar as partes não danificadas do ficheiro para um novo ficheiro

Por vezes, pode determinar a localização de danos no ficheiro de olhar para o ficheiro ou verificar o ficheiro para determinar quando ocorre o comportamento. Outra forma de determinar que área do ficheiro está danificada é para copiar ou uma página de cada vez ou uma série de páginas para um novo ficheiro. Guarde o novo ficheiro e, em seguida, teste para o comportamento original. Se o comportamento não ocorrer, continue a copiar páginas, guardar e testar até ocorre o comportamento original.

Se podem encontrar que área do ficheiro está danificada, pode copiar tudo excepto a parte danificada para um ficheiro novo e, em seguida, siga estes passos para reconstruir o documento:
  1. Copiar as que partes do documento e colá-los num novo ficheiro (não convém seleccione a marca de parágrafo final desta selecção, uma vez que essa marca de parágrafo pode conter algumas informações incorrectas).
  2. Guarde uma cópia do documento danificado no formato só de texto.
  3. Abra o ficheiro só de texto.
  4. Copie o texto a partir deste ficheiro e cole-o no ficheiro que contém parte do seu ficheiro não danificado.
  5. Reformatar as secções do documento que colou no passo 4 e, em seguida, guarde o documento recuperado.

Se o ficheiro não pode ser aberto no Word para Mac

Se não conseguir abrir o ficheiro no Word para Mac, utilize um dos seguintes métodos conforme adequado.

Método 1: Inserir o ficheiro num documento em branco

Se não conseguir abrir um ficheiro para copiar todo o texto (excepto a marca de parágrafo final), poderá inserir um novo documento. Isto insere uma nova marca de parágrafo final para o ficheiro que está a corrigir. Para o fazer, siga estes passos:
  1. Crie um novo documento baseado no modelo normal.
  2. No menu Inserir , clique em ficheiro . Seleccione o documento danificado e, em seguida, clique em OK .

Método 2: Utilizar o comando ' Colar ligação ' para abrir o documento com uma ligação

Este método utiliza um documento "fictício" para criar uma ligação e, em seguida, muda a ligação entre o documento "fictício" e o documento danificado.

Siga estes passos para utilizar uma operação de Colar ligação para abrir um documento danificado:
  1. Feche todos os documentos abertos no Word para Mac e, em seguida, abra um novo documento em branco.
  2. Tipo de teste .
  3. Seleccione a palavra teste . No menu Editar , clique em Copiar .
  4. No menu ficheiro , clique em Novo e, em seguida, abra um novo documento em branco.
  5. No menu Editar , clique em Colar especial . Na caixa de diálogo Colar especial , clique em Colar ligação . Na caixa como , clique em Texto formatado (RTF) e, em seguida, clique em OK .
  6. No menu Editar , clique em ligações .
  7. Na caixa de diálogo ligações , clique em Alterar origem . Na caixa de diálogo Abrir , localize e seleccione o documento que pretende recuperar. Clique em Abrir e clique em OK .
  8. Quando o documento for aberto, clique em Guardar como no menu ficheiro . Escreva um novo nome para o documento e, em seguida, clique em Guardar .
  9. Com o documento aberto, clique em ' ligações ' no menu Editar .
  10. Na caixa de diálogo ligações , clique em Interromper ligações . Na caixa de diálogo que aparece, clique em Sim para quebrar a ligação.
Nota : depois da ligação for interrompida, deve guardar o documento antes de fechá-la ou modificá-lo.

Método 3: Abrir o ficheiro utilizando o 'Recuperar texto de qualquer ficheiro'

Como último recurso, pode utilizar o conversor de "Recuperar texto de qualquer ficheiro" especial para abrir manualmente documentos danificados. Este conversor remove toda a formatação, gráficos e objectos incorporados a partir do ficheiro e mantém apenas texto legível (caracteres ASCII). Devido à forma como que o Word para Mac documento ficheiros são organizados e guardados, o texto pode ser disjointed ou duplicado.

Com o mesmo os ficheiros mais simples, reformatar considerável é necessária. Com ficheiros mais pequenos, poderá abrir um novo documento segundo e copiar e colar texto do documento recuperado num novo documento, porque não existe muito texto não pretendido recuperado.

Para utilizar o conversor de "Recuperar texto de qualquer ficheiro" para abrir um documento, siga estes passos:
  1. No menu ficheiro , clique em Abrir .
  2. Clique na lista Mostrar e, em seguida, clique em Recuperar texto de qualquer ficheiro .
  3. Localize a pasta que contém o ficheiro danificado e, em seguida, seleccione o ficheiro.
  4. Clique em Abrir .
Nota : O processo de recuperação pode demorar algum tempo, dependendo do tamanho do documento e o tipo de danos. Assim que a recuperação estiver concluída, clique em Abrir no menu ' ficheiro ' e altere Ficheiros do tipo para Documentos do Word ou Ficheiros de acesso de leitura .

sugestão : guardar o ficheiro recuperado com um novo nome neste momento. Isto impede a substituição acidental do documento original e assegura que o documento original permanece disponível para outras tentativas de recuperação.

Método 4: Abrir como cópia

Para abrir uma cópia de um documento danificado, siga estes passos:
  1. Feche todos os documentos abertos.
  2. Clique em Abrir no menu ficheiro .
  3. Seleccione a cópia da lista Abrir .
  4. Seleccione o ficheiro danificado.
  5. Clique em Abrir .

Propriedades

Artigo: 285393 - Última revisão: 29 de janeiro de 2007 - Revisão: 2.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Macintosh
Palavras-chave: 
kbmt kbinfo KB285393 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 285393

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com