Como solucionar problemas de documentos danificados no Word para Mac

Traduções deste artigo Traduções deste artigo
ID do artigo: 285393 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Este artigo fornece procedimentos de solução de problemas que você pode usar para identificar arquivos danificados no Microsoft Word para Mac e, em alguns casos, recuperar esses arquivos.

Arquivos de documento danificado podem causar qualquer programa para exibem comportamento incomum. Esse comportamento ocorre porque o programa estiver recebendo informações incorretas de arquivo danificado.

Mais Informações

Como identificar um arquivo danificado

Arquivos danificados com freqüência causar comportamento que não faz parte do design programa--por exemplo, repaginação infinita, layout do documento incorretos e formatação, caracteres ilegíveis na tela, mensagens de erro durante processamento, o sistema trava ou falhas ao carregar ou exibir o arquivo ou qualquer outro comportamento incomum que não pode ser atribuído a operação normal do programa. Esses comportamentos também podem ser causados por fatores diferente de danos do documento. Para determinar outros fatores, siga estas dicas de solução de problemas:
  • Procurar comportamento parecido em outros documentos.
  • Procurar comportamento parecido em outros programas.
  • Leve o arquivo em questão para outro computador e tentar duplicar o comportamento.
  • Use um driver de impressora diferente e tentar duplicar o comportamento. Para usar um driver de impressora diferente, execute estas etapas:

    1. Selecione seletor no menu Apple .
    2. No seletor de campos , selecione um driver de impressora diferente e, em seguida, feche o seletor .
    3. No Word para Mac, selecione Configurar página no menu arquivo , para verificar se o driver de impressora que você selecionou no seletor de campos é selecionado no Word para Mac.
  • Renomeie quaisquer modelos que anexado ao documento e, em seguida, tentar duplicar o comportamento.
  • Inicie o computador novamente, com as extensões desativadas para desabilite quaisquer programas de terceiros que estão sendo executados (tais como programas terminate-and-stay-resident [TSRs], gerentes de fonte e as proteções de tela). Em seguida, tente duplicar o comportamento. Para informações adicionais sobre como iniciar o computador com extensões logoff, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    263159Como solucionar problemas de conflitos de extensões no Macintosh
Se o problema ocorre apenas com um único documento depois de executar as etapas anteriores, seu documento está provavelmente danificado. Se o programa fechar inesperadamente antes do arquivo foi fechado e a opção de AutoRecuperação foi ativada, um arquivo de AutoRecuperação pode ter sido criado. Você pode usar esse arquivo de AutoRecuperação para recuperar o arquivo em questão.

O recurso de AutoRecuperação no Word para Mac tenta recuperar automaticamente o texto de um documento que estava aberto quando o Word para Mac parou de responder. Quando você reiniciar o Word para Mac depois ele pára de responder (trava), uma caixa de diálogo será ser exibida com a seguinte mensagem:
Word encontrou um dano no arquivo ao abrir o Nome do arquivo . Parte deste documento pode ser recuperada. Tentativa de recuperação agora?
Observação : esta recuperação pode levar algum tempo, dependendo do tamanho do documento e a quantidade de danos no documento.

Depois que o documento é recuperado, imediatamente use o comando Salvar como no menu arquivo para salvar o documento com um novo nome de arquivo. Isso garante que o documento original estará disponível para outras tentativas de recuperação. Esse método de recuperação automática remove todos os formatação, elementos gráficos e objetos do documento.

Outros métodos listados posteriormente neste artigo podem permitem que você recuperar mais de sua formatação original do documento danificado.

Para obter mais informações sobre o recurso AutoRecuperação, consulte o tópico "Evitar perda de e recuperar perder documentos do Word" no Word para Mac Ajuda .

Como corrigir um documento danificado

Há várias técnicas que você pode usar para tentar corrigir um documento danificado. O método que você usa depende o tipo e a gravidade dos danos e o tipo de comportamento que é exibido. Embora muitos desses métodos funcionar regularmente, não cada documento danificado pode ser recuperado. Manter uma cópia backup de um documento é a melhor maneira para garantir sua recuperação.

Os seguintes procedimentos de solução de problemas são divididos em duas seções: "Se o arquivo pode ser aberto no Word para Mac" e "Mac se o arquivo não pode ser aberto no Word para." Use a seção apropriada para sua situação.

Se o arquivo pode ser aberto no Word para Mac

Se você pode abrir o arquivo no Word para Mac, use um dos seguintes métodos.

Método 1: Converter o arquivo para outro formato

Converta o arquivo para outro formato e convertê-la novamente em seu formato nativo.

Esse é o método de recuperação de documento mais fácil e mais completa; sempre tente-lo primeiro. Salve o arquivo no formato Rich Text (RTF). Esse formato preserva a formatação em seu documento do Word para Mac. Após você salva o arquivo em RTF, reabrir o arquivo no Word para Mac e, em seguida, convertê-lo de RTF. Se esse método tiver êxito, o dano no arquivo será removido durante a conversão.

Para salvar o arquivo como RTF, execute essas etapas:
  1. No menu arquivo , clique em Salvar como .
  2. Clique na lista formato e clique em Formato Rich Text .
  3. Altere o nome do documento. (Isso é recomendado para que você possa continuar com as outras etapas usando o documento original não modificado).
  4. Clique em Salvar .
Se o dano persistir depois de salvar o arquivo como RTF, tente salvar o arquivo em um dos seguintes formatos de arquivo:
  • Outros formatos de processamento de texto
  • Somente texto
Observação : salvar um arquivo no formato somente texto com freqüência corrige o problema de dano; no entanto, toda a formatação é perdida, incluindo códigos de campo e elementos gráficos no Word para Mac. Este método requer mais reformatar; portanto, usá-lo somente depois que outros formatos de arquivo falharem corrigir o problema.

Para obter informações adicionais sobre perda do Visual Basic código de VBA no Word para Mac documentos que são convertidos em outros formatos de arquivo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
184153WD98: Código VBA perdido após a conversão para outro formato de documento

Método 2: Copiar tudo exceto a última marca de parágrafo para um novo documento

Word para Mac associa uma ampla variedade de formatação à última marca de parágrafo, especialmente seção e estilo de formatação. Se você copiar tudo no arquivo, exceto a última marca de parágrafo, para um novo arquivo, o dano pode ser deixado por trás no documento original.

Para copiar tudo, exceto a última marca de parágrafo no documento, siga estas etapas:
  1. Abra o documento que exibe o comportamento estranho.
  2. No menu Editar , clique em Selecionar tudo .
  3. Com o documento selecionado, pressione tecla direcional comando + SHIFT + esquerda. (Isso remove somente a última marca de parágrafo da seleção.)
  4. No menu Editar , selecione Copy .
  5. No menu arquivo , selecione Novo documento .
  6. No novo documento, selecione Paste no menu Editar .

    Observação : no novo documento, talvez seja necessário reaplicar a formatação de seção ou o estilo de formatação.

Método 3: Copiar as partes não danificadas do arquivo para um novo arquivo

Às vezes, você pode determinar o local de danos no seu arquivo observando o arquivo ou o arquivo para determinar quando ocorrerá o comportamento de teste. Outra maneira de determinar que área do arquivo está danificada é copiar em uma página por vez ou uma série de páginas em um novo arquivo. Salvar o novo arquivo e, em seguida, teste para o comportamento original. Se o comportamento não ocorrer, continue a copiar páginas, salvando e teste até que ocorra o comportamento original.

Se você pode encontrar que área do arquivo está danificada, poderá copiar tudo exceto a parte danificada para um novo arquivo e, em seguida, siga estas etapas para reconstruir seu documento:
  1. Copiar partes de seu documento não danificadas e colá-los em um novo arquivo (não é aconselhável para selecionar a marca de parágrafo final dessa seleção, porque essa marca de parágrafo pode conter algumas informações incorretas).
  2. Salve uma cópia do documento danificado no formato somente texto.
  3. Abra o arquivo somente texto.
  4. Copie o texto deste arquivo e cole-o no arquivo que contém parte de seu arquivo não danificada.
  5. Reformatar as seções do documento que você colou na etapa 4 e, em seguida, salve o documento recuperado.

Se o arquivo não pode ser aberto no Word para Mac

Se você não pode abrir o arquivo no Word para Mac, use um dos seguintes métodos conforme apropriado.

Método 1: Inserir o arquivo em um documento em branco

Se você não pode abrir um arquivo para copiar todo o texto (exceto a marca de parágrafo final), você poderá inserir o arquivo em um novo documento. Isso insere uma nova marca de parágrafo final para o arquivo que você está corrigindo. Para fazer isso, execute as seguintes etapas:
  1. Crie um novo documento com base no modelo Normal.
  2. No menu Inserir , clique em arquivo . Selecione o documento danificado e, em seguida, clique em OK .

Método 2: Usar o comando de link colar para abrir o documento com um link

Este método usa um documento "fictício" para criar um link e, em seguida, alterna o vínculo entre o documento "fictício" e o documento danificado.

Siga estas etapas para usar uma operação de colar vínculo para abrir um documento danificado:
  1. Feche todos os documentos abertos no Word para Mac e abra um novo documento em branco.
  2. Tipo de teste .
  3. Selecione a palavra teste . No menu Editar , clique em Copiar .
  4. No menu arquivo , clique em novo e, em seguida, abra um novo documento em branco.
  5. No menu Editar , clique em Colar especial . Na caixa de diálogo Colar especial , clique em Colar vínculo . Na caixa como , clique em Texto formatado (RTF) e, em seguida, clique em OK .
  6. No menu Editar , clique em links .
  7. Na caixa de diálogo links , clique em Alterar origem . Na caixa de diálogo Abrir , localize e selecione o documento que você deseja recuperar. Clique em Abrir e clique em OK .
  8. Quando o documento é aberto, clique em Salvar como no menu arquivo . Digite um novo nome para o documento e em seguida, clique em Salvar .
  9. Com o documento aberto, clique em vínculos no menu Editar .
  10. Na caixa de diálogo links , clique em Quebra Links . Na caixa de diálogo que aparece, clique em Sim para quebrar o vínculo.
Observação : após o vínculo for quebrado, você deve salvar o documento antes de fechá-lo ou modificá-lo.

Método 3: Abrir o arquivo usando o "Recuperar texto de qualquer arquivo"

Como um último recurso, você pode usar o conversor de "Recuperar texto de qualquer arquivo" especial para abrir manualmente documentos danificados. Esse conversor remove toda a formatação, elementos gráficos e objetos incorporados do arquivo e deixa somente texto legível (caracteres ASCII). Devido à maneira como que o Word para Mac documento arquivos são organizados e salvos, o texto pode ser separado ou duplicado.

Com até mesmo os arquivos mais simples, é necessário reformatar considerável. Com arquivos menores, convém abrir um novo documento segundo e cópia e colar texto do documento recuperado no novo documento, pois há muito texto indesejado recuperado.

Para usar o conversor de "Recuperar texto de qualquer arquivo" para abrir um documento, siga estas etapas:
  1. No menu arquivo , clique em Abrir .
  2. Clique na lista Mostrar e em seguida, clique em Recuperar texto de qualquer arquivo .
  3. Localize a pasta que contém o arquivo danificado e, em seguida, selecione o arquivo.
  4. Clique em Abrir .
Observação : O processo de recuperação pode levar algum tempo, dependendo do tamanho do documento e o tipo de dano. Assim que a recuperação for concluída, clique em Abrir no menu arquivo e altere List Files of Type para Documentos do Word ou Permissão de leitura de arquivos .

TIP : salvar o arquivo recuperado com um novo nome neste momento. Isso evita que você substitua acidentalmente o documento original e garante que o documento original permanece disponível para outras tentativas de recuperação.

Método 4: Abrir como cópia

Para abrir uma cópia de um documento danificado, execute essas etapas:
  1. Feche todos os documentos abertos.
  2. Clique em Abrir no menu arquivo .
  3. Selecione Copiar lista Abrir .
  4. Selecione o arquivo danificado.
  5. Clique em Abrir .

Propriedades

ID do artigo: 285393 - Última revisão: segunda-feira, 29 de janeiro de 2007 - Revisão: 2.3
A informação contida neste artigo aplica-se a:
  • Microsoft Word 2004 for Mac
  • Microsoft Word X para Macintosh
  • Microsoft Word 2001 para Mac
Palavras-chave: 
kbmt kbinfo KB285393 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 285393

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com