Устранение поврежденных документов Word для Mac

Переводы статьи Переводы статьи
Код статьи: 285393 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

Приводятся процедуры устранения неполадок, которые можно использовать для определения повреждения файлов в Microsoft Word для Mac, а в некоторых случаях восстановить эти файлы.

Поврежденных файлов документов может вызвать необычное поведение различных программ. Такое поведение наблюдается, поскольку программа получает неправильные данные из поврежденного файла.

Дополнительная информация

Определение поврежденного файла

Поврежденные файлы часто вызывают поведение, которое не является частью разработки программы — например, бесконечной вызывают, неправильная структура и форматирование документа, нечитаемых символов на экране, сообщения об ошибках во время обработки, система зависает или сбоев при загрузке или просмотре файла или любое другое поведение, не может быть отнесена к нормальной работе программы. Такое поведение также может быть вызвана факторами, отличными от повреждения документа. Чтобы исключить другие факторы, выполните следующие советы по устранению неполадок.
  • Проверьте, что подобное поведение не наблюдается при использовании других документов.
  • Проверьте, что подобное поведение не наблюдается при использовании других программ.
  • Откройте файл в вопросе на другом компьютере и попытаться воспроизвести проблему.
  • Использовать другой драйвер принтера и попытайтесь воспроизвести проблему. Чтобы использовать другой драйвер принтера, выполните следующие действия.

    1. Выберите Выбор В меню Apple меню.
    2. В Выбор, выберите другой драйвер принтера, а затем закройте Выбор.
    3. В Microsoft Word для Mac Выбор Параметры страницы В меню Файл меню, чтобы убедиться, что драйвер принтера, который был выбран в окне Chooser выбран в Word для Macintosh.
  • Переименуйте все шаблоны, вложенной в документ и попытаться воспроизвести проблему.
  • Еще раз, запустите компьютер с расширениями выключены, чтобы отключить любой третьей стороне запущенные (например, завершать и резидентных программ [TSR], диспетчеры шрифтов и заставки). Попробуйте воспроизвести проблему. Для получения дополнительных сведений о том, как запустить компьютер с расширениями выключения щелкните следующий номер статьи базы знаний Майкрософт:
    263159 Устранение конфликтов расширение для Macintosh
Если проблема возникает только с одним документом, после выполнения описанных выше действий, документ возможно поврежден. Если программа неожиданно до закрытия файла, а Каталог данных для автовосстановления параметр включен, файл автоматического восстановления были созданы. Этот файл автосохранения можно использовать для восстановления файла в вопросе.

Функция автоматического восстановления в Word для Mac пытается автоматически восстановить текст из документа, открытого при Word для Mac перестал отвечать. При повторном запуске Word для Mac после он перестает отвечать на запросы (зависает), в диалоговом окне будет отображаться следующее сообщение об ошибке:
Обнаружено повреждение файла при открытии Имя файла. Часть этого документа может быть восстановлен. Попытаться восстановить его сейчас?
ПРИМЕЧАНИЕ: Восстановление это может занять некоторое время, в зависимости от размера документа и объема повреждения документа.

После восстановления документа, немедленно использовать Сохранить как команды Файл меню, чтобы сохранить документ под новым именем файла. Это гарантирует, что исходный документ будет доступен для других попыток восстановления. Этот метод автоматического восстановления удаляются все форматирование, рисунки и объекты из документа.

Другие методы, перечисленные далее в этой статье может помочь восстановить из исходного форматирования из поврежденного документа.

Для получения дополнительных сведений о функции автоматического восстановления обратитесь к разделу «Предотвращения потери из и восстановить потерянные документы Word» Word для Mac Справка.

Как исправить поврежденный документ

Существует несколько методов, которые можно использовать, чтобы попытаться исправить поврежденный документ. Метод, который можно использовать, зависит от типа и степени повреждения и тип поведения, которое проявляется. Хотя многие из этих методов регулярно, не каждый поврежденный документ можно восстановить. Сохранение резервной копии документа является лучшим способом обеспечить его восстановление.

Следующие процедуры устранения неполадок, разделены на два раздела: «Если файл может быть открыт в Word для Mac» и «Если файл не может быть открыт в Word для Макинтош» Используйте соответствующий раздел в конкретной ситуации.

Если открыть файл в Microsoft Word для Mac

Если файл можно открыть в Microsoft Word для Mac, используйте один из следующих способов.

Метод 1: Преобразование файлов в другой формат

Преобразовать файл в другой формат, а затем преобразовать его обратно в его собственном формат.

Это способ восстановления документа простейшим и наиболее полным; всегда используйте его. Сохраните файл в форматированный текст (RTF). Этот формат сохраняет форматирование Word для Mac документов. После сохранения файла в формате RTF, открыть файл в Microsoft Word для Mac и преобразовать его в формате RTF. Если этот метод выполнен успешно, повреждение файла удаляется во время преобразования.

Чтобы сохранить файл в формате RTF, выполните следующие действия.
  1. На Файл меню, нажмите кнопку Сохранить как.
  2. Нажмите кнопку Формат список, а затем выберите Текст в формате RTF.
  3. Измените имя документа. (Это рекомендуется продолжить другие действия с помощью исходного неизмененного документа.)
  4. Нажмите кнопку Сохранить.
Если повреждения продолжают проявляться после сохранения файла в формате RTF, попробуйте сохранить файл в одном из следующих форматов:
  • Формат другого текстового редактора
  • Только текст
ПРИМЕЧАНИЕ: Сохранение файла в текстовом формате часто решает проблему повреждения; Тем не менее, все форматирование теряется, включая графику и поля кодов в Word для Macintosh. Этот метод требует более переформатирование; Поэтому используйте его только после других форматов файлов, не устранить проблему.

За дополнительной информацией о потере Visual Basic для приложений в Microsoft Word для Mac документов, которые будут преобразованы в другие форматы файлов щелкните следующий номер статьи базы знаний Майкрософт:
184153WD98: Код VBA, утеряны после преобразования в формат другого документа

Способ 2: Скопируйте все содержимое, за исключением последнего знака абзаца в новый документ

Microsoft Word для Mac связывает разнообразные форматирование с последним знаком абзаца особенно разделов и форматирование стиля. Если скопировать все содержимое в файле, за исключением последнего знака абзаца, в новый файл, повреждение может остаться в исходном документе.

Чтобы скопировать все содержимое, за исключением последнего знака абзаца в документе, выполните следующие действия:
  1. Откройте документ, который странным поведением.
  2. На Редактирование меню, нажмите кнопку Выбрать все.
  3. Выбрать документ и нажмите клавишу направления команда + SHIFT + Стрелка влево. (Последнего знака абзаца удаляется из выделенной области).
  4. На Редактирование Выберите пункт Копировать.
  5. На Файл Выберите пункт Новый документ.
  6. В новом документе выберите Вставить В меню Редактирование меню.

    ПРИМЕЧАНИЕ: В новый документ может потребоваться повторно применить форматирование разделов или стилей.

Способ 3: Скопируйте неповрежденные фрагменты файла в новый файл

Иногда удается определить расположение участка в файле, просмотрев файл или файл, чтобы определить, когда происходит тестирование. Еще один способ определить, какая область файл поврежден является копирование либо одной страницы или последовательность страниц в новый файл. Сохраните новый файл и затем проверить исходное поведение. Если неполадки не возникают, продолжайте копирование страниц, сохранение и тестирование до момента возникновения исходное поведение.

Можно найти, какие области файл поврежден, можно скопировать все содержимое, за исключением поврежденного участка в новый файл и затем выполните следующие действия для восстановления документа:
  1. Скопируйте неповрежденные фрагменты документа и вставить их в новый файл (не следует выберите последний знак абзаца из выбора, так как знак абзаца, могут содержать неверные сведения).
  2. Сохраните копию поврежденного документа в текстовом формате.
  3. Откройте текстовый файл.
  4. Скопируйте текст из этого файла и вставить его в файл, который содержит неповрежденные части файла.
  5. Переформатирование разделов документа, вставленный в шаге 4, а затем сохраните восстановленный документ.

Если не удается открыть файл в Microsoft Word для Mac

Если не удается открыть файл в Microsoft Word для Mac, используйте один из следующих методов соответствующим образом.

Метод 1: Вставьте файл в новый документ

Не удается открыть файл, чтобы скопировать весь текст (за исключением последний знак абзаца), можно вставить файл в новый документ. Этот параметр вставляет новый последний знак абзаца на проверяемый файл. Чтобы сделать это, выполните следующие действия.
  1. Создайте новый документ, основанный на шаблоне Normal.dot.
  2. На Вставка меню, нажмите кнопку Файл. Выберите поврежденный документ, а затем нажмите кнопку ОК.

Способ 2: Используйте команду вставки ссылки для открытия документа со ссылкой

Этот метод использует «пустой» документ для создания ссылки, а затем переключается между «фиктивные» документа и поврежденный документ.

Выполните следующие действия для открытия поврежденного документа с помощью операции вставки связи.
  1. Закройте все открытые документы в Microsoft Word для Mac, а затем откройте новый документ.
  2. Тип Тест.
  3. Выделите слово Тест. На Редактирование меню, нажмите кнопку Копировать.
  4. На Файл меню, нажмите кнопку Новый и откройте новый документ.
  5. На Редактирование меню, нажмите кнопку Специальная. В Специальная диалоговое окно, нажмите кнопку Вставить связь. В Как Выберите Форматированный текст (RTF), а затем нажмите кнопку ОК.
  6. На Редактирование меню, нажмите кнопку Ссылки.
  7. В Ссылки диалоговое окно, нажмите кнопку Изменение источника. В Открыть диалоговое окно, найдите и выберите документ, который требуется восстановить. Нажмите кнопку Открыть и выберите команду ОК.
  8. При открытии документа, нажмите кнопку Сохранить как В меню Файл меню. Введите новое имя для документа и нажмите кнопку Сохранить.
  9. При открытом документе нажмите кнопку Ссылки В меню Редактирование меню.
  10. В Ссылки диалоговое окно, нажмите кнопку Разорвать связи. В появившемся диалоговом окне нажмите кнопку Да Чтобы разорвать связь.
ПРИМЕЧАНИЕ: После связь разрывается, следует сохранить документ, прежде чем закрыть его или изменить его.

Способ 3: Откройте файл с помощью «Восстановление текста из любого файла»

В качестве последнего средства можно использовать специальный конвертер «Восстановление текста из любого файла» для открытия поврежденных документов вручную. Данный конвертер позволяет удалить все форматирование, рисунки и внедренные объекты из файла и оставляет только читаемый текст (ASCII символов). Из-за способ организации и сохранения Word для Mac файлы документов, текст может быть Несвязное или дублируется.

Даже простой файлами значительных переформатирование является обязательным. С небольшими документами может потребоваться открыть новый документ второй и копировать и вставить текст из восстановленного документа в новый документ, поскольку так много текста восстановлены.

Чтобы открыть документ с помощью конвертера «Восстановление текста из любого файла», выполните следующие действия:
  1. На Файл меню, нажмите кнопку Открыть.
  2. Нажмите кнопку Показать список и нажмите кнопку Восстановление текста из любого файла.
  3. Найдите папку, содержащую поврежденный файл, а затем выберите файл.
  4. Нажмите кнопку Открыть.
ПРИМЕЧАНИЕ: Процесс восстановления может занять некоторое время, в зависимости от размера документа и повреждений. Сразу после завершения восстановления, нажмите кнопку Открыть В меню Файл меню, а затем измените Типы файлов к началу статьи Документы Word -или- Для чтения файлов.

СОВЕТ: Сохраните восстановленный файл с новым именем в этот момент. Это предотвращает случайной замены исходного документа и гарантирует, что исходный документ остается доступным для других попыток восстановления.

Метод 4: Открыть как копию

Чтобы открыть копию поврежденного документа, выполните следующие действия.
  1. Закройте все открытые документы.
  2. Нажмите кнопку Открыть В меню Файл меню.
  3. Выберите Копировать из Открыть список.
  4. Выберите поврежденный файл.
  5. Нажмите кнопку Открыть.

Свойства

Код статьи: 285393 - Последний отзыв: 6 октября 2011 г. - Revision: 7.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Word 2004 for Mac
  • Microsoft Word X for Macintosh
  • Microsoft Word 2001 for Mac
Ключевые слова: 
dftsdahomeportal kbinfo kbmt KB285393 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:285393

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com