Mac için Word'de bozuk belgelerle ilgili sorunları giderme hakkında

Makale çevirileri Makale çevirileri
Makale numarası: 285393 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Özet

Bu makalede, Mac için Microsoft Word'deki hasar görmüş dosyaları tanımlamak ve bazı durumlarda, bu tür dosyaları kurtarmak için kullanabileceğiniz sorun giderme yordamları içermektedir.

Bozuk belge dosyaları, programların beklenmedik davranışlar göstermesine neden olabilir. Bu davranış, program bozuk bir dosyadan yanlış bilgi alma nedeniyle oluşur.

Daha fazla bilgi

Bozuk dosya belirleme hakkında

Bozuk dosyaları, genellikle program tasarım--örneğin olmayan davranışı, sonsuz yeniden sayfalandırma, yanlış belge düzeni ve biçimlendirmesi, ekranda, hata iletileri işleme, sistem askıda kalıyor veya yükleme veya dosya ya da programın normal çalışması için tüm diğer beklenmedik davranışlar çöküyor sırasında okunamayan karakterler neden. Bu davranış da belge hasar dışındaki Etkenler neden olabilir. Başka etmenlerin dışında bırakmak için <a0></a0>, bu sorun giderme ipuçlarını izleyin:
  • Diğer belgelerde benzer davranışların olup olmadığını denetleyin.
  • Başka programlarda benzer davranışların olup olmadığını denetleyin.
  • Söz konusu dosyayı başka bir bilgisayara taşıyın ve davranışı yeniden oluşturmaya çalışır.
  • Farklı bir yazıcı sürücüsü kullanın ve davranışı yeniden oluşturmaya çalışır. Farklı bir yazıcı sürücüsü kullanmak için aşağıdaki adımları izleyin:

    1. Seçici üzerinde Apple menüsünü seçin.
    2. Seçici, farklı bir yazıcı sürücüsü seçin ve sonra Chooser ' ı kapatın.
    3. Mac için Word'de Chooser'da seçtiğiniz yazıcı sürücüsü, Mac için Word'de seçildiğini doğrulamak için Dosya menüsünden Sayfa Yapısı seçin...
  • Belgeye eklenmiş ve sonra da davranışı yeniden oluşturmaya çalışın şablonları yeniden adlandırın.
  • Tüm üçüncü taraf programları (sonlandır-ve-bellekte kal programları [TSR], yazı tipi yöneticileri, ekran koruyucular gibi) çalıştırıyorsanız ve devre dışı bırakmak için devre dışı uzantılı bilgisayarı yeniden başlatın. Sonra davranışı yeniden oluşturmaya çalışın. Uzantıları devre dışı olan bilgisayar başlatma hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
    263159Macintosh üzerinde uzantısı çakışmaları ile ilgili sorunları giderme
Belgenizi, yukarıdaki adımları gerçekleştirdikten sonra yalnızca tek bir belge ile sorun ortaya çıkarsa, büyük olasılıkla bozuk. Program beklenmedik biçimde sonlandırılıyor dosyası kapatıldı ve Otomatik Kurtarma seçeneği etkinleştirilmeden önce bir Otomatik Kurtarma dosyası oluşturulmuş olabilir. Bu otomatik kurtarma dosyası, söz konusu dosyayı kurtarmak için kullanabilirsiniz.

Mac için Word Otomatik Kurtarma özelliğini, otomatik olarak da Mac için Word yanıt vermemeye başladığında açık olan belgeden metni kurtarmaya çalışır. (Bu bağlantı, bir kısmı veya tamamı ingilizce olan içeriğe işaret edebilir.) yanıt vermiyor sonra Mac için Word'Ü yeniden başlattığınızda, bir iletişim kutusu aşağıdaki ileti görüntülenir:
Word, Dosya adı açılırken dosya hasarını karşılaştı. Bu belgenin bir bölümü kurtarılabilir. Kurtarma şimdi denensin mi?
Not: Bu kurtarma, belge belgedeki bozukluk miktarını ve boyutuna bağlı olarak biraz zaman alabilir.

Hemen belge kurtarıldı sonra belgeyi yeni bir dosya adıyla kaydetmek için Dosya menüsünden Farklı Kaydet komutunu kullanın. Bu, özgün belgedeki diğer Kurtarma girişimleri için kullanılabilir olmasını sağlar. Bu otomatik kurtarma yöntemi, tüm biçimlendirme, grafikler ve nesneler belgede doğru soyarak.

Bu makalenin sonraki bölümlerinde listelenen diğer yöntemleri daha özgün zarar görmüş belgeden biçimlendirmenizin kurtarmanıza olanak verebilir.

Otomatik Kurtarma özelliği hakkında daha fazla bilgi için Mac için Yardım Word'deki "Engelle zarar, Word ve Kurtar kayıp belgeleri" konusuna bakın.

Belge bozuk düzeltme nasıl kaldırılır

Bozuk bir belgeyi düzeltmek için kullanabileceğiniz çeşitli teknikler vardır. Kullandığınız yöntem, türünü ve zararı ve yaşandığı bir davranış türü önem bağlıdır. Bu yöntemlerin birçoğu genelde başarılı olmasına karşın, tüm bozuk belgeler kurtarılamayabilir. Bir belgenin yedek kopyasını tutarak, kendi kurtarma sağlamak için en iyi yoldur.

Aşağıdaki sorun giderme yordamları, iki bölüme ayrılır: ", dosya can be açılan, Word için ak" ve ", dosya cannot be açıldı, Word için Mac" Uygun bölümü durumunuza kullanın.

Dosyayı Word'de Mac için açtıysanız

Mac için Word dosyayı açabilir, aşağıdaki yöntemlerden birini kullanın.

Yöntem 1: dosyayı başka bir biçimine dönüştürün.

Dosyayı başka bir biçime dönüştürebilirsiniz ve sonra özgün biçimine dönüştür.

Bu en kolay ve en eksiksiz belge kurtarma yöntemidir; her zaman ilk deneyin. Dosyayı zengin metin biçimi (RTF) olarak kaydedin. Bu biçim, Mac belge sizin Word'deki biçimlendirmeyi korur. RTF dosyası kaydettikten sonra Mac için Word dosyayı açın ve sonra bir RTF Dönüştür. Dosya zarar görmüş, bu yöntem başarılı olursa, dönüştürme sırasında kaldırılır.

RTF dosyayı kaydetmek için <a0></a0>, aşağıdaki adımları izleyin:
  1. Dosya menüsünden farklı Kaydet ' i tıklatın.
  2. Biçim liste'ı tıklatın ve sonra Zengin metin biçimi seçin.
  3. Belgenin adını değiştirin. (Böylece özgün, değiştirilmemiş belgeyi kullanarak diğer adımlara devam etmeden bu önerilir.)
  4. Kaydet ' i tıklatın.
RTF dosyası kaydettikten sonra zararı devam ederse, aşağıdaki dosya biçimlerinden birinde dosyayı kaydetmeyi deneyin:
  • Diğer sözcük işleme biçimi
  • Salt metin
Not: salt metin biçiminde bir dosyayı kaydetme, sık sık, hasarı sorunu düzeltir; ancak, tüm biçimlendirme, grafikler ve alan kodları, Mac için Word'de dahil kaybolur Bu yöntem, daha fazla biçimlendirme gerektirir; bu nedenle, bu sorunu gidermek, yalnızca diğer dosya biçimlerine başarısız olduktan sonra kullanın.

Ek bilgiler Visual Basic için zarar for Applications kodu için diğer dosya biçimlerinden dönüştürülen belgeler Mac için Word, Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
184153WD98: VBA kodu başka bir belge biçimine dönüştürme sonra kayıp

Yöntem 2: Yeni bir belgeye son paragraf işareti dışında her şeyi kopyala

Mac için Word'ün son paragraf işareti ile özellikle de bölüm ve stil biçimlendirmesi biçimlendirme çeşitli ilişkilendirir. Her şeyi son paragraf işareti dışındaki dosyasının yeni bir dosyaya kopyalayabilir, vereceği zarar özgün belgede kalabilir.

Son paragraf işareti dışındaki tüm öğeleri kopyalamak için belgede aşağıdaki adımları izleyin:
  1. Tek bir davranış sergiler belgeyi açın.
  2. Düzen menüsünden Tümünü Seç'i tıklatın.
  3. Seçtiğiniz belgeyle, KOMUTU + ÜST KRKT + sol tek yönlü bir tuşa basın. (Bu yalnızca son paragraf işareti seçimden kaldırır.)
  4. Düzen menüsünden Kopyala ' ı seçin.
  5. Dosya menüsünde, Yeni bir belge seçin.
  6. Yeni belgede, Düzen menüsünden Yapıştır ' ni seçin.

    Not: yeni belgede, bölüm biçimlendirmesi veya stil biçimlendirmesini yeniden uygulamanız gerekebilir.

Yöntem 3: bozulmamış bölümleri dosyasının yeni bir dosyaya kopyalayın.

Bazen konumundaki dosyayı arayan veya dosyayı davranış ortaya çıktığında belirlemek için sınama dosyanızda zarar konumunu belirleyebilirsiniz. Hangi alan dosyasının bozuk belirlemek için başka bir zaman veya bir dizi sayfa ya da bir sayfa yeni dosyaya kopyalamak için yoludur. Yeni dosyayı kaydedin ve sonra özgün çalışma biçimine için sınayın. Davranış oluşmazsa, kaydetme ve özgün çalışma biçimine oluşana kadar sınama sayfaları kopyalama devam edin.

Hangi alan dosyasının bozuk fark ederseniz, bozuk bölümünün dışında her şeyi yeni bir dosyaya kopyalayın ve belgeyi yeniden oluşturmak için aşağıdaki adımları izleyin:
  1. Belgenin Bozulmamış bir bölümünü kopyalamak ve bunları (Bu bir paragraf işareti bazı yanlış bilgiler içerebileceğinden, bu seçim, son paragraf işareti seçmek için istemeyebilirsiniz) yeni bir dosyaya yapıştırın.
  2. Bozuk dosyanın bir kopyasını salt metin biçiminde kaydedin.
  3. Salt metin dosyası açın.
  4. Bu dosyadan metni kopyalayın ve dosyanız bozuk bir bölümünü içeren dosyaya yapıştırın.
  5. Adım 4'te yapıştırılan belgenin bölümlerine yeniden biçimlendirmeniz ve kurtarılan belgeyi kaydedin.

Dosyayı Word'de Mac için Cannot açtıysanız

Mac için Word dosyayı açamıyorsanız, aşağıdaki yöntemlerden uygun olanını kullanın.

Yöntem 1: dosyayı boş bir belge ekleyin.

() Son paragraf işareti dışındaki tüm metni kopyalamak için bir dosyayı açamazsa, dosyayı yeni bir belgeye eklemek, mümkün olabilir. Bu düzeltme, dosyanın üzerine yeni bir son paragraf işareti ekler. Bunu yapmak için şu adımları izleyin:
  1. Normal şablonu temel alan yeni bir belge oluşturun.
  2. Ekle menüsünden Dosya ' yı tıklatın. Hasar görmüş belgeyi seçin ve Tamam ' ı tıklatın.

Yöntem 2:, bir bağlantı ile belgeyi açmak için <a0>Yapıştır</a0> bağlantısı komutunu kullanın.

Bu yöntem, bir bağlantı oluşturmak için bir "kukla" Belge kullanır ve sonra "kukla" belge hasar görmüş belgeyi arasındaki bağı geçer.

Bozuk bir belgeyi açmak için bir bağlantı yapıştırma işlemi için şu adımları izleyin:
  1. Mac için Word'ün tüm açık belgeleri kapatmak ve yeni bir boş belge açın.
  2. Sınama türü.
  3. Sınama sözcüğü seçin. Düzen menüsünden Kopyala ' yı tıklatın.
  4. Dosya menüsünde Yeni'yi tıklatın ve yeni bir boş belge açın.
  5. Düzen menüsünden Yapıştır Özel ' i tıklatın. Özel Yapıştır iletişim kutusuna Bağlantı Yapıştır'ı tıklatın. Kutusunda,Biçimlendirilmiş Metin'i (RTF) tıklatın ve sonra Tamam ' ı tıklatın.
  6. Düzen menüsünde Bağlantılar ' ı tıklatın.
  7. Bağlantılar iletişim kutusunda da Kaynağı Değiştir'i tıklatın. iletişim kutusunda bulun ve kurtarmak istediğiniz belgeyi seçin. ' ı tıklatın ve sonra Tamam ' ı tıklatın.
  8. Belgeyi açtığında, Dosya menüsünden farklı Kaydet ' i tıklatın. Belge için yeni bir ad yazın ve sonra da <a2>Kaydet</a2>'i tıklatın.
  9. Belge açık olmadan, Düzen menüsünden Bağlantılar ' ı tıklatın.
  10. Bağlantılar iletişim kutusundaki Bağlantılar Kes'i tıklatın. Görüntülenen iletişim kutusunda bağlantıyı kesmek için Evet ' i tıklatın.
Not: bağlantı bozulur sonra kapatın veya değiştirmeden önce belgeyi kaydetmelisiniz.

Yöntem 3: "Metin, herhangi bir dosyadan kurtarma" kullanarak dosyayı açın...

Son çare olarak, özel "Herhangi bir dosya dan metin Kurtar" dönüştürücüsünü el ile bozuk belgeleri açmak için kullanabilirsiniz. Bu dönüştürücü, tüm biçimlendirme, grafikler ve katıştırılmış nesneler dosyasından kaldırır ve yalnızca okunabilir metin (ASCII karakterleri) bırakır. Belge dosyalarının Mac için Word düzenlenmiş ve kaydedilen biçimi nedeniyle, metni ayrık yinelenmiş veya.

Hatta kolay dosyalarla önemli ölçüde biçimlendirmeden gereklidir. Bu nedenle çok kurtarıldı istenmeyen metin olduğundan daha küçük dosyalar ile bir ikinci yeni bir belge ve kopyayı açın ve kurtarılan belgeyi metin yeni belgeye yapıştırın isteyebilirsiniz.

Bir belgeyi açmak için "Herhangi bir dosya dan metin Kurtar" dönüştürücüsünü kullanmak için aşağıdaki adımları izleyin:
  1. Dosya menüsünden ' ı tıklatın.
  2. Göster listesinde tıklatın ve Dosyadan Metin Kurtar</a1>'ı tıklatın.
  3. Bozuk dosyayı içeren klasörü bulun ve ardından dosyayı seçin.
  4. ' ı tıklatın.
Not: Kurtarma işlemi, belge hasar türüne ve boyutuna bağlı olarak biraz zaman alabilir. Kurtarma işlemi tamamlanır tamamlanmaz, Dosya menüsünden ' ı tıklatın ve sonra Word belgeleri veya Okunabilir dosyaListelenecek dosya türü değiştirin.

IPUCU: Bu noktada kurtarılan dosya'yı yeni bir adla kaydet. Bu, özgün belgeyi yanlışlıkla geçersiz kılmasını engeller ve özgün belgedeki diğer Kurtarma girişimleri için kullanılabilir kalmasını sağlar.

Yöntem 4: Açık olarak Kopyala

Bozuk bir belgeyi bir kopyasını açmak için <a0></a0>, aşağıdaki adımları izleyin:
  1. Tüm açık belgeleri kapatın.
  2. Dosya menüsünden ' ı tıklatın.
  3. Kopyala, açık listeden seçin.
  4. Bozuk dosyayı seçin.
  5. ' ı tıklatın.

Özellikler

Makale numarası: 285393 - Last Review: 29 Ocak 2007 Pazartesi - Gözden geçirme: 2.3
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Office Word 2004 for Mac
  • Microsoft Word X for Macintosh
  • Microsoft Word 2001 for Mac
Anahtar Kelimeler: 
kbmt kbinfo KB285393 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:285393

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com