如何疑難排解在 Word 中的損毀文件為 Mac

文章翻譯 文章翻譯
文章編號: 285393 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文提供您可用來識別為 Mac 損毀的檔案,在 Microsoft Word 中,並在某些情況下復原這類檔案的疑難排解程序。

損毀的文件檔案可能會造成程式出現不尋常的行為。這類問題的發生原因,是因為程式從損毀的檔案接收錯誤的資訊。

其他相關資訊

如何找出損毀的檔案

損毀的檔案經常會造成不屬於程式設計--例如,行為、 無限重新編頁、 不正確的文件版面配置及格式無法讀取的字元螢幕、 處理、 系統停止回應或當您載入或檢視該檔案或任何其他不尋常行為不能是正常操作程式當機期間的錯誤訊息。這些行為也可能被因文件損毀以外的因素。如果要排除其他因素,請依照下列這些疑難排解提示:
  • 檢查有類似的行為在其他文件中。
  • 檢查有類似情況發生在其他程式中。
  • 把有問題檔案拿到另一台電腦,並嘗試重現此行為。
  • 請使用不同的印表機驅動程式,並嘗試重現該行為。若要將不同的印表機驅動程式請依照下列步驟執行:

    1. 選取 選擇 [Apple 功能表上的 []。
    2. 選擇器 中,選取不同的印表機驅動程式],然後關閉 選取程式]。
    3. Mac 的 Word 中, 選取 版面設定] [檔案] 功能表上,以確認您在 [選擇] 中選取的印表機驅動程式在 Word 中選取的 Mac.]
  • 重新命名任何會貼附於文件,然後嘗試重現該行為的範本。
  • 副檔名為關閉,以停用 (例如終止和-保持-常駐程式 [常駐程式]、 字型管理員和螢幕保護程式) 正在執行的任何協力廠商程式一次,啟動電腦。然後嘗試重現該行為。如需有關如何啟動副檔名為關閉電腦的詳細資訊,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的發行項:
    263159如何疑難排解在 Macintosh 上的延伸衝突
如果您執行上述步驟後,問題會發生只與單一文件,是可能已經損毀您的文件。如果關閉檔案,並已啟用 [自動回復] 選項之前,程式意外結束,自動回復 」 檔案可能已建立。您可以使用這個 「 自動回復 」 檔案來修復檔案有問題。

Mac 的 Word 中的 [自動回復] 功能會嘗試自動復原從 Mac 的 Word 停止回應時,已開啟的文件的文字。重新啟動 Word 時為 Mac 之後會停止回應 (擱置),將會顯示對話方塊,並出現下列訊息:
Word 在開啟 檔案名稱 時發現檔案損毀的部分。這份文件的部分可能可以回復。現在嘗試恢復損毀??
注意: 這個復原可能要花一些時間,文件和文件中的損毀的量的大小而定。

復原文件之後立即使用 [另 新檔] 指令在 [檔案] 功能表上儲存文件以新的檔案名稱。這可確保原始的文件會供其他修復嘗試。這個自動復原方法會移除所有的格式設定、 圖形,與文件中的物件。

本文稍後所列其他方法可能會讓您復原多個您的原始格式設定從損毀的文件。

如需有關 「 自動回復 」 功能的詳細資訊,參閱 「 「 不允許損失的 Word,並復原文邪惡件 」 在 Word 中為 Mac 說明

如何修正損毀的文件

有數種技巧,您可以使用來嘗試解決損毀的文件。您使用的方法取決於類型和嚴重性所造成的損害的固定的行為方式類型。雖然這些方法通常有效,可以復原不是每個損毀的文件。保持文件的備份複本是最好的方式以確保其復原。

下列的疑難排解程序分為兩節: < 如果可以在 Word 中為 Mac 開啟檔案"與"如果檔案無法開啟在 Word 中,進行 Mac." 您的情況使用適當的區段。

如果該檔案可以針對 Mac 在 Word 中開啟

如果為 Mac,可以在 Word 中開啟檔案,使用下列的方法之一。

方法 1: 將檔案轉換成另一種格式

將檔案轉換成另一種格式,然後再轉換回原生格式。

這是最簡單也最完整的文件復原方法 ; 請務必先嘗試。將檔案儲存在純文字格式 (RTF)。這種格式會保留在您的 Word Mac 文件的格式設定。 以 RTF 格式儲存檔案後的 Mac,重新開啟在 Word 中的檔案,然後再轉換從 RTF 格式。如果這個方法成功,檔案損毀的部分是在轉換期間移除。

如果要將檔案儲存為 RTF,請依照下列步驟執行:
  1. 在 [檔案] 功能表上按一下 [另存]。
  2. 按一下 [格式] 清單,然後選取 [RTF 格式
  3. 變更文件的名稱。(這被建議,以便使用原始未經修改的文件,可以繼續進行其他步驟)。
  4. 按一下 [儲存]。
如果之後您將檔案儲存為 RTF 格式,持續發生所造成的損害,嘗試將檔案儲存在下列檔案格式之一:
  • 其他文字處理格式
  • 只有文字
注意: 只有文字的格式經常儲存檔案可以改正文損毀的問題 ; 不過,所有格式設定是遺失包括在 Word 中的圖形和欄位代碼的 Mac.這個方法需要更多重新格式化,; 因此,其他檔案格式無法修正問題之後,才使用它。

如其他有關遺失的 Visual Basic 在 Word 中 Mac 會轉換成其他檔案格式的文件的應用程式程式碼,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的發行項:
184153將轉換為另一個文件格式後的 WD98: VBA 程式碼遺失

方法 2: 將最後一個段落之外的任何資料標記到新文件的複製

Mac 的 Word 將相關聯的各種不同的格式設定與最後一個段落標記特別區段和樣式格式。如果您將複製的所有項目在檔案最後的段落標記以外中到新的檔案,損毀部份可能會被留在原始文件。

若要複製最後一個段落標記以外的所有內容在文件在依照下列步驟執行:
  1. 開啟文件,表現異常行為。
  2. 按一下 [編輯] 功能表的 [全選]。
  3. 選取文件按下命令 + SHIFT + 向左方向的索引鍵。(這只有最後一個段落標記會從選取範圍中移除)。
  4. 編輯] 功能表上選取 [複製]。
  5. 在 [檔案] 功能表上, 選取 [新增文件]。
  6. 在新文件選取 [編輯] 功能表上的 [貼上]。

    注意: 在新文件,您可能需要重新套用分節格式或樣式格式。

方法 3: 將檔案未損毀的部分複製到新的檔案

有時您可以在檔案中判斷損害位置藉由查看檔案或測試檔案時,就會發生此問題,判斷。判斷檔案的哪個區域損毀的另一個方法是將任一一頁在一次或一系列的頁面複製到新的檔案。儲存新檔案,然後再測試為原始的行為。如果沒有發生行為,繼續複製分頁,儲存,與測試直到原始的行為發生。

如果您可以找到檔案的哪個區域已損毀,可將損毀的部分以外的所有內容複製到新的檔案,然後再依照下列步驟執行來重建您的文件:
  1. 複製的文件未損毀的部分,並將它們貼到新的檔案 (您可能不想選取此選取範圍的最後段落標記因為該段落標記可能包含一些不正確的資訊)。
  2. 只有文字格式儲存損毀的文件副本。
  3. 開啟僅文字檔案。
  4. 從這個檔案複製文字,然後再將它貼至包含您的檔案未損毀的部分的檔案。
  5. 重新格式化您貼上在步驟 4,文件的區段,然後儲存修復的文件。

如果檔案無法以可開啟在 Word 中為 Mac

如果您不能在 Word 中開啟檔案,為 Mac,視使用下列方法之一。

方法 1: 插入空白的文件中的檔案

如果您無法開啟檔案,以複製所有文字 (除了最後一個段落標記),就可以將檔案插入新的文件。這會插入新的最後一個段落標記,拖曳到您正在修復檔案。要這麼做,請您執行下列步驟:
  1. 建立新文件 Normal 範本為基礎。
  2. 插入] 功能表上按一下 [檔案]。選取損毀的文件,然後按一下 [確定]

方法 2: 使用 [貼上連結] 指令來開啟文件的連結

這個方法會使用 「 空的 」 的文件建立的連結,並切換 「 空的 」 的文件與損毀的文件之間的連結。

請依照下列步驟執行如果要使用貼上連結作業開啟損毀的文件:
  1. 對於 Mac,關閉 Word 中所有開啟的文件,然後開啟新的空白文件。
  2. 型別 測試
  3. 選取單字 測試。在 編輯] 功能表上按一下 [複製]。
  4. 在 [檔案] 功能表上按一下 [新增],然後再開啟新的空白文件]。
  5. 在 [編輯] 功能表上按一下 [選擇性貼上]。在 [選擇性貼上] 對話方塊按一下 [貼上連線]。在 [ 方塊按一下 格式化文字 (RTF),然後按一下 [[確定]
  6. 按一下 [編輯] 功能表 連結
  7. 在 [連結] 對話方塊中,按一下 [變更來源]。在 [開啟舊檔] 對話方塊找出並選取您要復原的文件]。按一下 [開啟],然後按一下 [確定]
  8. 開啟 [文件] 時,按一下 [檔案] 功能表上的 [另存新檔]。輸入文件的新名稱,然後按一下 [儲存檔案
  9. 開啟文件與按一下 [編輯] 功能表上的 [連結]。
  10. 在 [連結] 對話方塊中,按一下 [中斷連結]。在出現此對話方塊,按一下 [是] 中斷連結]。
注意: 連結已中斷之後您就應該儲存文件,關閉它,或修改它之前。

方法 3: 藉由使用 「 從任何檔案復原文字"開啟 [檔案]

最後的方法是: 您可以使用特殊的 「 從 「 任何檔案 」 轉換程式,手動開啟損毀的文件。這個轉換子會移除所有圖形和內嵌的物件從檔案格式,使只可讀取文字 (ASCII 字元)。是由於方式 Mac 文件檔案的 Word 是組織,並且儲存,可能會是 disjointed 或重複的文字。

即使在最簡單檔案相當大的重新格式化是必要的。以較小的檔案您可能想要開啟新的第二個文件和複製並貼入新的文件的已復原的文件中的文字因為有這麼多不想要的文字復原。

如果要使用 「 從 「 任何檔案 」 轉換程式開啟文件,請依照下列步驟執行:
  1. 在 [檔案] 功能表上, 按一下 [開啟舊檔]。
  2. 按一下 [顯示] 清單,然後按一下 [復原文字],從 「 任何檔案
  3. 找出包含損毀的檔案資料夾,然後選取該檔案。
  4. 按一下 [開啟舊檔]。
注意: 的修復程序可能需要根據上文件和類損失的大小一些時間。只要復原已完成,按一下 [檔案] 功能表上的 [開啟舊檔,並回到 Word 文件] 或 [可讀取的檔案 變更 [檔案類型

TIP: 在此時儲存復原的檔案以新名稱。這可防止您意外覆寫原始文件,並確保原始的文件會保持可用的其他修復嘗試。

為複製的方法 4: 開啟

若要開啟 [損毀的文件的複本,請依照下列步驟執行:
  1. 關閉所有開啟的文件。
  2. 按一下 [檔案] 功能表上的 [開啟舊檔]。
  3. 從 [開啟舊檔] 清單中選取 複製
  4. 選取損毀的檔案。
  5. 按一下 [開啟舊檔]。

屬性

文章編號: 285393 - 上次校閱: 2007年1月29日 - 版次: 2.3
這篇文章中的資訊適用於:
  • Microsoft Word 2004 for Mac
  • Microsoft Word X for Macintosh
  • Microsoft Word 2001 for Mac
關鍵字:?
kbmt kbinfo KB285393 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:285393
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com