PowerPoint nemůže načíst doplněk při nižší úroveň zabezpečení maker

Překlady článku Překlady článku
ID článku: 285470 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při nižší úroveň zabezpečení maker v aplikaci PowerPoint a otevřete soubor doplňku PowerPoint (* .ppa), nemusí být použita nová úroveň zabezpečení maker a na soubor může fungovat podle očekávání. Doplněk uveden jako dostupné doplněk v dialogovém okně Doplňky ale zaškrtávací políčko není zaškrtnuto a při pokusu o zaškrtněte políčko se zobrazí chybová zpráva podobná následující:
PowerPoint nemůže načíst doplněk file name.

Příčina

Toto chování může dojít, pokud jsou splněny následující podmínky:
  1. Pokus otevřít soubor doplňku PowerPoint pomocí příkazu Otevřít v nabídce soubor, zatímco úroveň zabezpečení maker nastavena na hodnotu Vysoká.
  2. Nižší nastavení úroveň zabezpečení maker.
  3. Stejný PowerPoint doplněk soubor otevřít pomocí příkazu Otevřít v nabídce soubor.
Při pokusu otevřít soubor doplňku a doplněk není načten z důvodu zabezpečení maker, PowerPoint dočasně ukládá (mezipamětí) selhání načtení informací o toto přidání in. PowerPoint nemůže načíst přidání - v po snížení úrovně zabezpečení maker, dokud ji vymaže informace v mezipaměti.

Jak potíže obejít

Tento problém vyřešit, zrušte informace v mezipaměti a načíst doplněk podle následujících některou z následujících metod po změně nastavení úroveň zabezpečení maker.

Metoda 1: Ukončení a restartování PowerPoint

  1. Ukončení aplikace PowerPoint.
  2. Restartujte PowerPoint.
  3. Otevřete soubor doplňku.
  4. Klepněte na tlačítko "I AGREE" načtení doplňku.

Metoda 2: Odebrat a přidat doplňku

Odebrat a přidat doplněk v aplikaci PowerPoint 2002, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz Doplňky.
  2. V seznamu Doplňky k dispozici klepněte doplněk a potom klepněte na tlačítko Odebrat.
  3. Klepněte na tlačítko Přidat, vyberte doplněk, klepněte na tlačítko OK, klepněte "I AGREE" načíst doplněk a potom klepněte na tlačítko Zavřít.
Chcete-li odebrat doplněk v aplikaci PowerPoint 2007, postupujte takto:
  1. Klepněte na Tlačítko Office, klepněte na tlačítko Možnosti aplikace PowerPoint a potom klepněte na příkaz Doplňky.
  2. V seznamu SpravovatDoplňky PowerPoint vyberte a klepněte na tlačítko Přejít.
  3. Vyberte v seznamu Dostupné doplňky doplněk, který chcete odebrat, klepněte na tlačítko Odebrat a potom klepněte na tlačítko Zavřít.
K přidání doplněk v aplikaci PowerPoint 2007 postupujte takto:
  1. Klepněte na Tlačítko Office, klepněte na tlačítko Možnosti aplikace PowerPoint a potom klepněte na příkaz Doplňky.
  2. V seznamu SpravovatDoplňky PowerPoint klepněte a potom klepněte na tlačítko Přejít.
  3. V dialogovém okně Doplňky klepněte na tlačítko Přidat nový.
  4. V dialogovém okně Nová PowerPoint přidat doplněk vyhledejte doplněk, který chcete přidat a potom klepněte na tlačítko OK.
  5. Zobrazí se upozornění zabezpečení. Pokud jste si jisti, že doplněk pochází z důvěryhodného zdroje, klepněte na tlačítko Povolit makra a klepněte na tlačítko Zavřít.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Postup reprodukce problému

PowerPoint 2007

  1. Spusťte aplikaci PowerPoint 2007.
  2. Na kartě Developer klepněte ve skupině KódZabezpečení maker.
    Poznámka: Ve výchozím nastavení nemusí zobrazit kartu Vývojář. Zobrazit kartu Vývojář, klepněte na Tlačítko Office, klepněte na tlačítko Možnosti aplikace PowerPoint, vyberte Zobrazit kartu Vývojář na pásu pod Nejpoužívanější možnosti pro práci s aplikací PowerPoint a klepněte na tlačítko OK.
  3. Na stránce Centra ve skupinovém rámečku Nastavení maker vyberte Zakázat všechna makra s oznámením a potom klepněte na tlačítko OK.
  4. V nabídce Office klepněte na tlačítko Otevřít.
  5. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte Add-Ins(*.ppam;*.ppa) PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: Doplněk nenačte očekávaným způsobem.
  6. Na kartě Developer klepněte ve skupině KódZabezpečení maker.
  7. Na stránce Centra vyberte Povolit všechna makra (nedoporučuje; spuštění potenciálně nebezpečného kódu) ve skupinovém rámečku Nastavení maker a potom klepněte na tlačítko OK.
  8. V nabídce Office klepněte na tlačítko Otevřít.
  9. V rozevíracím seznamu Typ souboru klepněte na šipku, vyberte Add-Ins(*.ppam;*.ppa) PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: Povolit nebo zakázat makro nejsou vyzváni. Navíc doplněk stále nenačte.

PowerPoint 2002

  1. Spusťte aplikaci PowerPoint.
  2. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz zabezpečení.
  3. Na kartě Úroveň zabezpečení klepněte na tlačítko Vysoká.
  4. V nabídce soubor klepněte na tlačítko Otevřít.
  5. V poli Typ souboru klepněte na šipku, vyberte Doplňky PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: doplněk nenačte očekávaným způsobem.
  6. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz zabezpečení.
  7. Na kartě Úroveň zabezpečeníStřední.
  8. V nabídce soubor klepněte na tlačítko Otevřít.
  9. V poli Typ souboru klepněte na šipku, vyberte Doplňky PowerPoint, vyberte doplněk a potom klepněte na tlačítko Otevřít.

    Poznámka: Při nejsou vyzváni k povolení nebo zakázání makro a doplněk stále nenačte.

Vlastnosti

ID článku: 285470 - Poslední aktualizace: 29. ledna 2007 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Office PowerPoint 2007
Klíčová slova: 
kbmt kbbug kberrmsg kbpending KB285470 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:285470

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com