Article ID: 286199 - Last Review: October 3, 2003 - Revision: 3.2 BUG: Error Message "Transaction Cannot Start in Firehose Mode" Occurs When a Table is Open in SQL Server Enterprise Manager During a Failover
This article was previously published under Q286199
BUG #: 228790 (Shiloh)
SYMPTOMS
When you connect to a Virtual Server and open a table or a view in the SQL Server Enterprise Manager, if a failover occurs the following error message may display when you try to make changes to the data from Enterprise Manager:
Transaction cannot start while in firehose mode.
CAUSE
When you right-click a table, and then click Return all rows, a firehose cursor is opened and only the rows that have been processed are displayed. After the failover occurs and after you reconnect to the virtual server, only a batch of the rows in the table are processed. The error message shown in the "Symptoms" section occurs when an OLE-DB provider attempts to perform a join transaction, with results pending, while not in an updateable cursor mode.
WORKAROUND
To work around this problem, use any one of these methods:
STATUS
Microsoft has confirmed this to be a problem in SQL Server 2000. MORE INFORMATION
If a failover occurs when the result set of a table or view is open, the SQL Server Enterprise Manager displays a message that states that the connection to the SQL Server has been lost. To reconnect to the Virtual Server, click OK. Open a SQL Server pane and try to make updates to the data by using an Update query. After the query runs, the data grid either becomes blank or dimmed. If you close and then reopen the SQL Server Enterprise Manager on the same node, it reflects the update that was made. However, you are not able to make any data changes through the Enterprise Manager by directly entering data into the grid.
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