ACC2002: No Option to Import, Link, or Export to the FoxPro File Type

Article translations Article translations
Article ID: 286224 - View products that this article applies to.
This article was previously published under Q286224
This article has been archived. It is offered "as is" and will no longer be updated.
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies only to a Microsoft Access database (.mdb).

For a Microsoft Access 2000 version of this article, see 225861.
Expand all | Collapse all

On This Page

Symptoms

In the Import, Export, and Link dialog boxes in Microsoft Access 2002, FoxPro is not listed as an option for file type.

Cause

The Microsoft FoxPro ISAM driver is no longer included with Microsoft Access.

Resolution

To import from, link to, and export to Microsoft FoxPro, use the Visual FoxPro ODBC driver, as demonstrated in the following steps.

Import from FoxPro

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, open the ODBC Data Sources (32-bit) tool, and add a new ODBC Data Source for your FoxPro database or tables by selecting the appropriate Microsoft Visual FoxPro driver.
  3. Open the Access database that you want to import into.
  4. On the File menu, point to Get External Data, and then click Import.
  5. In the Import dialog box, click ODBC Databases in the Files of type list.
  6. In the Select Data Source dialog box, select the Visual FoxPro data source that you created in step 2, and then click OK.
  7. In the Import Objects dialog box, select the tables that you want to import, and then click OK.

Link to FoxPro

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, open the ODBC Data Sources (32-bit) tool and add a new ODBC Data Source for your FoxPro database or tables by selecting the appropriate Microsoft Visual FoxPro driver.
  3. Open the Access database that you want to create the link in.
  4. On the File menu, point to Get External Data, and then click Link Tables.
  5. In the Link dialog box, click ODBC Databases in the Files of type list.
  6. In the Select Data Source dialog box, select the Visual FoxPro data source that you created in step 2, and then click OK.
  7. In the Link Tables dialog box, select the tables that you want to import, and then click OK.

Export to FoxPro

  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, open the ODBC Data Sources (32-bit) tool and add a new ODBC Data Source for your FoxPro database or tables by selecting the appropriate Microsoft Visual FoxPro driver.
  3. Open the Access database that you want to export from.
  4. On the File menu, click Export.
  5. In the Export Table 'tablename' To dialog box, click ODBC Databases in the Files of type list.
  6. In the Export dialog box, type the name of the new table, and then click OK.
  7. In the Select Data Source dialog box, select the Visual FoxPro data source that you created in step 2, and then click OK.

More information

Access to FoxPro data through the Microsoft Jet database engine was provided in earlier versions of Microsoft Access and earlier versions of the Microsoft Jet database engine. However, with Access 2002, access to Microsoft FoxPro data is possible only through the Microsoft Visual FoxPro ODBC driver. Access to FoxPro data through the Microsoft Jet database engine is no longer supported.

Steps to Reproduce Behavior

  1. Open any Access database.
  2. On the File menu, point to Get External Data, and then click Import.
  3. In the Import dialog box, click the Files of type list.
Note that FoxPro is not there.

References

For more information about setting up ODBC data sources, click Microsoft Access Help on the Help menu, type set up ODBC data sources in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

For additional information about issues you may encounter when importing, linking, and exporting FoxPro data, please click the article number below to view the article in the Microsoft Knowledge Base:
188401 PRB: ACCESS Cannot Import/Link Table if Index Contains Function

Properties

Article ID: 286224 - Last Review: October 26, 2013 - Revision: 3.0
Applies to
  • Microsoft Access 2002 Standard Edition
Keywords: 
kbnosurvey kbarchive kbprb KB286224

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com