Evento 7009 quando gli utenti provano a inviare o ricevere messaggi di posta elettronica in Exchange Server 2013 o Exchange Server 2016

Numero KB originale: 2866822

Sintomi

Quando un utente tenta di inviare messaggi di posta elettronica in un ambiente Exchange Server 2013 o Microsoft Exchange Server 2016, il messaggio di posta elettronica non viene inviato come previsto. Rimane invece nella cartella Posta in uscita o nella cartella Bozze.

Quando si verifica questo problema, nella cartella Application viene registrato un evento simile al seguente:

Inoltre, le informazioni sull'attività di connessione simili alle seguenti vengono registrate nel log di connettività delle cassette postali. Si noti l'errore "Server non attivo".

2013-06-27T21:08:37.520Z,08D03F2DE58E0D70,MapiSubmission,89294a5c-bf90-4ae2-a3ff-7f2b81b4ba71,+,Exchange-Server.contoso.com
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,+,Undefined 00000000-0000-0000-0000-000000000000;QueueLength=0
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,>,Exchange-Server.contoso[192.168.0.12]
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,>,Established connection to 192.168.0.12
2013-06-27T21:08:37.583Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,-,Messages: 0 Bytes: 0 (Retry : Service not active)

Quando si prova a testare le comunicazioni SMTP usando Telnet, viene visualizzato un errore 412.4.3.2 simile al seguente:

220 Exchange-Server.contoso.comMicrosoft ESMTP MAIL Service ready at Thu, 27 Jun 2013 17:04:17 -0400
ehlo
250-Exchange-Server.contoso.com Hello [fe80::2174:c9da:4ac0:74c2%13]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250-XRDST
250 XSHADOWREQUEST
mail from: user@contoso.com

412 4.3.2 Service not active

Causa

Questo problema si verifica se il servizio trasporto si trova in uno stato inattivo.

In Exchange Server, gli amministratori possono impostare i server in modalità manutenzione. Quando un server è in modalità di manutenzione, si trova in uno stato inattivo e non accetta più connessioni.

Risoluzione

Per risolvere questo problema, impostare il componente Trasporto hub su uno stato attivo. A tal fine, attenersi alla seguente procedura:

  1. Eseguire il seguente cmdlet:

    Set-ServerComponentState -Identity <Exchange_server_name>  -Requester Functional -State active -Component HubTransport
    

    Se il Set-ServerComponentState cmdlet non modifica lo stato del componente in attivo, eseguire il cmdlet seguente:

    Set-ServerComponentState -Identity <Exchange_server_name>  -Requester Maintenance -State Active -Component HubTransport
    
  2. Riavviare il servizio Trasporto Exchange.

Verificare che un server sia inattivo

Per verificare che uno stato del server sia inattivo, eseguire il Get-ServerComponentState cmdlet . L'output di questo cmdlet è simile al seguente:

Screenshot che mostra l'output eseguendo Get-ServerComponentState usando il cmdlet.

Riferimenti