Evento 7009 quando os utilizadores tentam enviar ou receber e-mails no Exchange Server 2013 ou Exchange Server 2016

Número original da BDC: 2866822

Sintomas

Quando um utilizador tenta enviar mensagens de e-mail num ambiente Exchange Server 2013 ou Microsoft Exchange Server 2016, o e-mail não é enviado conforme esperado. Em vez disso, permanece na pasta Caixa de Saída ou na pasta Rascunhos.

Quando este problema ocorre, é registado um evento semelhante ao seguinte na pasta Aplicação:

Além disso, as informações de atividade de ligação que se assemelham ao seguinte são registadas no registo de Conectividade da Caixa de Correio. (Repare no erro "O servidor não está ativo".)

2013-06-27T21:08:37.520Z,08D03F2DE58E0D70,MapiSubmission,89294a5c-bf90-4ae2-a3ff-7f2b81b4ba71,+,Exchange-Server.contoso.com
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,+,Undefined 00000000-0000-0000-0000-000000000000;QueueLength=0
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,>,Exchange-Server.contoso[192.168.0.12]
2013-06-27T21:08:37.536Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,>,Established connection to 192.168.0.12
2013-06-27T21:08:37.583Z,08D03F2DE58E0D71,SMTP,mailboxtransportsubmissioninternalproxy,-,Messages: 0 Bytes: 0 (Retry : Service not active)

Quando tenta testar comunicações SMTP com Telnet, recebe um erro 412.4.3.2 semelhante ao seguinte:

220 Exchange-Server.contoso.comMicrosoft ESMTP MAIL Service ready at Thu, 27 Jun 2013 17:04:17 -0400
ehlo
250-Exchange-Server.contoso.com Hello [fe80::2174:c9da:4ac0:74c2%13]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250-XRDST
250 XSHADOWREQUEST
mail from: user@contoso.com

412 4.3.2 Service not active

Causa

Este problema ocorre se o serviço transporte estiver num estado inativo.

No Exchange Server, os administradores podem colocar servidores no modo de Manutenção. Quando um servidor está no modo de Manutenção, está num estado inativo e já não aceita ligações.

Resolução

Para resolver este problema, defina o componente Transporte do Hub como um estado ativo. Para tal, siga estes passos:

  1. Execute o seguinte cmdlet:

    Set-ServerComponentState -Identity <Exchange_server_name>  -Requester Functional -State active -Component HubTransport
    

    Se o Set-ServerComponentState cmdlet não alterar o estado do componente para ativo, execute o seguinte cmdlet:

    Set-ServerComponentState -Identity <Exchange_server_name>  -Requester Maintenance -State Active -Component HubTransport
    
  2. Reinicie o serviço transporte do Exchange.

Verificar se um servidor está inativo

Para verificar se um servidor está num estado inativo, execute o Get-ServerComponentState cmdlet . O resultado deste cmdlet assemelha-se ao seguinte:

Captura de ecrã a mostrar o resultado ao executar Get-ServerComponentState com o cmdlet .

Referências