Code 31-Fehler in Geräte-Manager für WAN-Miniportgerät (Netzwerkmonitor) unter Windows

Dieser Artikel bietet eine Problemumgehung für ein Problem, bei dem Geräte-Manager neben dem WAN-Miniport (Netzwerkmonitor)-Gerät ein gelbes Ausrufezeichen anzeigt.

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 2871372

Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie installieren Windows.
  • Sie öffnen Geräte-Manager, nachdem die Installation abgeschlossen ist.

In diesem Szenario zeigt Geräte-Manager ein gelbes Ausrufezeichen neben dem WAN-Miniport (Netzwerkmonitor)-Gerät an. Darüber hinaus wird auf der Registerkarte Details des Geräteeigenschaftenfensters die folgende Meldung angezeigt:

Das Gerät funktioniert nicht ordnungsgemäß, da Windows die für dieses Gerät erforderlichen Treiber nicht laden kann. (Code 31)

Ursache

Dieses Problem tritt auf, weil Windows die Treiber, die für das WAN-Gerät (Netzwerkmonitor) erforderlich sind, nicht laden kann. Da dem Gerät kein Treiber zugeordnet ist, kann er nicht aus Geräte-Manager entfernt werden.

Lösung

Um dieses Problem bei zukünftigen Installationen zu vermeiden, müssen Sie Update-2822241 in die Installationsmedien integrieren, die Sie während des Setups verwenden.

Informationen zur Integration eines Hotfixpakets in Installationsmedien mithilfe von Deployment Image Servicing and Management (DISM) finden Sie unter Hinzufügen oder Entfernen von Paketen offline.

Problemumgehung

Wenn Sie das Betriebssystem bereits installiert haben und derzeit auf dem WAN-Miniport (Netzwerkmonitor)-Gerät einen Fehler vom Typ "Code 31" erhalten, führen Sie die folgenden Schritte aus:

  1. Öffnen Sie den Geräte-Manager.
  2. Klicken Sie mit der rechten Maustaste auf das WAN-Miniportgerät (Netzwerkmonitor), und klicken Sie dann auf Treibersoftware aktualisieren.
  3. Klicken Sie auf Computer nach Treibersoftware durchsuchen.
  4. Klicken Sie auf Auswahl aus einer Liste von Gerätetreibern auf meinem Computer zulassen.
  5. Deaktivieren Sie das Kontrollkästchen Kompatible Hardware anzeigen .
  6. Wählen Sie in der Spalte auf der linken Seite Microsoft und in der Spalte auf der rechten Seite Microsoft KM-TEST Loopback Adapter aus.
  7. Klicken Sie im Dialogfeld Treiberwarnung aktualisieren auf Ja , um die Installation dieses Treibers fortzusetzen.
  8. Klicken Sie nach der Installation des Treibers mit der rechten Maustaste auf das Gerät, und klicken Sie dann auf Deinstallieren.
  9. Klicken Sie nach der Deinstallation des Geräts mit der rechten Maustaste auf den Computernamen in Geräte-Manager, und klicken Sie dann auf Nach Hardwareänderungen suchen.
  10. Klicken Sie im Menü Ansicht auf Ausgeblendete Geräte anzeigen. Das WAN-Miniport -Gerät (Netzwerkmonitor) sollte jetzt gestartet werden und kein gelbes Ausrufezeichen mehr daneben haben.