Windows의 WAN 미니포트(네트워크 모니터) 디바이스에 대한 장치 관리자 코드 31 오류

이 문서에서는 장치 관리자 WAN 미니포트(네트워크 모니터) 디바이스 옆에 노란색 느낌표를 표시하는 문제에 대한 해결 방법을 제공합니다.

적용 대상: Windows 10 - 모든 버전, Windows Server 2012 R2
원래 KB 번호: 2871372

증상

다음과 같은 경우를 생각해볼 수 있습니다.

  • Windows를 설치하고 있습니다.
  • 설치가 완료된 후 장치 관리자 엽니다.

이 시나리오에서 장치 관리자 WAN 미니포트(네트워크 모니터) 디바이스 옆에 노란색 느낌표를 표시합니다. 또한 디바이스 속성 창의 세부 정보 탭에는 다음 메시지가 표시됩니다.

Windows에서 이 디바이스에 필요한 드라이버를 로드할 수 없으므로 디바이스가 제대로 작동하지 않습니다. (코드 31)

원인

이 문제는 Windows에서 WAN(네트워크 모니터) 디바이스에 필요한 드라이버를 로드할 수 없기 때문에 발생합니다. 디바이스와 연결된 드라이버가 없으므로 장치 관리자 제거할 수 없습니다.

해결 방법

이후 설치 중에 이 문제를 방지하려면 설치 중에 사용하는 설치 미디어에 업데이트 2822241 통합해야 합니다.

DISM(배포 이미지 서비스 및 관리)을 사용하여 핫픽스 패키지를 설치 미디어에 통합하는 방법에 대한 자세한 내용은 오프라인에서 패키지 추가 또는 제거를 참조하세요.

해결 방법

운영 체제를 이미 설치했으며 현재 WAN 미니포트(네트워크 모니터) 디바이스에서 "코드 31" 오류가 발생하는 경우 다음 단계를 수행합니다.

  1. 장치 관리자 엽니다.
  2. WAN 미니포트(네트워크 모니터) 디바이스를 마우스 오른쪽 단추로 클릭한 다음 드라이버 소프트웨어 업데이트를 클릭합니다.
  3. 내 컴퓨터에서 드라이버 소프트웨어 찾아보기를 클릭합니다.
  4. 내 컴퓨터의 디바이스 드라이버 목록에서 선택하도록 허용을 클릭합니다.
  5. 호환되는 하드웨어 검사 표시 상자를 선택 취소합니다.
  6. 왼쪽 열에서 Microsoft를 선택하고 오른쪽 열에서 Microsoft KM-TEST 루프백 어댑터를 선택합니다.
  7. 드라이버 경고 업데이트 대화 상자에서 예를 클릭하여 이 드라이버를 계속 설치합니다.
  8. 드라이버가 설치되면 디바이스를 마우스 오른쪽 단추로 클릭한 다음 제거를 클릭합니다.
  9. 디바이스를 제거한 후 장치 관리자 컴퓨터 이름을 마우스 오른쪽 단추로 클릭한 다음 하드웨어 변경 내용 검색을 클릭합니다.
  10. 보기 메뉴에서 숨겨진 디바이스 표시를 클릭합니다. 이제 WAN 미니포트(네트워크 모니터) 디바이스가 시작되고 더 이상 옆에 노란색 느낌표가 없습니다.