Il connettore Service Manager per Configuration Manager non trasferisce le informazioni software disinstallate
Questo articolo consente di risolvere un problema in cui il connettore Service Manager per Configuration Manager non rimuove una relazione installata dal software anche se il software viene disinstallato.
Versione originale del prodotto: System Center 2016 Service Manager, System Center 2012 R2 Service Manager, System Center 2012 Service Manager, Configuration Manager (current branch), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Numero KB originale: 2874780
Sintomi
Il software installato nei computer viene portato a Microsoft System Center Service Manager tramite il connettore Configuration Manager. Tuttavia, quando si disinstalla il software da un computer e quindi si esegue un inventario hardware in Configuration Manager, la relazione installata dal software non viene rimossa in Service Manager anche se la relazione viene rimossa correttamente in Configuration Manager.
Causa
Il connettore Service Manager da Configuration Manager usa record di eliminazione software per rimuovere la relazione installata dal software. Tuttavia, una modifica introdotta in System Center 2012 Configuration Manager SP1 impedisce la scrittura di questi record di eliminazione.
Risoluzione
Per risolvere questo problema, riabilitare i trigger che scrivono i record di eliminazione in Configuration Manager. Il connettore Service Manager sarà quindi in grado di riconoscere ed eseguire correttamente l'azione associata per rimuovere la relazione installata dal software.
A tale scopo, usare la stored procedure descritta in Come abilitare e disabilitare le viste di estrazione.
Commenti e suggerimenti
https://aka.ms/ContentUserFeedback.
Presto disponibile: Nel corso del 2024 verranno gradualmente disattivati i problemi di GitHub come meccanismo di feedback per il contenuto e ciò verrà sostituito con un nuovo sistema di feedback. Per altre informazioni, vedereInvia e visualizza il feedback per