Article ID: 287625 - View products that this article applies to.
This article was previously published under Q287625
For a Microsoft Outlook 2000 version of this article, see 197025.
For a Microsoft Outlook 98 version of this article, see 179431.
Expand all | Collapse all

On This Page

Summary

Microsoft Outlook supports vCalendar, a powerful approach to electronic Personal Data Interchange (PDI). PDI occurs every time individuals communicate, in either a business or personal context. These interchanges frequently include the exchange of information, such as business cards, telephone numbers, addresses, dates and times of appointments, and such. The vCard and vCalendar features facilitate PDI electronically.

More information

vCalendar files are used to exchange information about appointments and schedules with others who are not in your workgroup or organization. You can also use them to schedule appointments with those who use scheduling software incompatible with yours.

How to Create a vCalendar File

To create a vCalendar file, follow these steps.

In Microsoft Office Outlook 2007 and earlier versions

  1. In a Calendar folder, click to select an appointment for which you want a vCalendar file.
  2. On the File menu, click Save As.
  3. In the Save as type box, click to select vCalendar Format (*.vcs).
  4. In the Save In box, click the folder where you want to save the vCalendar file, and then click Save.

In Microsoft Outlook 2013 and Microsoft Outlook 2010

  1. In a Calendar folder, click to select an appointment for which you want a vCalendar file.
  2. Click the File tab, on the Backstage, click Save As.
  3. In the Save as type list, click vCalendar Format (*.vcs).
  4. In the Save In list, click the folder where you want to save the vCalendar file, and then click Save.

How to Distribute a vCalendar File

You can distribute a vCard file like other computer files. To send it as an e-mail attachment, follow these steps.

In Outlook 2007 and earlier versions

  1. Open a new e-mail message, and then address it to the recipient.
  2. On the Insert menu, click File.
  3. Click to select a vCalendar (.vcs) file, and then click OK.

In Outlook 2013 and Outlook 2010

  1. Open a new e-mail message, and then address it to the recipient.
  2. On the Insert tab, click Attach File.
  3. Click to select a vCalendar (.vcs) file, and then click Insert.

How to Automatically Process a vCalendar File

With Outlook, you can automatically convert a vCalendar file received from an external source into an Outlook appointment entry. If the vCalendar file arrives as an e-mail attachment, you can double-click the vCalendar, then click Save And Close to add the appointment to your default Calendar folder.

If you receive the vCalendar in the form of a file, perhaps on a disk, you can import it into your default Calendar folder by using the Outlook Import and Export Wizard. To do this:

In Outlook 2007 and earlier versions

  1. On the File menu, click Import and Export.
  2. Click to select Import an iCalendar or vCalendar file (*.vcs), and then click Next.
  3. Click to select the vCalendar file, and then click Open.

In Outlook 2010

  1. On the File tab, click Open, and then click Import.
  2. Click to select Import an iCalendar (.ics) or vCalendar file (.vcs), and then click Next.
  3. Click to select the vCalendar file, and then click OK.

In Outlook 2013

  1. On the File tab, click Open & Export, and then click Import/Export.
  2. Click to select Import an iCalendar (.ics) or vCalendar file (.vcs), and then click Next.
  3. Click to select the vCalendar file, and then click OK.

How to Manually Process a vCalendar File As a Text File

A vCalendar record is just a text file. If you do not have an automated facility to process vCalendar records, you can open them with a text editor and use the information. The content of a vCalendar file varies with the information inserted by the file creator, but a typical file created from an Outlook appointment looks like the following example in a text editor:
BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook MIMEDIR//EN
VERSION:1.0
BEGIN:VEVENT
DTSTART:19980114T210000Z
DTEND:19980114T230000Z
LOCATION:My office
CATEGORIES:Business
DESCRIPTION;ENCODING=QUOTED-PRINTABLE:This is a note associated with the
meeting=0D=0A
SUMMARY:Meeting to discuss salaries
PRIORITY:3
END:VEVENT
END:VCALENDAR
				
NOTE: The DTSTART and DTEND entries are a combination of the date and time in the format, YYYYMMDDThhmmssZ, where YYYY=year, MM=month, DD=day of the month, T=start time character, hh=hour, mm=minutes, ss=seconds, Z=end character. This string expresses the time as Greenwich Mean Time (GMT), on a 24-hour clock so must be adjusted to your time zone.

For example, if you are in the Central Time zone, your time is 6 hours behind GMT. So, you would subtract 6 hours from the start and end times to derive the correct time range for the appointment. In the previous appointment example, the start time would be 210000-060000 or 150000 on the 24-hour clock. If you converted the time to A.M or P.M, the start time is 150000-120000 or 3:00 P.M.

IMPORTANT: For more information about how Microsoft provides support for public protocols, click the following article number to view the article in the Microsoft Knowledge Base:
2269506 Developer support limitations for public protocols

Properties

Article ID: 287625 - Last Review: April 26, 2013 - Revision: 6.0
Applies to
  • Microsoft Outlook 2013
  • Microsoft Outlook 2010
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2010 Enterprise
Keywords: 
kbcalendar kbhowto KB287625

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com