Outlook の使用時にエラー メッセージ "このコンピュータのルールは、Exchange Server のルールと異なります" が表示される

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文書番号: 287640 - 対象製品
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目次

現象

Microsoft Outlook の使用時に、次のエラー メッセージが表示されることがあります。
このコンピュータのルールは、Exchange Server のルールと異なります。保存できるルールは、どちらか片方に限られます。通常はサーバーのルールを保存してください。保存したい方のルールを選択してください。
このエラー メッセージ ボックスを閉じるためのオプションは、[クライアント]、[サーバー]、および [キャンセル] のみです。

原因

この問題は、以下の条件のいずれかに該当する場合に発生することがあります。

2 台の Outlook コンピュータが同じ Microsoft Exchange Server メールボックスに接続されている

2 台のコンピュータが同じ Exchange Server メールボックスに接続されている場合、一方のコンピュータからサーバー上のルールを更新するように各プロファイルを構成している可能性があります。

次のシナリオで、この状況について説明します。

コンピュータ W (職場のコンピュータ)
  1. Exchange Server から個人用フォルダ (.pst) ファイルにメッセージを配信するプロファイルを作成します。
  2. "PST サブフォルダ" (引用符は含まれません) という電子メール フォルダを新しく作成します。
  3. 次のルールを作成します。

    状態 : 件名に "PST" が含まれている
    処理 : "PST サブフォルダ" フォルダに移動する
  4. このルールが正しく機能することを確認します。
  5. Outlook を終了します。
コンピュータ H (自宅のコンピュータ)
  1. 同じ Exchange Server アカウントからメールボックスにメッセージを配信するプロファイルを作成します。
  2. このプロファイルを使用して Outlook を起動します。
  3. [ツール] メニューの [自動仕訳ウィザード] をクリックします。ルールが無効になっていることに注意してください。これは、このルールが .pst ファイルを使用するコンピュータのみに適用されるためです。
  4. 自動仕訳ウィザードで [キャンセル] をクリックします。
  5. Outlook を終了します。
コンピュータ W

  1. Outlook を起動します。
  2. 「現象」に記載されているエラー メッセージ ダイアログ ボックスが表示されます。
ダイアログ ボックスの提示に従って [サーバー] をクリックした場合、今まで使用していたルールは失われます。この動作は、Exchange Server メールボックスに関連付けられたルール (このシナリオでは存在しません) によって、個人用フォルダ (.pst) ファイルに関連付けられたルールが置き換えられることが原因で発生します。このシナリオでは、"クライアント" のルールを保存することを選択する必要があります。

異なるバージョンの Outlook が同じ Exchange Server メールボックスに接続している

この資料の「現象」に記載されているエラー メッセージは、Outlook 2002 以降と、それ以前のバージョンの Microsoft Outlook の両方から同じ Exchange Server メールボックスにアクセスした場合にも発生することがあります。Outlook 2002 と Microsoft Outlook 2000 から同じ Exchange Server メールボックスにアクセスした場合の例を次に示します。

コンピュータ A (Outlook 2000 を実行)

  1. Exchange Server サービスを使用してプロファイルを作成し、デフォルトの配信場所を Exchange Server メールボックスにします。
  2. ルールを作成して正しく機能するかどうかを確認します。
コンピュータ B (Outlook 2002 を実行)

  1. コンピュータ A で指定したものと同じ Exchange Server を使用してプロファイルを作成します。デフォルトの配信場所は Exchange Server メールボックスのままにします。
  2. Outlook 2002 を起動します。
  3. 「現象」に記載されているエラー メッセージ ダイアログ ボックスが表示されます。
Outlook 2002 コンピュータで [サーバー] を選択した場合、Outlook 2000 コンピュータで同じエラー メッセージが表示されることがあります。

解決方法

この問題を解決するには、次のいずれかの方法を使用します。
  1. サーバー側のルールまたはクライアント側のルールを保存することを選択します。
  2. 引き続きエラー メッセージが表示される場合は、すべてのルールを削除して再インポートすることが必要な場合があります。
  3. MDBVu を使用して、すべてのルールを削除し、再インポートします。

サーバー側のルールまたはクライアント側のルールを保存する

サーバー側のルールとクライアント側のルールのうち、多く使用されている方を選択する必要があります。たとえば、メッセージを Exchange Server メールボックスに格納している場合は、サーバー側のルールの方が多く使用されています。メッセージを個人用フォルダに格納している場合は、クライアント側のルールの方が多く使用されています。どちらを使用するのかを決定した後、正しく機能するようにいくつかのルールを再調整することが必要になる場合があります。

ルールを削除して再インポートする方法

この手順を実行する前に、ルールを後でインポートできるように .RWZ ファイルにエクスポートします。これを行うには、次の手順を実行します。
  1. Outlook で、[ツール] メニューの [自動仕訳ウィザード] をクリックします。
  2. [オプション] をクリックします。
  3. [ルールをエクスポート] をクリックします。
  4. .RWZ ファイルの保存先に移動し、覚えやすいファイル名を付けた後、[保存] をクリックします。
  5. [OK] を 2 回クリックします。
ルールをエクスポートしたら、次の手順を使用して、すべてのルールを削除した後、前の手順でエクスポートした .RWZ ファイルからそれらのルールをインポートします。
  1. Outlook で、[ツール] メニューの [自動仕訳ウィザード] をクリックします。
  2. [自動仕訳ウィザード] ダイアログ ボックスで、ルールをクリックし、[削除] をクリックします。
  3. 残っているルールがなくなるまで手順 2. を繰り返します。
  4. Outlook を終了して再起動します。
  5. Outlook で、[ツール] メニューの [自動仕訳ウィザード] をクリックします。
  6. [オプション] をクリックします。
  7. [ルールをインポート] をクリックします。
  8. ルールをエクスポートした .RWZ ファイルを見つけ、[開く] をクリックします。
  9. ルールが正しく構成されていることを確認します。
  10. [OK] をクリックします。

MDBVu を使用してルールを削除し、再インポートする方法

この手順を実行する前に、ルールを後でインポートできるように .RWZ ファイルにエクスポートしてください。次の手順に従い、MDBVu を使用してメールボックスのルールを削除します。
  1. Mdbvu32.exe ファイルをダブルクリックし、プロファイルを選択するように求めるダイアログ ボックスが表示されたら、適切なプロファイルを選択します。
  2. [MAPILogonEX(MAPI_LOGON_UI)] ダイアログ ボックスで、[OK] をクリックします。
  3. [MDB Viewer Test Application] ダイアログ ボックスで、[MDB] メニューの [OpenMessageStore] をクリックします。
  4. [メールボックス] をクリックし、[Open] をクリックします。
  5. [MDB Viewer Test Application] ダイアログ ボックスで、[MDB] メニューの [Open Root Folder] をクリックします。
  6. [MAPI_Folder - Root] ダイアログ ボックスで、[Child Folders] ボックスの一覧の [Top of Information Store] をダブルクリックします。
  7. [MAPI_Folder - Top of Information Store] ダイアログ ボックスで、[Child Folders] ボックスの一覧の [Inbox] をダブルクリックします。
  8. [MAPI_FOLDER - Inbox] ダイアログ ボックスで、[Associated Messages in Fld] ボックスの一覧の [RulesOrganizer] をクリックします。

    : [RulesOrganizer] をダブルクリックしないようにしてください。
  9. [Operations available] の一覧で、[IpFld->DeleteMessaes()(ON SELECTED MSGS)] をクリックし、[Call Function] をクリックします。確認ウィンドウが表示されたら、[OK] をクリックします。
  10. 上記の手順を続行しますが、RulesOrganizer は削除せず、"cb: 40|*pb:" (引用符は含まれません) で始まる各アイテムを確認します。これらのアイテムをダブルクリックし、次の行があるかどうかを確認します。
    PR_MESSAGE_CLASS PT_STRING8 IPM.RULE.MESSAGE
    各アイテムにはメッセージ クラスが含まれていますが、ここで必要な部分は IPM.RULE.MESSAGE です。IPM.RULE.MESSAGE が含まれているアイテムをすべて削除します。
  11. [MDB Viewer] ボックスに戻るまで [Close] をクリックします。
  12. [Session] メニューの [Exit] をクリックします。
  13. 表示されるすべてのダイアログ ボックスで [OK] をクリックします。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

ルールの横に "クライアント ルール" (引用符は含まれません) と表示されている場合、そのルールで指定された処理を実行するには、クライアントがログオンしている必要があります (たとえば、"音で知らせる" という処理は、クライアントがログオンしていない場合は機能しません)。一方、サーバー側のルールで指定された処理は、クライアントがログオンしていなくても実行できます。たとえば、別のフォルダにアイテムを移動する処理 (移動先のフォルダが個人用フォルダ内にある場合は除きます) などがあります。クライアント ルールは、サーバーにも格納されます。これらのルールは、クライアントがログオンしているかどうかにかかわらず、サーバーの受信トレイにメッセージが届いたときに評価されます。処理を実行するにはユーザーが接続している必要があることが確認された場合、サーバーで遅延処理メッセージが作成され、クライアントの次回ログオン時にそのメッセージがクライアントにダウンロードされ、ペイロードがクライアントに配信されます。

関連情報

Mdbvu32.exe ファイルは、Exchange Server 5.5 CD の Support\Utils\I386 ディレクトリにあります。

プロパティ

文書番号: 287640 - 最終更新日: 2007年2月28日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard Edition
キーワード:?
kbhowto kbbug kberrmsg kbpending KB287640
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