Client Access server crashes when you use Outlook in cached mode together with a Riverbed Steelhead WAN optimizer in an Exchange Server 2010 environment

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Article ID: 2878175 - View products that this article applies to.
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Symptoms

When you use Microsoft Outlook together with a Riverbed Steelhead WAN optimizer in a Microsoft Exchange Server 2010 environment, the Client Access server crashes. When this issue occurs, users cannot connect to the Exchange server. Additionally, one of the following events is logged many times in the Application log on the Client Access server:

Time:     Date
ID:       4999
Level:    Error
Source: MSExchange Common
Machine:  Computer
Message:  Watson report about to be sent for process id: ProcessID, with parameters: E12, BuildType, VersionNumber, M.E.RpcClientAccess.Service, unknown, M.E.D.S.M.F.Enumerator.MoveNext, System.InvalidOperationException, xxxx, unknown.
ErrorReportingEnabled: False.

Time:     Date
Event ID: 4999
Level:    Error
Source: MSExchange Common
Machine:  Computer
Message: Watson report about to be sent for process id: ProcessID, with parameters: E12, BuildType, VersionNumber, M.E.RpcClientAccess.Service, M.E.Data.Storage, M.E.D.S.CoreFolder.SetItemStatus, System.ArgumentOutOfRangeException, xxxx, VersionNumber.

Cause

This issue occurs because the MAPI cached mode accelerator in the Riverbed Steelhead WAN optimizer does not correctly accelerate the fast transfer copy command. Then, the Microsoft Exchange RPC Client Access service (Microsoft.Exchange.RpcClientAccess.Service.exe) crashes on the Client Access server.

Resolution

To resolve this issue, enable MAPI skip-copy on client-side and server-side Riverbed Steelhead devices. To do this, enter the following commands at the system prompt: 
Steelhead > enable
Steelhead # config term
Steelhead (config) # protocol mapi skip-copy enable
Note This command will disable acceleration for MAPI fast transfer copy commands without affecting other accelerators.

More information

For more information about the RPC Client Access service, go to the following Microsoft website:
General information about RPC Client Access service
Third-party information disclaimer

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The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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Properties

Article ID: 2878175 - Last Review: December 27, 2013 - Revision: 4.0
Applies to
Keywords: 
kbqfe kbfix kbsurveynew kbexpertiseinter KB2878175

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