Comment créer un classeur de macros personnelles dans Excel pour Mac

Traductions disponibles Traductions disponibles
Numéro d'article: 288117 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article explique comment créer un classeur de macros personnelles pour l'écriture et la modification de macros Microsoft Visual Basic pour Applications (VBA) que vous ne pouvez pas enregistrer.

Plus d'informations

Procédure pour créer un classeur de macros personnelles

Le moyen le plus simple de créer un classeur de macros personnelles est d'enregistrer une macro "factice". Exécutez les procédures pour cela :
  1. Démarrez Excel de sorte que seul un nouveau classeur soit ouvert. Dans le menu Outils, pointez sur Macro et puis cliquez sur Nouvelle macro.
  2. Dans la boîte de dialogue Enregistrer une macro, cliquez sur classeur de macros personnelles dans la liste Enregistrer la macro.
  3. Cliquez sur OK. La macro étant "factice", ne cliquez sur rien et ne tapez rien.
  4. Dans la barre d'outils qui apparaît, cliquez sur <B>Arrêter l'enregistrement</B>.
  5. Dans le menu Excel, cliquez sur Quitter. Pour des versions antérieures qu'Excel X d'Excel, cliquez sur Quitter dans le menu Fichier.
  6. Cliquez sur <B>Enregistrer</B> quand le système vous invite à enregistrer vos modifications.
Lorsque vous démarrez Excel, ce classeur de macros personnelles s'ouvre en tant que classeur masqué. Il est par défaut stocké dans le chemin d'accès suivant selon votre version d'Excel.

Dans Excel 98 et dans Excel 2001
:Office:Startup:Excel:Personal classeur Macros Microsoft Office
Dans Excel X ou versions ultérieures
:Applications:Microsoft :Office:Startup:Excel:Personal de version Office classeur Macros disque dur

Procédure pour utiliser un classeur de macros personnelles

Pour écrire ou pour modifier le code VBA dans un classeur de macros personnelles, procédez comme suit :
  1. Dans le menu Outils, pointez sur Macro et ensuite cliquez sur Visual Basic Editor.
  2. Dans la fenêtre "Projet - Projet VBA", double-cliquez sur <B>Projet VBA (Classeur de macros personnelles)</B> pour afficher le dossier <B>Modules</B> qu'il contient.
  3. Double-cliquez sur le dossier <B>Modules</B> pour afficher les modules de ce projet et double-cliquez sur un module pour afficher son code ou une feuille de code vierge.

    Vous pouvez utiliser cette feuille de code pour écrire et pour modifier le code VBA.

Propriétés

Numéro d'article: 288117 - Dernière mise à jour: mercredi 31 janvier 2007 - Version: 3.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Mac
  • Microsoft Excel 98 for Macintosh
Mots-clés : 
kbdtacode kbhowto KB288117 KbMtfr kbmt
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que feraient une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique. Si vous relevez des erreurs graves et souhaitez contribuer à l?amélioration du système, vous pouvez compléter l?enquête à votre disposition dans le bas des articles.
La version anglaise de cet article est la suivante: 288117
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com