如何为 Mac 在 Excel 中创建一个个人宏工作簿

文章翻译 文章翻译
文章编号: 288117 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文介绍如何编写和编辑您不能录制的应用程序 (VBA) 宏 Microsoft Visual Basic 中创建一个个人宏工作簿。

更多信息

如何创建一个个人宏工作簿

若要录制一个"虚拟"的宏是最简单的方法创建一个个人宏工作簿。若要这样做,请按照下列步骤操作:
  1. 启动 Excel,以便只是一个新的工作簿处于打开状态。在 工具 菜单上指向 ,然后单击 录制新宏
  2. 录制宏 对话框中单击在 将宏保存在 列表中的 个人宏工作簿
  3. 单击 确定。因为创建的"虚拟"宏不要单击或键入任何内容。
  4. 在显示的工具栏中单击 停止录制 按钮。
  5. Excel 菜单上单击 退出。或版本的 Excel 早于 Excel X,单击 退出,文件 菜单上。
  6. 当系统提示您保存所做的更改,请单击 保存
当您启动 Excel 时,该个人宏工作簿打开为隐藏的工作簿。默认状态下,它存储在下面的路径取决于您的 Excel 版本。

在 Excel 98 中,并在 Excel 2001
Microsoft Office folder: 办公室: 启动: Excel: 个人宏工作簿
在 Excel X 或更高版本中
Hard disk drive: 应用程序: Microsoft Office version:Office:Startup:Excel:Personal 宏工作簿

如何使用一个个人宏工作簿

若要编写或编辑一个个人宏工作簿中的 VBA 代码,请按照下列步骤操作:
  1. 工具 菜单上指向 ,然后单击 Visual Basic 编辑器
  2. 在项目-VBA 项目窗口中双击 VBAProject (个人宏工作簿) 以显示 模块 文件夹中。
  3. 双击要显示此的项目中的所有模块 模块 文件夹,双击一个模块,以都显示其代码或为空的代码页。

    使用此代码页,可以编写和编辑 VBA 代码。

属性

文章编号: 288117 - 最后修改: 2007年1月31日 - 修订: 3.4
这篇文章中的信息适用于:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Mac
  • Microsoft Excel 98 for Macintosh
关键字:?
kbmt kbdtacode kbhowto KB288117 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 288117
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com