如何在 Excel 中建立個人的巨集活頁簿為 Mac

文章翻譯 文章翻譯
文章編號: 288117 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文將告訴您,如何建立個人的巨集活頁簿的撰寫和編輯 Microsoft Visual Basic 應用程式 (VBA) 無法錄製的巨集。

其他相關資訊

如何建立個人的巨集活頁簿

建立個人的巨集活頁簿最簡單的方法,就是記錄 「 空的 」 巨集。要這麼做,請您執行下列步驟:
  1. 啟動 Excel,使其只新的活頁簿已開啟。在 [工具] 功能表上指向 [巨集],然後再按一下 [錄製新巨集
  2. 錄製巨集] 對話方塊按一下 [將巨集儲存在 清單中的 [個人巨集活頁簿]。
  3. 按一下 [確定]。因為您正在建立 「 空的 」 巨集,請勿按一下或輸入任何內容。
  4. 在出現工具列按一下 [停止錄製] 按鈕。
  5. 按一下 [Excel] 功能表 結束。或版本的 Excel 早於 Excel X,按一下 [檔案] 功能表上的 [結束
  6. 當系統提示您儲存所做的變更時,請按一下 [儲存]。
當您啟動 Excel 時,這個個人巨集活頁簿,開啟為隱藏的活頁簿。預設情況下,它會儲存在下列路徑根據您的 Excel 版本中。

在 Excel 98 和 Excel 2001
Microsoft Office folder: 辦公室: 啟動: Excel: 個人巨集活頁簿
在 Excel X 或更新版本中
Hard disk drive: 應用程式: Microsoft Office version:Office:Startup:Excel:Personal 巨集活頁簿

如何使用個人的巨集活頁簿

撰寫或編輯個人巨集活頁簿中的 VBA 程式碼,請依照下列步驟執行:
  1. 在 [工具] 功能表上指向 [巨集,然後按一下 [Visual Basic 編輯器]。
  2. 在 [A 專案-VBA 專案"] 視窗中,按兩下 VBAProject (個人巨集活頁簿) 以顯示 [模組] 資料夾內。
  3. 連按兩下要顯示的任何模組在這個專案中的 [模組] 資料夾,連按兩下以顯示其程式碼或空的程式碼的工作表模組。

    您可以使用這個程式碼] 頁來撰寫和編輯 VBA 程式碼。

屬性

文章編號: 288117 - 上次校閱: 2007年1月31日 - 版次: 3.4
這篇文章中的資訊適用於:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Macintosh
  • Microsoft Excel 98 for Macintosh
關鍵字:?
kbmt kbdtacode kbhowto KB288117 KbMtzh
機器翻譯
重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,而非使用人工翻譯而成。Microsoft 同時提供使用者人工翻譯及機器翻譯兩個版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,機器翻譯的文章可能不盡完美。這些文章中也可能出現拼字、語意或文法上的錯誤,就像外國人在使用本國語言時可能發生的錯誤。Microsoft 不為內容的翻譯錯誤或客戶對該內容的使用所產生的任何錯誤或損害負責。Microsoft也同時將不斷地就機器翻譯軟體進行更新。
按一下這裡查看此文章的英文版本:288117
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com