Adreslijstsynchronisatie naar Microsoft Entra ID stopt of u krijgt een waarschuwing dat synchronisatie niet meer dan een dag is geregistreerd

In dit artikel wordt een prestatieprobleem in azure Active Directory Sync Tool beschreven. Het hulpprogramma stopt met synchroniseren of meldt dat de synchronisatie al meer dan 24 uur niet is uitgevoerd.

Oorspronkelijke productversie: Microsoft Entra ID, Microsoft Intune, Azure Backup, Office 365 Identity Management
Origineel KB-nummer: 2882421

Opmerking

Was dit artikel nuttig? Uw inbreng is belangrijk voor ons. Gebruik de knop Feedback op deze pagina om ons te laten weten hoe goed dit artikel voor u heeft gewerkt of hoe we het kunnen verbeteren.

Symptomen

U ondervindt een van de volgende symptomen:

  • De Microsoft Azure Active Directory-synchronisatie wordt niet meer gesynchroniseerd.
  • U ontvangt e-mailberichten waarin staat dat Microsoft Entra ID de afgelopen 24 uur geen synchronisatiepoging hebt geregistreerd.
  • In het MIISClient.exe hulpprogramma ontvangt u een bericht 'Stopped-Server-Down' of 'Stopped-Extension-DLL-Exception'.
  • U kunt een of meer adreslijstsynchronisatieservices niet starten.

Opmerking

Adreslijstsynchronisatie wordt standaard elke drie uur uitgevoerd.

Oorzaak

Dit probleem kan optreden als aan een of meer van de volgende voorwaarden wordt voldaan:

  • Het werk- of schoolaccount dat in de configuratiewizard is gebruikt om adreslijstsynchronisatie in te stellen, heeft een van de volgende problemen:

    • Het account is verwijderd.
    • Het account is uitgeschakeld.
    • Het accountwachtwoord is verlopen.
  • Het aanmeldingsaccount voor een of meer adreslijstsynchronisatieservices heeft een van de volgende problemen:

    • Het account is verwijderd.
    • Het account is uitgeschakeld.
    • Het accountwachtwoord is verlopen.

    Opmerking

    Het aanmeldingsaccount voor de adreslijstsynchronisatieservice wordt automatisch geconfigureerd en mag niet worden gewijzigd.

  • Het beheerdersaccount dat wordt gebruikt voor adreslijstsynchronisatie, is gewijzigd.

  • U hebt problemen met de netwerkverbinding.

  • Adreslijstsynchronisatieservices zijn gestopt.

Oplossing

Methode 1: Handmatig controleren of de service is gestart en of het beheerdersaccount zich kan aanmelden

  1. Selecteer Start, selecteer Uitvoeren, typ Services.msc en selecteer vervolgens OK.

  2. Zoek de Microsoft Entra synchronisatieapparaatservice en controleer of de service is gestart. Als de service niet is gestart, klikt u er met de rechtermuisknop op en selecteert u Start.

    • Als u het hulpprogramma Azure Active Directory-synchronisatie gebruikt, zoekt u naar Azure Active Directory Sync Service.
    • Als u Microsoft Entra Connect gebruikt, zoekt u naar Microsoft Azure AD Sync.
  3. Controleer of het beheerdersaccount dat wordt gebruikt voor adreslijstsynchronisatie nog steeds bestaat. En controleer of het account zich mag aanmelden. Als het account nog bestaat, stelt u het wachtwoord opnieuw in en controleert u of u zich kunt aanmelden. Als u hierom wordt gevraagd, wijzigt u het wachtwoord.

    Als u niet weet welk globale beheerdersaccount wordt gebruikt voor het configureren van adreslijstsynchronisatie, volgt u deze stappen op de server waarop u het apparaat voor adreslijstsynchronisatie hebt geïnstalleerd:

    1. Ga naar %ProgramFiles%\Microsoft Azure AD Sync\UIShell\en voer Miisclient.exe uit.

      Opmerking

      Als u Microsoft Entra Connect of de Azure Active Directory-synchronisatieservice gebruikt, selecteert u Start en zoekt u synchronisatieservice en opent u deze.

    2. Selecteer Connectors en dubbelklik vervolgens op de Microsoft Entra-connector.

    3. Selecteer Connectiviteit.

    4. Noteer de waarde UserName . Het is het globale beheerdersaccount dat wordt gebruikt voor het configureren van adreslijstsynchronisatie.

  4. Voer op de adreslijstsynchronisatieserver de configuratiewizard Microsoft Entra synchronisatieapparaat uit. Typ het nieuwe wachtwoord voor het beheerdersaccount dat wordt gebruikt voor adreslijstsynchronisatie en volg de resterende stappen in de wizard.

  5. Wanneer u hierom wordt gevraagd, schakelt u het selectievakje Adreslijstsynchronisatie afdwingen in.

Methode 2: Het probleem met het aanmeldingsaccount voor de adreslijstsynchronisatieservice oplossen

  1. Selecteer Start, selecteer Uitvoeren, typ Services.msc en selecteer vervolgens OK.

  2. Zoek de Microsoft Entra synchronisatieapparaatservice:

    • Als u het hulpprogramma Azure Active Directory-synchronisatie gebruikt, zoekt u naar Azure Active Directory Sync Service.
    • Als u Microsoft Entra Connect gebruikt, zoekt u naar Microsoft Azure AD Sync. Klik met de rechtermuisknop op de service en selecteer vervolgens Eigenschappen. Noteer op het tabblad Aanmelden de accountnaam die wordt vermeld.

    Opmerking

    Het opnieuw configureren van een van de adreslijstsynchronisatieservices om u aan te melden als een lokaal systeemaccount wordt niet ondersteund en kan problemen veroorzaken.

  3. Open op een domeincontroller of een computer waarop de Beheerhulpprogramma's zijn geïnstalleerd Active Directory: gebruikers en computers (Dsa.msc), klik met de rechtermuisknop op de domeinnaam en selecteer vervolgens Zoeken. Typ de naam van het account dat u in stap 2 hebt genoteerd en selecteer vervolgens Nu zoeken.

    • Als u het account hebt gevonden, gaat u naar stap 4.
    • Als u het account niet kunt vinden, is het mogelijk verwijderd. Zie Stapsgewijze handleiding voor De Prullenbak van Active Directory voor meer informatie over het herstellen van dit account. Als u het account niet kunt herstellen, moet u de adreslijstsynchronisatieclient verwijderen en opnieuw installeren.
  4. Klik met de rechtermuisknop op het account en selecteer vervolgens Eigenschappen. Voer op het tabblad Account onder Accountopties de volgende stappen uit:

    1. Zorg ervoor dat het selectievakje Wachtwoord verloopt nooit is ingeschakeld.
    2. Zorg ervoor dat het selectievakje Account is uitgeschakeld is uitgeschakeld. Voer vervolgens een van de volgende acties uit:
    • Als het selectievakje Account is uitgeschakeld is ingeschakeld, schakelt u dit uit om het account in te schakelen. Start vervolgens de Microsoft Entra synchronisatieapparaatservice opnieuw. Selecteer hiervoor Start, selecteer Uitvoeren, typ Services.msc en selecteer vervolgens OK. Zoek de service, klik er met de rechtermuisknop op en selecteer opnieuw opstarten.
      • Als u het hulpprogramma Azure Active Directory-synchronisatie gebruikt, zoekt u naar Azure Active Directory Sync Service.
      • Als u Microsoft Entra Connect gebruikt, zoekt u naar Microsoft Azure AD Sync.
    • Als het selectievakje Account is uitgeschakeld al is uitgeschakeld, gaat u naar stap 5.
  5. Als het selectievakje Account is uitgeschakeld al is uitgeschakeld, is het mogelijk dat het wachtwoord voor het account handmatig is gewijzigd. Als u een nieuw wachtwoord wilt instellen, opent u Active Directory: gebruikers en computers, klikt u met de rechtermuisknop op het account en selecteert u vervolgens Wachtwoord opnieuw instellen om het wachtwoord opnieuw in te stellen. Noteer het wachtwoord dat u hebt ingesteld, omdat u dit in de volgende stap moet gebruiken.

  6. Stel het wachtwoord in voor het aanmeldingsaccount voor de adreslijstsynchronisatieservices:

    1. selecteer Start, selecteer Uitvoeren, typ Services.msc en selecteer vervolgens OK.

    2. Stel het wachtwoord in voor de volgende services, afhankelijk van de client die u gebruikt. Klik hiervoor met de rechtermuisknop op de juiste service, selecteer Eigenschappen, selecteer het tabblad Aanmelden en typ het wachtwoord.

      Microsoft Entra synchronisatieclient Microsoft Entra Connect

      Forefront Identity Manager Synchronization Service
      SQL Server (MOSONLINE) (indien aanwezig)
      Azure Active Directory-synchronisatieservice

      Azure AD Sync
    3. Start de service of services waarvoor u het nieuwe wachtwoord hebt ingesteld.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.