Como mover uma folha de macro para outra Excel para a pasta de trabalho Mac

Traduções deste artigo Traduções deste artigo
ID do artigo: 288400 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sumário

Este artigo descreve como mover corretamente uma folha de macro para outra pasta de trabalho do Excel para que a nova folha de macro funcionem como antes.

Se você mover uma folha de macro de uma pasta de trabalho para outro, você também deve redefinir todas as macros na nova pasta de trabalho. Se você remover a folha de macro da pasta de trabalho original, você deve remover também a definição de macro na pasta de trabalho original, antes da transferência.

Mais Informações

Para mover uma folha de macro de uma pasta de trabalho do Excel para outra, siga estas etapas.

Observação : O método a seguir descreve como mover a folha de macro e removê-lo da pasta de trabalho original. Se você deseja copiar a folha de macro em ambas as pastas de trabalho, ignore as etapas 4 e 5 e deixe as definições da pasta de trabalho existente. Na etapa 6, clique para Selecionar a caixa de seleção criar uma cópia . Em seguida, use as etapas 7 a 10 para definir cada macro na nova pasta de trabalho.
  1. No Excel, abra a pasta de trabalho ao qual você deseja mover a folha de macro, ou abra uma nova pasta de trabalho.
  2. Abra a pasta de trabalho que contém a folha de macro que você deseja mover.
  3. Selecione a folha de macro que você deseja mover.
  4. No menu Inserir , aponte para nome e, em seguida, clique em Definir .
  5. Para cada nome na pasta de trabalho que define uma macro, selecione o nome e clique em Excluir . Clique em OK para fechar a caixa de diálogo.
  6. No menu Editar , clique em mover ou copiar . Na lista para catálogo , clique em pasta de trabalho de destino. Clique para desmarcar a caixa de seleção criar uma cópia e, em seguida, clique em OK .
  7. Na nova localidade de folha de macro, selecione um nome de macro ou selecione a célula superior em uma macro. No menu Inserir , aponte para nome e, em seguida, clique em Definir .
  8. Na caixa nomes na pasta de trabalho , o nome selecionado aparecerá ou você pode digitar um nome.

    A caixa refere-se a exibe a célula selecionada é a primeira célula na macro.
  9. Em macro , clique em comando . Clique em Adicionar e, em seguida, clique em OK .
  10. Repita as etapas 7 a 9 para cada macro na planilha de macro.

    Se você usar um botão para executar uma macro, reatribua no botão para o novo local de macro. Para fazer isso, mantenha o controle, clique no botão ou objeto e clique em Atribuir Macro no menu de atalho. Procure o nome da macro e clique duas vezes esse novo local de macro para reatribuir o botão para esse local.
  11. Salve cada uma das pastas de trabalho alteradas.

Propriedades

ID do artigo: 288400 - Última revisão: quarta-feira, 31 de janeiro de 2007 - Revisão: 2.5
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel 2001 para Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 98 for Macintosh
Palavras-chave: 
kbmt kbdtacode kbhowto KB288400 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 288400

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com