Jak přesunout modulu kódu jiného Excel sešit Mac

Překlady článku Překlady článku
ID článku: 288401 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Souhrn

Tento článek popisuje, jak přesunout Microsoft Visual Basic pro kód (VBA) z jednoho sešitu do jiného.

Další informace

Pokud chcete přesunout do jiného sešitu kódu nemůžete přesunout jako listu. Místo toho musíte zkopírovat kód z modulu původní sešit a vložit kód modul v jiném sešitu.

Přesunout do jiné aplikace Excel sešit Mac kódu, postupujte takto:
  1. Otevřete sešit obsahující makro modul, který chcete přesunout.
  2. Otevřete sešit, který chcete přesunout kód nebo otevřete nový sešit.
  3. V nabídce Nástroje přejděte na příkaz makro a klepněte na příkaz Editor jazyka.
  4. V okně Project vyberte projekt (sešit), ve kterém chcete umístit modulu maker. Pokud okno Project není zobrazen, klepněte v nabídce ZobrazitProhlížeč projektu.

    Poznámka: V Microsoft Excel X pro Mac a novější verze nelze zavřít okno Project a není k dispozici v nabídce Zobrazit.
  5. V nabídce Vložit klepněte na modul.
  6. V okně projektu poklepejte na projekt, který obsahuje existující makro.
  7. Ve skupinovém rámečku projektu poklepejte na složku moduly a potom poklepejte na modul níže otevřete okno Kód modulu.
  8. Vyberte všechny kód v modulu existující a stisknutím kláves COMMAND + C.
  9. V nabídce okno klepněte na nový modul, který jste vytvořili v kroku 5. Klepněte dovnitř okno kód a stiskněte klávesu COMMAND + V vložte zkopírovaný kód do tento nový list modulu.
  10. Chcete-li odstranit původní modul vyberte modul původní v okně Project; v nabídce soubor klepněte na tlačítko Odebrat modul a po zobrazení výzvy, klepněte na tlačítko Ano odstraníte modulu.
  11. Pokud existují další moduly, opakujte kroky 4-10 kopírovat, vložit a (volitelně) z původního projektu odebrat těchto modulech.
  12. V nabídce soubor (je nabídky Excel v Excel X pro Mac a pozdější verze) klepněte na tlačítko Zavřít se vrátíte do aplikace Excel pro Mac. Uložte oba sešity.
Pokud tlačítko nebo objekt je přiřazen původní makro spustit a přesunut kód přeřadit tlačítko nebo objekt na nové umístění makro. Chcete-li to provést, podržte klávesu CTRL, klepněte na tlačítko nebo objekt a v místní nabídce klepněte na příkaz Přiřadit makro. Vyhledejte název makra a poklepejte na nové umístění makro změnit přiřazení tlačítko do daného umístění.

Vlastnosti

ID článku: 288401 - Poslední aktualizace: 3. února 2014 - Revize: 3.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X pro počítače Macintosh
  • Microsoft Excel 2001 pro počítače Macintosh
  • Microsoft Excel 98 pro počítače Macintosh
Klíčová slova: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:288401

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com