Cómo mover el código del módulo a Excel otro para Mac libro

Seleccione idioma Seleccione idioma
Id. de artículo: 288401 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Resumen

En este artículo se describe cómo mover Microsoft Visual Basic para aplicaciones (VBA) de un libro a otro.

Más información

Si desea mover el código de VBA a un libro diferente, no podrá moverlo directamente como una hoja de cálculo. En su lugar, debe copiar el código desde el módulo en el libro original y, a continuación, pegue el código a un módulo en el otro libro.

Para mover el código de VBA a una diferente de Microsoft Excel para Mac libro, siga estos pasos:
  1. Abra el libro que contiene el módulo de macro que desea mover.
  2. Abra el libro al que desea mover el código o abra un nuevo libro.
  3. En el menú Herramientas , elija macro y, a continuación, haga clic en Editor de Visual Basic.
  4. En la ventana proyecto, seleccione el proyecto (libro) en el que desea colocar el módulo de macro. Si no está visible la ventana proyecto, haga clic en Explorador de proyectos en el menú Ver .

    Nota En Microsoft Excel X para Mac y versión posterior, no se puede cerrar la ventana proyecto y no está disponible en el menú Ver .
  5. En el menú Insertar , haga clic en módulo .
  6. En la ventana proyecto, haga doble clic en el proyecto que contiene la macro existente.
  7. En el proyecto, haga doble clic en la carpeta módulos y haga doble clic en el módulo siguiente para abrir la ventana de código para ese módulo.
  8. Seleccione todo el código en el módulo existente y presione CTRL + C para copiarlo.
  9. En el menú ventana , haga clic en el nuevo módulo que creó en el paso 5. Haga clic en dentro de esa ventana de código y presione CTRL + V para pegar el código copiado en esta nueva hoja de módulo.
  10. Si desea quitar el módulo original, seleccione el módulo original en la ventana proyecto; haga clic en Quitar módulo en el menú archivo y, cuando se le pida, haga clic en para eliminar el módulo.
  11. Si no hay módulos adicionales, repita los pasos 4-10, copiar, pegar y (opcionalmente) elimine dichos módulos del proyecto original.
  12. En el menú archivo (éste es el menú Excel en Excel X para Mac y versiones posteriores), haga clic en Cerrar para volver a Excel para Mac. Guarde ambos libros.
Si un botón o el objeto se asigna para ejecutar la macro original y ha movido el código, reasignar botón u objeto a la nueva ubicación de macro. Para ello, mantenga presionada la tecla CONTROL, haga clic en el botón u objeto y, a continuación, haga clic en Asignar Macro en el menú contextual. Busque el nombre de la macro y haga doble clic que nueva ubicación de macro para reasignar el botón para esa ubicación.

Propiedades

Id. de artículo: 288401 - Última revisión: sábado, 01 de febrero de 2014 - Versión: 3.4
La información de este artículo se refiere a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Macintosh
  • Microsoft Excel 98 para Macintosh
Palabras clave: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 288401

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com