Comment déplacer le code de module vers un autre Excel pour le classeur Mac

Traductions disponibles Traductions disponibles
Numéro d'article: 288401 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Résumé

Cet article explique comment déplacer du code Microsoft Visual Basic pour Applications (VBA) d'un classeur dans un autre

Plus d'informations

Si vous souhaitez déplacer du code VBA dans un autre classeur vous ne pouvez pas le déplacer directement comme une feuille de calcul Au lieu de cela vous devez copier le code à partir du module dans le classeur d'origine puis le coller dans un module dans l'autre classeur

Pour déplacer le code VBA vers un Microsoft Excel différent pour classeur Mac, procédez comme suit :
  1. Ouvrez le classeur qui contient le module de macro à déplacer
  2. Ouvrez le classeur dans lequel vous souhaitez déplacer le code ou ouvrez un nouveau classeur
  3. Dans le menu Outils, pointez sur Macro et ensuite cliquez sur Visual Basic Editor.
  4. Dans la fenêtre Projet sélectionnez le projet (classeur) dans lequel vous voulez placer le module de macro Si la fenêtre Projet n'est pas visible, cliquez sur Explorateur de projets dans le menu Affichage.

    Remarque In Microsoft Excel X pour Mac, version ultérieure, la fenêtre de Projet ne peut pas être fermé et il n'est pas disponible dans le menu Affichage.
  5. Dans le menu Insertion, cliquez sur Module.
  6. Dans la fenêtre Projet double-cliquez sur le projet qui contient la macro existante
  7. Sous le projet double-cliquez sur le dossier <B>Modules</B> puis double-cliquez sur le module au-dessous pour ouvrir la fenêtre de code de ce module
  8. Sélectionnez tout le code dans le module existant et appuyez sur COMMANDE+C pour le copier
  9. Dans le menu <B>Affichage</B> cliquez sur le nouveau module créé à l'étape 5 Cliquez à l'intérieur de cette fenêtre de code et appuyez sur COMMANDE+V pour coller le code copié dans cette nouvelle feuille de module
  10. Si vous souhaitez supprimer le module d'origine sélectionnez-le dans la fenêtre Projet cliquez sur <B>Supprimer le module</B> dans le menu <B>Fichier</B> et répondez <B>Oui</B> au message de confirmation
  11. S'il y a d'autres modules répétez les étapes 4 à 10 pour copier coller et (le cas échéant) supprimer ces modules du projet d'origine
  12. Le menu sur Fichier (cela est le menu Excel dans Excel X pour Mac et des versions ultérieures) vous cliquez sur Fermer pour revenir pour Mac à Excel. Enregistrez les deux classeurs
Si un bouton ou un objet est affecté à l'exécution de la macro d'origine et que vous avez déplacé le code réaffectez le bouton ou l'objet au nouvel emplacement de la macro Pour cela, maintenez la touche CONTRÔLE enfoncée, cliquez sur le bouton ou l'objet, puis cliquez sur <B>Affecter une macro</B> dans le menu contextuel. Recherchez le nom de la macro et double-cliquez sur son nouvel emplacement pour réaffecter le bouton à cet emplacement.

Propriétés

Numéro d'article: 288401 - Dernière mise à jour: mardi 4 février 2014 - Version: 3.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Mac
  • Microsoft Excel 98 for Macintosh
Mots-clés : 
kbnosurvey kbarchive kbinfo KB288401 KbMtfr kbmt
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que feraient une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique. Si vous relevez des erreurs graves et souhaitez contribuer à l?amélioration du système, vous pouvez compléter l?enquête à votre disposition dans le bas des articles.
La version anglaise de cet article est la suivante: 288401
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com