Come spostare il codice di modulo in un altro Excel per Mac cartella di lavoro

Traduzione articoli Traduzione articoli
Identificativo articolo: 288401 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
Espandi tutto | Chiudi tutto

Sommario

In questo articolo viene descritto come spostare Microsoft Visual Basic, Applications Edition (VBA) codice da una cartella di lavoro a un altro.

Informazioni

Se si desidera spostare il codice VBA a una diversa cartella di lavoro, non è possibile spostarlo direttamente come un foglio di lavoro. Invece, è necessario copiare il codice del modulo nella cartella di lavoro originale e quindi incollare il codice a un modulo in altra cartella di lavoro.

Per spostare codice VBA in una cartella di lavoro di Mac diverse di Microsoft Excel, attenersi alla seguente procedura:
  1. Aprire la cartella di lavoro contiene il modulo macro che si desidera spostare.
  2. Aprire la cartella di lavoro a cui spostare il codice, oppure aprire una nuova cartella di lavoro.
  3. Scegliere macro dal menu Strumenti , quindi Visual Basic Editor.
  4. Nella finestra progetto, selezionare il progetto (cartella di lavoro) che in cui si desidera inserire il modulo macro. Se la finestra di Project non è visibile, scegliere Gestione progetti dal menu Visualizza .

    Nota In Microsoft Excel X per Mac e versione successiva, nella finestra progetto non può essere chiuso e non è disponibile dal menu Visualizza .
  5. Scegliere modulo dal menu Inserisci .
  6. Nella finestra progetto, fare doppio clic sul progetto che contiene la macro esistente.
  7. Sotto il progetto, fare doppio clic sulla cartella moduli e quindi fare doppio clic su del modulo seguente per aprire la finestra del codice per tale modulo.
  8. Selezionare tutto il codice nel modulo esistente e premere comando + C per copiarlo.
  9. Dal menu finestra , selezionare il nuovo modulo creato nel passaggio 5. Fare clic all'interno di tale finestra di codice e premere Comando + V per incollare il codice copiato in questo nuovo foglio di modulo.
  10. Se si desidera rimuovere il modulo originale, selezionare il modulo originale nella finestra progetto, fare clic su Rimuovi modulo dal menu file e quando richiesto, fare clic su per eliminare il modulo.
  11. Se esistono altri moduli, è necessario ripetere i passaggi da 4 a 10 per copiare, incollare e, facoltativamente, rimuovere tali moduli dal progetto originale.
  12. Dal menu file (si tratta del menu di Excel in Excel X per Mac e versioni successive), fare clic su Chiudi per tornare a Excel per Mac. Salvare entrambe le cartelle di lavoro.
Se è assegnato un pulsante o di un oggetto per eseguire la macro originale e avere spostato il codice, riassegnare il pulsante o l'oggetto nella nuova posizione della macro. Per effettuare questa operazione, tenere premuto CTRL, fare clic sul pulsante o sull'oggetto e quindi scegliere Assegna Macro dal menu di scelta rapida. Cercare il nome della macro e fare doppio clic su tale posizione macro nuova per riassegnare il pulsante per tale posizione.

Proprietà

Identificativo articolo: 288401 - Ultima modifica: giovedì 30 gennaio 2014 - Revisione: 3.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X per Mac
  • Microsoft Excel 2001 per Mac
  • Microsoft Excel 98 per Macintosh
Chiavi: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 288401
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com