Como mover o código do módulo para outro Excel para Mac livro

Traduções de Artigos Traduções de Artigos
Artigo: 288401 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Sumário

Este artigo descreve como mover o Microsoft Visual Basic para código Applications (VBA) de um livro para outra.

Mais Informação

Se pretender mover o código VBA para outro livro, não é possível movê-lo directamente como uma folha de cálculo. Em vez disso, tem de copiar o código do módulo no livro original e, em seguida, cole o código a um módulo do livro.

Para mover o código VBA para uma diferente Microsoft Excel para Mac livro, siga estes passos:
  1. Abra o livro que contém o módulo de macro que pretende mover.
  2. Abra o livro ao qual pretende mover o código ou abrir um livro novo.
  3. No menu Ferramentas , aponte para macro e, em seguida, clique em Editor do Visual Basic.
  4. Na janela Project, seleccione o projecto (livro) na qual pretende colocar o módulo de macro. Se a janela Project não estiver visível, clique em Project Explorer no menu Ver .

    Nota No Microsoft Excel X para Mac e versão posterior, a janela Project não pode ser fechada e não está disponível no menu Ver .
  5. No menu Inserir , clique em módulo .
  6. Na janela Project, clique duas vezes o projecto que contém a macro existente.
  7. No projecto, faça duplo clique na pasta módulos e faça duplo clique em módulo existente abaixo para abrir a janela código nesse módulo.
  8. Seleccione todo o código no módulo existente e prima COMMAND + C para o copiar.
  9. No menu janela , clique em novo módulo que criou no passo 5. Clique no interior dessa janela de código e prima COMMAND + V para colar o código copiado nesta nova folha de módulo.
  10. Se pretender remover o módulo original, seleccione o módulo original na janela Project; clique em Remover do módulo no menu ficheiro e, quando for pedido, clique em Sim para eliminar o módulo.
  11. Se existirem módulos adicionais, repita os passos 4 a 10 para copiar, colar e (opcionalmente) remover esses módulos do projecto original.
  12. No menu ficheiro (isto é o menu do Excel no Excel X para Mac e versões posteriores), clique em Fechar para regressar ao Excel para Mac. Guarde ambos os livros.
Se um botão ou objecto é atribuído para executar a macro original e moveu o código, reatribua o botão ou objecto para a nova localização de macro. Para efectuar este procedimento, premida a tecla CONTROL, clique no botão ou objecto e, em seguida, clique em Atribuir Macro no menu de atalho. Procure o nome da macro e faça duplo clique nessa localização macro nova para reatribuir o botão para essa localização.

Propriedades

Artigo: 288401 - Última revisão: 13 de fevereiro de 2014 - Revisão: 3.4
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Macintosh
  • Microsoft Excel 98 para Macintosh
Palavras-chave: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 288401

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com