Como mover o código do módulo para outro Excel para a pasta de trabalho Mac

Traduções deste artigo Traduções deste artigo
ID do artigo: 288401 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sumário

Este artigo descreve como mover o Microsoft Visual Basic para código Applications (VBA) de uma pasta de trabalho para outro.

Mais Informações

Se você deseja mover o código do VBA para uma pasta de trabalho diferente, você não pode movê-lo diretamente como uma planilha. Em vez disso, você deve copiar o código do módulo na pasta de trabalho original e, em seguida, cole o código a um módulo na outra pasta de trabalho.

Para mover o código do VBA para um diferente do Microsoft Excel para a pasta de trabalho Mac, execute estas etapas:
  1. Abra a pasta de trabalho que contém o módulo de macro que você deseja mover.
  2. Abra a pasta de trabalho ao qual você deseja mover o código, ou abra uma nova pasta de trabalho.
  3. No menu Ferramentas , aponte para macro e, em seguida, clique em Visual Basic Editor.
  4. Na janela Project, selecione o projeto (pasta de trabalho) na qual você deseja colocar o módulo de macro. Se a janela de projeto não estiver visível, clique em Project Explorer no menu Exibir .

    Observação No Microsoft Excel X para Mac e versão posterior, a janela de projeto não pode ser fechada e não está disponível no menu Exibir .
  5. No menu Inserir , clique em módulo .
  6. Na janela Project, clique duas vezes o projeto que contém a macro existente.
  7. Em projeto, clique duas vezes na pasta de módulos e em seguida, clique duas vezes o módulo abaixo para abrir a janela de código para esse módulo.
  8. Selecione todo o código no módulo existente e pressione COMMAND + C para copiá-lo.
  9. No menu janela , clique no novo módulo que você criou na etapa 5. Clique dentro dessa janela de código e pressione COMMAND + V para colar o código copiado nessa nova folha de módulo.
  10. Se você quiser remover o módulo original, selecione o módulo original na janela projeto; clique em Remover módulo no menu arquivo e, quando você for solicitado, clique em Sim para excluir o módulo.
  11. Se houver módulos adicionais, repita as etapas 4 a 10 para copiar, colar e (opcionalmente) remover esses módulos do projeto original.
  12. No menu arquivo (esse é o menu Excel no Excel X para Mac e versões posteriores), clique em Fechar para retornar ao Excel para Mac. Salve ambas as pastas de trabalho.
Se um botão ou objeto é atribuído para executar a macro original e você moveu o código, reatribua o botão ou objeto para o novo local de macro. Para fazer isso, mantenha o controle, clique no botão ou objeto e clique em Atribuir Macro no menu de atalho. Procure o nome da macro e clique duas vezes esse novo local de macro para reatribuir o botão para esse local.

Propriedades

ID do artigo: 288401 - Última revisão: quarta-feira, 23 de outubro de 2013 - Revisão: 3.4
A informação contida neste artigo aplica-se a:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X para Macintosh
  • Microsoft Excel 2001 para Mac
  • Microsoft Excel 98 for Macintosh
Palavras-chave: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 288401

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com