Modül kodu başka bir Excel Mac çalışma kitabında taşıma

Makale çevirileri Makale çevirileri
Makale numarası: 288401 - Bu makalenin geçerli olduğu ürünleri görün.
Bu makale arşivlenmiştir. "Olduğu gibi" sunulmaktadır ve bundan sonra güncelleştirilmeyecektir.
Hepsini aç | Hepsini kapa

Özet

Bu makalede, Microsoft Visual Basic for Applications (VBA) kodunu bir çalışma kitabından diğerine taşımak açıklamaktadır.

Daha fazla bilgi

VBA kodunu farklı bir çalışma kitabına taşımak istiyorsanız, doğrudan çalışma sayfası gibi taşınamıyor. Bunun yerine, kodu modüle özgün çalışma kitabına kopyalamak ve başka bir çalışma kitabında kodu bir modüle yapıştırın gerekir.

Mac çalışma kitabında farklı bir Microsoft Excel VBA kodu taşımak için aşağıdaki adımları izleyin:
  1. Taşımak istediğiniz bir makro modülü içeren çalışma kitabını açın.
  2. Kodu taşımak istediğiniz çalışma kitabını açın veya yeni bir çalışma kitabını açın.
  3. Araçlar menüsünden, makro seçin ve'ı sonra Visual Basic Düzenleyicisi'ni tıklatın .
  4. Proje penceresinde makro modülü koymak istediğiniz proje (çalışma kitabı) seçin. Proje penceresi görünmüyorsa, Görünüm menüsünde Project Explorer ' ı tıklatın.

    Not Microsoft Excel X Mac ve sonraki bir sürümünü, proje penceresi kapatılamıyor ve Görünüm menüsünde kullanılamaz.
  5. Ekle menüsünden modülü ' nü tıklatın.
  6. Proje penceresinde varolan bir makroyu içeren proje çift tıklatın.
  7. Projenin altında modülleri klasörü çift tıklatın ve bu modül için kod penceresi açmak için aşağıdaki modülü</a5>'ni çift tıklatın.
  8. Tüm kod varolan modülünde seçmek ve kopyalamak için COMMAND + C tuşlarına basın.
  9. Pencere menüsünde 5. adımda oluşturduğunuz yeni modüle'ı tıklatın. Bu kod pencerenin içini tıklatın ve kopyalanan kodu bu yeni modül sayfasına yapıştırmak için COMMAND + V tuşlarına basın.
  10. Özgün modül kaldırmak isterseniz, özgün modül proje penceresinde seçin; Dosya menüsünde Modülü Kaldır'ı tıklatın ve istendiğinde, modül silmek için Evet ' i tıklatın.
  11. Ek modülleri varsa, 4-10 kopyalama, yapıştırma ve (isteğe bağlı) bu modüllerde, özgün projeden kaldırmak için adımları yineleyin.
  12. Dosya menüsünde (Mac ve sonraki sürümler için Excel X, Excel menü budur), Mac için Excel'e dönmek için Kapat ' ı tıklatın Her iki çalışma kitabı olarak kaydedin.
Düğme veya nesnenin yeni makro konumuna özgün makroyu çalıştırmak için bir düğme veya nesneye atanan ve kod taşınmış, yeniden atama. Bunu yapmak için <a0></a0>, CTRL basılı tutun, sonra da düğme veya nesneyi tıklatın ve sonra da kısayol menüsünde Makro Ata'yı tıklatın. Makro adı arayın ve bu konum için düğmeyi yeniden atamak için yeni makro konumu çift tıklatın.

Özellikler

Makale numarası: 288401 - Last Review: 1 Şubat 2014 Cumartesi - Gözden geçirme: 3.4
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Excel 2001 for Macintosh
  • Microsoft Excel 98 for Macintosh
Anahtar Kelimeler: 
kbnosurvey kbarchive kbmt kbinfo KB288401 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:288401

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com